+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19

Thread: Computer freezes for a few seconds at a time

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Posts
    4

    Default Computer freezes for a few seconds at a time

    It -seems- like this started happening after Saturday's patch, but I can't say that for sure. My computer (even when alt-tabbed with Rift running in the background) will randomly freeze for a few seconds at a time. Everything will 'catch' up once it returns to normal. This happens every fifteen seconds or so, and is making it very hard to play the game.

    Vista 64bit, service pack 1
    AMD Phenom 9750 Quad-Core Processor 2.4 GHz
    8 GB RAM
    ATI Radeon HD 3650

  2. #2
    Soulwalker
    Join Date
    Feb 2011
    Posts
    4

    Default

    Bump!

    I am now also getting a black screen during the freeze, but then everything goes back to normal.

  3. #3
    Soulwalker
    Join Date
    Sep 2010
    Posts
    13

    Default

    Running Win 7 Pro. AMD Phenom II X4 and a ATI 3860 and have the same issue... I feel ya!!

  4. #4
    Soulwalker
    Join Date
    Jan 2011
    Posts
    15

    Default

    I get these too. Sometimes they go black and return. other times the client just freezes and the error handler sends a report and logs me back in. it seems to happen 1-2 times an hour and doesn't seem to be an overheating issue or anything I'm doing wrong.

  5. #5
    Soulwalker
    Join Date
    Feb 2011
    Posts
    7

    Default

    I'm getting a black screen for a couple of seconds. Happens a few times in a row then eventually stops.
    Running Windows 7 64-bit, ATI Radeon HD 5870

  6. #6
    Rift Disciple Barabas's Avatar
    Join Date
    Dec 2010
    Location
    Chicago
    Posts
    131

    Default

    hd 5770
    intel i7 q 740 1.73 ghz
    6 gb ram
    win 7 64 bit

    Game runs well but at times will lock up for seconds at a time. Ive noticed it happens at rifts right before the stage anouncement flashes, in warfronts often when targeting or switching targeting etc.

  7. #7
    Shadowlander
    Join Date
    Feb 2011
    Posts
    26

    Default

    There is a Fix... At least it seemed to work for me. What appears to be happening is the ATI GPU DeadLock protection is being triggered. Which you can disable (but will have to re-disable on each restart)

    Instructions for Win 7 because it's what I'm running and can not verify how to do it else where.

    Start -> In the search bar type "Verifier" -> Display Information About Currently Verified Drivers -> Add -> For the filename type "amdkmdap" -> Open -> Change -> Uncheck DeadLock Detection -> Ok -> Next -> Next -> Finish

    Hope this helps.

    Intel 2.6 Dual Core (not core2)
    2GB Ram
    ATI 3850
    SB Audigy 2
    Windows Pro 7

    I also used driver sweeper to get rid of my old drivers and reinstalled the 11.2 drivers.

  8. #8
    Rho
    Rho is offline
    Soulwalker Rho's Avatar
    Join Date
    Feb 2011
    Posts
    1

    Default

    I can confirm having similar problems.
    Observations:
    - Frozen Screen for a few seconds up to crash
    - Black screen for a few seconds up to a minute or so.
    - Frequency: random, about every 20mins
    - Returns in about 90% to normal after 10s or so.
    - sometimes windows reports graphics driver has stopped working.
    - Internet connection DSL 16MBit, Latency ~60ms, fps ~45.
    - Problems basically stay the same if I turn graphic settings from high to low.

    PC configuration:
    AMD HD5570
    Intel Core 2 DUO 3800
    OS Win 7 Ultimate

    I have this issues with no other software including World of Warcraft
    It started with Headstart, not sure about Open Beta, but for sure this was not happening in the last 2 closed betas.

    If this stays it is for sure not possible to play in a grp/raid. It already makes the game quite difficult to play. If I cannot solve it I am forced to stop playing.
    Last edited by Rho; 02-27-2011 at 11:41 AM.

  9. #9
    Rift Disciple Barabas's Avatar
    Join Date
    Dec 2010
    Location
    Chicago
    Posts
    131

    Default

    Thanks, I will try it. Can you explain what ATI GPU deadlock protection is ?

    Quote Originally Posted by Mytheral View Post
    There is a Fix... At least it seemed to work for me. What appears to be happening is the ATI GPU DeadLock protection is being triggered. Which you can disable (but will have to re-disable on each restart)

    Instructions for Win 7 because it's what I'm running and can not verify how to do it else where.

    Start -> In the search bar type "Verifier" -> Display Information About Currently Verified Drivers -> Add -> For the filename type "amdkmdap" -> Open -> Change -> Uncheck DeadLock Detection -> Ok -> Next -> Next -> Finish

    Hope this helps.

    Intel 2.6 Dual Core (not core2)
    2GB Ram
    ATI 3850
    SB Audigy 2
    Windows Pro 7

    I also used driver sweeper to get rid of my old drivers and reinstalled the 11.2 drivers.

  10. #10
    Shadowlander
    Join Date
    Feb 2011
    Posts
    26

    Default

    Deadlock Detection monitors the driver's use of resources which need to be locked -- spin locks, mutexes, and fast mutexes. This Driver Verifier option will detect code logic that has the potential to cause a deadlock at some future point.

    The Deadlock Detection option of Driver Verifier, along with the !deadlock kernel debugger extension, is an effective tool for making sure your code avoids poor use of these resources.

    Deadlock Detection is supported only in Windows XP and later versions of Windows.
    Causes of Deadlocks

    A deadlock is caused when two or more threads come into conflict over some resource, in such a way that no execution is possible.
    http://msdn.microsoft.com/en-us/libr...=vs.85%29.aspx
    Last edited by Mytheral; 02-27-2011 at 06:24 PM.

  11. #11
    Telaran Zorky's Avatar
    Join Date
    May 2010
    Location
    Iceland
    Posts
    54

    Default

    I also have this problem Im using Nvidia GTX 580 on Win 7 Ultimate 64bit and the game keeps freezing and graphics driver crash this is really annoying new game and they couldn't fix this in alpha/beta.
    Last edited by Zorky; 02-28-2011 at 10:40 AM.
    Global Gamers - Host: Irc.globalgamers.net - Port: 6667
    Channels: #Rift - #Archeage - #GlobalGamers #Wildstar

  12. #12
    Rift Disciple Nymirah's Avatar
    Join Date
    Jan 2011
    Location
    Canada
    Posts
    150

    Default

    Quote Originally Posted by Mytheral View Post
    There is a Fix... At least it seemed to work for me. What appears to be happening is the ATI GPU DeadLock protection is being triggered. Which you can disable (but will have to re-disable on each restart)

    Instructions for Win 7 because it's what I'm running and can not verify how to do it else where.

    Start -> In the search bar type "Verifier" -> Display Information About Currently Verified Drivers -> Add -> For the filename type "amdkmdap" -> Open -> Change -> Uncheck DeadLock Detection -> Ok -> Next -> Next -> Finish

    Hope this helps.

    Intel 2.6 Dual Core (not core2)
    2GB Ram
    ATI 3850
    SB Audigy 2
    Windows Pro 7

    I also used driver sweeper to get rid of my old drivers and reinstalled the 11.2 drivers.
    Has this fix worked for anyone else?

  13. #13
    Soulwalker Plonker's Avatar
    Join Date
    Feb 2011
    Posts
    24

    Default

    Just posted about this issue on another thread, obviously didn't search hard enough!

    I'm having the same (or similar) issues with a Nvidia Geforce 560 Ti.

    Black screen lasts about 1-2 seconds, game continues to run in background, sound keeps going (no stuttering) and just comes good after it goes black. Sometimes it can happen twice within a minute, other times it might happen once every 10 minutes. Having it happen on both our computers; we both got new rigs, so I can't really say if it's something new in the latest patch, or if something I've changed. Played a couple of other 3D games over the past few days with this setup and doesn't seem to be happening in anything but Rift.

    Setup for both machines:

    Windows 7 x64
    Gigabyte SOC 560 Ti (Driver Release 266.66)
    Intel i7 2600K
    G.Skill 8GB PC-12800
    Asus P8P76 Pro
    Asus Xonar DX

    Cheers.

  14. #14
    Rift Disciple Barabas's Avatar
    Join Date
    Dec 2010
    Location
    Chicago
    Posts
    131

    Default

    Quote Originally Posted by Nymirah View Post
    Has this fix worked for anyone else?
    nope, tried the verifer and diver sweep no go. Still second lock ups in warfrotns, looting, and and rifts.

  15. #15
    Champion gel214th's Avatar
    Join Date
    Feb 2011
    Posts
    521

    Default

    I will try that verifier thing and see if it helps.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts