+ Reply to Thread
Page 1 of 8 1 2 3 4 5 ... LastLast
Results 1 to 15 of 114

Thread: I can't freaking patch at all..

  1. #1
    Rift Disciple Marre's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    148

    Default I can't freaking patch at all..

    When I start the launcher, it says it needs updating and I press "yes"

    After a few seconds I get "unable to connect with the patch server, please try again later (error #1021)"

    Then I once again get back at the login screen , but without logging in I get the news and "update" button showing. I click update and I get another error.

    "failed to connect to the authentication server (error #2005)

    What is wrong? I can't even type in the email and password area at the launcher..

    Tried uninstalling beta and everything 4 times now.


    ##UPDATE##
    Okay so my case got moved into tecnhical discussions, so i'll summarize everything i've tried to do.

    *Removed all rift related things from my computer, the beta client, all appdata, registry etcetc.
    *Port forwarded 6900-692something
    *Removed my anti virus, and turning off my firewall
    *As above, I also applied play rift to be safe with windows firewall, even though it's off.
    *Rebooted my computer after several tries of reinstallments. CC cleaned as well.
    *Rebooted router 3 times.

    I can't really see anything blocking my connection to the patcher.

    Summarize of what happens.

    I start the patcher after installing it, it patches up to the right version fast "26-b6". After that it kindof freezes up for a few seconds at the login screen, without being able to click the boxes to fill in my info, I get the error #1021 , after I click OK on the error, I get directed to the UPDATE button with all the news etc. And I click update, and I get the error #2005.
    Last edited by Marre; 02-23-2011 at 09:40 AM.

  2. #2
    RIFT Community Ambassador Morvick's Avatar
    Join Date
    Dec 2010
    Location
    Behind you.
    Posts
    3,294

    Default

    You need to uninstall all of your Beta data. It won't be used for Head Start.
    Just view the target location folder, and delete everything Rift-related.

    This is what you want to go to after doing that. Click the blue button.
    http://www.riftgame.com/en/headstart/index.php
    Last edited by Morvick; 02-23-2011 at 07:19 AM.
    Quote Originally Posted by Zinbik View Post
    I also made other enhancements to certain aspects of the game for various reasons.

  3. #3
    RIFT Guide Writer Sinfullysweet's Avatar
    Join Date
    Jan 2011
    Location
    Georgia
    Posts
    2,525

    Default

    Quote Originally Posted by Marre View Post
    When I start the launcher, it says it needs updating and I press "yes"

    After a few seconds I get "unable to connect with the patch server, please try again later (error #1021)"

    Then I once again get back at the login screen , but without logging in I get the news and "update" button showing. I click update and I get another error.

    "failed to connect to the authentication server (error #2005)

    What is wrong? I can't even type in the email and password area at the launcher..

    Tried uninstalling beta and everything 4 times now.
    Give me a sec and I will pull up a couple of error threads that talks about that.

    Sinfullysweet of Grievance on Wolfsbane
    PLAY ~*~Twitter ~*~ Raptr ~*~ Sinfullysweet's Steam ~*~ Sin's Xbox Profile
    WorldofWardrobes.net is no longer available due to hosting issues *RIP*.

  4. #4
    Rift Chaser jokomul's Avatar
    Join Date
    Feb 2011
    Posts
    304

    Default

    I've had 2 threads going about the 2005 error but still no luck. I've tried deleting all rift data from my PC including the registry, as well as disabling my firewall and antivirus.

  5. #5
    Rift Disciple Marre's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    148

    Default

    I did remove EVERYTHING even related to rift, and I get the same ****.. It's really weird.

  6. #6
    RIFT Guide Writer Sinfullysweet's Avatar
    Join Date
    Jan 2011
    Location
    Georgia
    Posts
    2,525

    Default

    Here are some fixes in case that the uninstalling beta doesn't work:

    http://forums.riftgame.com/showthrea...=error+%232005

    You experience error #1012 during patching.

    1. When you install the client, choose to install for “anyone who uses this computer”. Installing “only for me” currently does not work correctly.
    2. Install the client to a subdirectory (for example, C:\Rift) instead of directly to the drive’s root (C. Installing to the drive root does not work correctly.
    Also, I know this sounds dumb, but once you uninstall, reboot. Sometimes it takes a clean reboot to get things working right. (Not a cureall but just a small tip)
    Last edited by Sinfullysweet; 02-23-2011 at 07:25 AM.

    Sinfullysweet of Grievance on Wolfsbane
    PLAY ~*~Twitter ~*~ Raptr ~*~ Sinfullysweet's Steam ~*~ Sin's Xbox Profile
    WorldofWardrobes.net is no longer available due to hosting issues *RIP*.

  7. #7
    Rift Chaser jokomul's Avatar
    Join Date
    Feb 2011
    Posts
    304

    Default

    Where did you pre-order from?


    Edit:
    Here are some fixes in case that the uninstalling beta doesn't work:

    http://forums.riftgame.com/showthrea...=error+%232005
    lol small world (forums)
    Last edited by jokomul; 02-23-2011 at 07:30 AM.

  8. #8
    Banned
    Join Date
    Dec 2010
    Location
    Louisiana
    Posts
    6,449

    Default

    yo Firewall suckssss...what firewall you got?

  9. #9
    RIFT Guide Writer Sinfullysweet's Avatar
    Join Date
    Jan 2011
    Location
    Georgia
    Posts
    2,525

    Default

    Quote Originally Posted by jokomul View Post
    Where did you pre-order from?


    Edit: lol small world (forums)
    I preordered from Trion (if the question was directed at me) lol. Still trying to find more information about the 2005 error. So many threads that fixes get scattered around.

    Sinfullysweet of Grievance on Wolfsbane
    PLAY ~*~Twitter ~*~ Raptr ~*~ Sinfullysweet's Steam ~*~ Sin's Xbox Profile
    WorldofWardrobes.net is no longer available due to hosting issues *RIP*.

  10. #10
    Rift Chaser jokomul's Avatar
    Join Date
    Feb 2011
    Posts
    304

    Default

    Quote Originally Posted by Sinfullysweet View Post
    I preordered from Trion (if the question was directed at me) lol. Still trying to find more information about the 2005 error. So many threads that fixes get scattered around.
    It was directed to the OP, but the edit was directed to you because i thought i got so confused when I clicked on your link and it was my thread haha

    I was just wondering if maybe the fact that I pre-ordered from Walmart and didn't get an actual pre-order key was the issue. I know it's kind of out there, but maybe it thinks my account isn't authorized to download the full game. Trion assured me that it looks good from their end, but my account management page doesn't say I own the game.

  11. #11
    RIFT Guide Writer Sinfullysweet's Avatar
    Join Date
    Jan 2011
    Location
    Georgia
    Posts
    2,525

    Default

    Quote Originally Posted by jokomul View Post
    Where did you pre-order from?


    Edit: lol small world (forums)
    Jokomul, I have a very odd question. What firewall program do you use? Is it something you can reinstall?

    Reason why I ask this, is I know I have had to do this with programs before, I had to literally uninstall my firewall, run a registry cleaner, (Glary utilities is free and AWESOME for this: http://www.glarysoft.com/products/ut...ties/download/ ) then install the program that wasn't allowing, then reinstall my firewall.

    It worked after that on other programs. I am really grasping at straws for your case.

    Sinfullysweet of Grievance on Wolfsbane
    PLAY ~*~Twitter ~*~ Raptr ~*~ Sinfullysweet's Steam ~*~ Sin's Xbox Profile
    WorldofWardrobes.net is no longer available due to hosting issues *RIP*.

  12. #12
    Rift Disciple Marre's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    148

    Default

    Quote Originally Posted by jokomul View Post
    It was directed to the OP, but the edit was directed to you because i thought i got so confused when I clicked on your link and it was my thread haha

    I was just wondering if maybe the fact that I pre-ordered from Walmart and didn't get an actual pre-order key was the issue. I know it's kind of out there, but maybe it thinks my account isn't authorized to download the full game. Trion assured me that it looks good from their end, but my account management page doesn't say I own the game.
    Hey, I read your thread and it didn't help either with all the people trying to help ya.

    I ordered from direct2drive.co.uk, which my guild leader from finland did as well, (im from sweden) and his patching works perfectly fine.

    I heard that you have to setup a subscription from the https://rift.trionworlds.com/account/profile/ page, and make sure your game is there under manage games. e.g "Manage games
    RIFT Digital Collector's Edition"

    Anyways, I will give it a try now since i've turned off my firewall & antivirus, ill let you know how it goes.

  13. #13
    Rift Chaser jokomul's Avatar
    Join Date
    Feb 2011
    Posts
    304

    Default

    Quote Originally Posted by Sinfullysweet View Post
    Jokomul, I have a very odd question. What firewall program do you use? Is it something you can reinstall?

    Reason why I ask this, is I know I have had to do this with programs before, I had to literally uninstall my firewall, run a registry cleaner, (Glary utilities is free and AWESOME for this: http://www.glarysoft.com/products/ut...ties/download/ ) then install the program that wasn't allowing, then reinstall my firewall.

    It worked after that on other programs. I am really grasping at straws for your case.
    The only firewall I have enabled right now is Windows Firewall, and I have Play Rift and the rift patcher in the allowed programs. I've also disabled my antivirus to see if that was affecting it.

    Also, I just thought of something. My college uses the Cisco NAC Agent. Could that have something to do with it? I'm really not familiar with this Cisco stuff, all I know is that it's a pain in the ***.

  14. #14
    Rift Disciple Marre's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    148

    Default

    Okay so this is what I did (without success)

    Clean registry
    remove everything rift related on comp, including from %appdata%
    uninstalled beta ages ago, and live patcher 6 times now.

    I still get the #2005 error.


    Hope we can get a trion announcement about this soon.

  15. #15
    Rift Chaser jokomul's Avatar
    Join Date
    Feb 2011
    Posts
    304

    Default

    Quote Originally Posted by Marre View Post
    Okay so this is what I did (without success)

    Clean registry
    remove everything rift related on comp, including from %appdata%
    uninstalled beta ages ago, and live patcher 6 times now.

    I still get the #2005 error.


    Hope we can get a trion announcement about this soon.
    I sent them a question via the support option. I'm assuming they're experiencing an extreme amount of questions, but if they get back to me I'll make sure to post back on all the error 2005 threads I can find.

+ Reply to Thread
Page 1 of 8 1 2 3 4 5 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts