+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 21

Thread: ERROR: 1021, 1014, then 2005

  1. #1
    Shadowlander
    Join Date
    Feb 2011
    Posts
    30

    Default ERROR: 1021, 1014, then 2005

    Ii got the first patcher patch downloaded and installed. When the rift patcher restarted, the problems occured.

    I got error 1021 as I started the launcher. (Unable to connect with patch server)

    Then error 1014 after I clicked ok on the 1021 error notification. (cannot connect to the update server)

    Then error 2005 after I entered my account name/password and clicked login in hopes of downloading the game client before tomorrow. (failed to connect with authentication server)


    EDIT: Added what the error numbers stood for.

    EDIT 2: After restarting my PC, I was able to connect to the above servers and begin the download.
    Last edited by Dren the Black; 02-23-2011 at 07:44 AM.

  2. #2
    Soulwalker Stagda's Avatar
    Join Date
    Feb 2011
    Location
    Texas
    Posts
    10

    Default

    Quote Originally Posted by Dren the Black View Post
    I got error 1021 as I started the launcher.

    Then error 1014 after I clicked ok on the 1021 error notification.

    Then error 2005 after I entered my account name/password and clicked login in hopes of downloading the game client before tomorrow.
    Error 1021 then 1013 here. I was half way done last night, I dunno what happened

  3. #3
    Soulwalker
    Join Date
    Sep 2010
    Posts
    2

    Default

    i am getting error 1034, network operation timed out. please check your connection. connection is fine

  4. #4
    Rift Disciple
    Join Date
    May 2010
    Posts
    72

    Default

    I would uninstall the launcher, redownload it (disable your antivirus first), then run the setup. After that initial patcher setup, check your firewall settings and make sure that rift patcher is added as an exception. Then, try topatch again. All I had to do was add the firewall exception, then the entire game patched without a hitch.

    If that doesn't help, then keep looking here for other folks who may have same issue you are having and have found a solution. Best of luck!

  5. #5
    Rift Disciple
    Join Date
    May 2010
    Posts
    72

    Default

    Ghengis, that is EXACTLY 1 of 2 error messages I was getting. I added the exception to my firewall (allowing rift patcher access to the internet) and the game then patched fully.
    Last edited by Hordakk; 02-23-2011 at 07:19 AM.

  6. #6
    Soulwalker Stagda's Avatar
    Join Date
    Feb 2011
    Location
    Texas
    Posts
    10

    Default

    I tried adding the exception to my firewall, anti-virus already disabled, but the game started patching already. I'd have to agree that adding the exception now so you don't have issues later on might be helpful.

  7. #7
    Shadowlander
    Join Date
    Feb 2011
    Posts
    30

    Default

    Well, i got the first patcher patch downloaded and installed. When the rift patcher restarted, the problems occured.

  8. #8
    Soulwalker
    Join Date
    Jan 2011
    Posts
    4

    Default time

    If it's 2005 verify your system clock + time is accurate.

  9. #9
    Soulwalker
    Join Date
    Feb 2011
    Posts
    2

    Default

    I get the same set of errors.

    Everything went smoothly from patch to playing in game for a couple hours. Even got to level 7. Then the game froze my system. Rebooted and was able to get back in for about 10mins before it crashed again. Second reboot, I started getting these error #'s.

    Tried:
    - checked system timezone/clock/date. Viewed the auth site via browser with no SSL cert issues. My clock syncs the time with the time.gov server. All correct. Tried resetting the clock to a wrong date/year, launching the game (same errors), then resetting it back to the correct time/date. Still same errors.
    - Tried running the self patcher. Went through its thing and runs the launcher automatically- same set of errors.
    - Tried running the launchers as Administrator (running win7 ultimate 64bit), same errors
    - Tried shutting down the computer for 20-30mins. in case it was a heat issue. Same errors
    - Even though the game was running fine for me earlier, and just to eliminate the possibility of my anti-virus (mcafee), I uninstalled it. Made sure windows firewall was off too. Guess what the results were? Yep- the same errors.
    - Checked the patch log:
    [Fri Feb 25 02:41:13 2011] Log opened

    [Fri Feb 25 02:41:13 2011] RiftPatch version 28-8a (main@378644)

    [Fri Feb 25 02:41:13 2011] Downloading remote versions file 'http://update2.triongames.com/ch1-live-client-patch/public/ch1-live.txt'
    [Fri Feb 25 02:41:13 2011] Downloading 'http://update2.triongames.com/ch1-live-client-patch/public/ch1-live.txt' (using cookie )
    [Fri Feb 25 02:41:13 2011] ----------------------------------------------------------------------------------------
    [Fri Feb 25 02:41:13 2011] http://update2.triongames.com/ch1-li...c/ch1-live.txt
    [Fri Feb 25 02:41:13 2011] ----------------------------------------------------------------------------------------
    [Fri Feb 25 02:41:13 2011] Downloading into 'C:\Users\Nobody\AppData\Local\Temp\ver6'
    [Fri Feb 25 02:41:13 2011] Setting file offset to 0
    [Fri Feb 25 02:41:13 2011] Finishing request
    [Fri Feb 25 02:41:13 2011] Perform failed with code 7
    [Fri Feb 25 02:41:13 2011] Request Failed http://update2.triongames.com/ch1-li...c/ch1-live.txt
    [Fri Feb 25 02:41:13 2011] Version download: Unable to download 'http://update2.triongames.com/ch1-live-client-patch/public/ch1-live.txt' to 'C:\Users\Nobody\AppData\Local\Temp\ver6'


    I have no idea why it's failing. I can browse to that url fine. I can create a file in the Temp dir fine. I tried manually grabing the contents of the ch1-live.txt file and creating a ver6 file. Ran the launcher and it tries to create a ver7 file with the same error.

    At this point i'm more than pissed. My last resort is uninstall everything, make sure the registry is cleaned too, and re-download the whole damn thing again. I can't even try this until late tomorrow evening, which blows away another day of supposed enjoyment of the game due to the 2-3hr download time.


    So if anyone has any other ideas to try, please post them.

  10. #10
    Soulwalker
    Join Date
    Feb 2011
    Posts
    2

    Default

    Quote Originally Posted by Sceaden View Post
    I get the same set of errors.

    Everything went smoothly from patch to playing in game for a couple hours. Even got to level 7. Then the game froze my system. Rebooted and was able to get back in for about 10mins before it crashed again. Second reboot, I started getting these error #'s.

    Tried:
    - checked system timezone/clock/date. Viewed the auth site via browser with no SSL cert issues. My clock syncs the time with the time.gov server. All correct. Tried resetting the clock to a wrong date/year, launching the game (same errors), then resetting it back to the correct time/date. Still same errors.
    - Tried running the self patcher. Went through its thing and runs the launcher automatically- same set of errors.
    - Tried running the launchers as Administrator (running win7 ultimate 64bit), same errors
    - Tried shutting down the computer for 20-30mins. in case it was a heat issue. Same errors
    - Even though the game was running fine for me earlier, and just to eliminate the possibility of my anti-virus (mcafee), I uninstalled it. Made sure windows firewall was off too. Guess what the results were? Yep- the same errors.
    - Checked the patch log:
    [Fri Feb 25 02:41:13 2011] Log opened

    [Fri Feb 25 02:41:13 2011] RiftPatch version 28-8a (main@378644)

    [Fri Feb 25 02:41:13 2011] Downloading remote versions file 'http://update2.triongames.com/ch1-live-client-patch/public/ch1-live.txt'
    [Fri Feb 25 02:41:13 2011] Downloading 'http://update2.triongames.com/ch1-live-client-patch/public/ch1-live.txt' (using cookie )
    [Fri Feb 25 02:41:13 2011] ----------------------------------------------------------------------------------------
    [Fri Feb 25 02:41:13 2011] http://update2.triongames.com/ch1-li...c/ch1-live.txt
    [Fri Feb 25 02:41:13 2011] ----------------------------------------------------------------------------------------
    [Fri Feb 25 02:41:13 2011] Downloading into 'C:\Users\Nobody\AppData\Local\Temp\ver6'
    [Fri Feb 25 02:41:13 2011] Setting file offset to 0
    [Fri Feb 25 02:41:13 2011] Finishing request
    [Fri Feb 25 02:41:13 2011] Perform failed with code 7
    [Fri Feb 25 02:41:13 2011] Request Failed http://update2.triongames.com/ch1-li...c/ch1-live.txt
    [Fri Feb 25 02:41:13 2011] Version download: Unable to download 'http://update2.triongames.com/ch1-live-client-patch/public/ch1-live.txt' to 'C:\Users\Nobody\AppData\Local\Temp\ver6'


    I have no idea why it's failing. I can browse to that url fine. I can create a file in the Temp dir fine. I tried manually grabing the contents of the ch1-live.txt file and creating a ver6 file. Ran the launcher and it tries to create a ver7 file with the same error.

    At this point i'm more than pissed. My last resort is uninstall everything, make sure the registry is cleaned too, and re-download the whole damn thing again. I can't even try this until late tomorrow evening, which blows away another day of supposed enjoyment of the game due to the 2-3hr download time.


    So if anyone has any other ideas to try, please post them.
    Ya wtf im not re downloading this. **** worked fine yesterday now its blown to hell. Do they have any kind of support here?

  11. #11
    General of Telara
    Join Date
    Oct 2010
    Posts
    864

    Default

    If you guys are receiving numerous "could not connect" errors then it's most likely a firewall/router/proxy of some sort which is blocking the connection. Either disable them or add an exception for both riftlivepatch.exe and rift.exe
    Shard population charts and monitoring: http://riftideas.com/shardwatch/

  12. #12
    Soulwalker
    Join Date
    Feb 2011
    Posts
    2

    Default

    Quote Originally Posted by Meritt View Post
    If you guys are receiving numerous "could not connect" errors then it's most likely a firewall/router/proxy of some sort which is blocking the connection. Either disable them or add an exception for both riftlivepatch.exe and rift.exe
    Both are allowed same problem. Is there anywhere I can go to get help or i am basically talking to myself?

  13. #13
    General of Telara
    Join Date
    Oct 2010
    Posts
    864

    Default

    Quote Originally Posted by jasdeep3 View Post
    Both are allowed same problem. Is there anywhere I can go to get help or i am basically talking to myself?
    Is your username for Windows actually 'Nobody' or is that part of the issue? Trying to write to some random directory?
    Shard population charts and monitoring: http://riftideas.com/shardwatch/

  14. #14
    Soulwalker
    Join Date
    Feb 2011
    Posts
    2

    Default

    Quote Originally Posted by Meritt View Post
    Is your username for Windows actually 'Nobody' or is that part of the issue? Trying to write to some random directory?
    It's actually "Nobody".

    I tried resetting the router, disabling/re-enabling nic card. Hell, I turned on the wireless and tried using that. Just for chitz and giggles, I even tethered my CELL phone and it wouldn't connect (same errors, but then the cell network can be blocking ports anyway).

    As posted earlier it was working just fine and was playing in game without any issues for about 2 hours. Even logged out and back in at the start just to be sure the patch process completed. I already tried adding the game launcher exe's to the exception list, but since that didn't work I removed the anti-virus, disabled the windows firewall. Still no go.

    So unless during that 2 hours of working play they added special ports and/or updated something within the launcher itself that broke, my guess is that my second game crash corrupted a few VERY key files. So my only choice at this point is to re-install. Beta play was a LOT smoother; never crashed or gave these errors.

  15. #15
    Soulwalker
    Join Date
    Nov 2010
    Posts
    1

    Default

    Same thing is happening to me, yesterday everything was fine, now I get error 1021 followed by 2005, same situation, any help would be awsome as this is getting very disheartening.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts