+ Reply to Thread
Results 1 to 15 of 15

Thread: Is it just the engine?

  1. #1
    Plane Touched Feiyth's Avatar
    Join Date
    Jan 2011
    Location
    Perth, Western Australia
    Posts
    218

    Default Is it just the engine?

    Hi guys,

    Not sure if this has been posted but a forum search didnt reveal anything specific to what im asking so here goes:

    Wondering if the gamebryo engine is the reason that my FPS seems to be unusually low (for my computer specs) or if there is something else going on i should know about.

    First my system specs:-
    Alienware M17X R2
    Dual 5870's in x-fire
    intel i7 920xm unlocked (overclocked 5% via bios menu)
    8gb DDR3 1333
    256gb SSD

    Now i run the game on 1920x1200 and during the betas have had to run it on low/medium to have half playable FPS in warfronts and rifts (sometimes drops to as low as 15 on medium, 9 on high). Now i know that my specs arent the best in the world but i think that they definately should be able to run this game at a minimum of high without too many issues... or at very least a playable frame rate

    I try and make it a point to not have any processes i dont need running in the background apart from the alienware bloat crap that i cant get rid of. Running windows 7 64Bit BTW.

    Fully updated video drivers and profiles - have tried the DX9 fixes that people have posted up here to no avail...

    If anybody has some kind of diagnostic i can run to see whats happening while im playing or any ideas to test during headstart it would be highly appreciated if you shared them.

    Also if i am being unreasonable and my system WILL NOT run this on ultra/high ever just tell me, i can accept that even if i think its hjorribly unfair

    TL;DR - Read my specs - should i be able to run the game on 1920x1200 at high/ultra detail with little to no FPS lag - and if so why cant i? Having to run on medium/low for it to be playable during warfronts/rifting.

    Thanks to all in advance for the replies.

    Reiyhn.
    Last edited by Feiyth; 02-22-2011 at 05:58 AM.

  2. #2
    Telaran Kaynar's Avatar
    Join Date
    Jan 2011
    Posts
    58

    Default

    first of all, u dont have 5870 cards, u have 5870M which is like 1/3 of a normal 5870 power.

    secondly, the Xfire profile for ATI cards on desktops dont make any difference in the game right now, maybe it will when the game will be released. Remember this game is a beta and therefore things are under preparation.

    In release and when proper drivers for Xfire will be released you should be able to run on the Ultra preset without AA in 1900x1200.


    As far as I have read around in technical website, the 5870M is of the same specs as a 5750 for desktop. (I wanted to buy that laptop too but i finally went for desktop).

    And yes up to now what we have seen is modified gamebryo fails (but its only beta!!!)
    Last edited by Kaynar; 02-22-2011 at 06:09 AM.

  3. #3
    Plane Touched Feiyth's Avatar
    Join Date
    Jan 2011
    Location
    Perth, Western Australia
    Posts
    218

    Default

    DOh, wish i had of known that when i wasted all my money on this laptop - oh well live and learn..

    Cheers for reply.

    Roll on official release and x-fire support then eh? =)

  4. #4
    Champion of Telara Forum Troll's Avatar
    Join Date
    Jan 2011
    Location
    Norcal
    Posts
    1,254

    Default

    That laptop would cost like $1600 if you didn't have to pay for that alien emblem.
    My computer
    Proud member of the Forum Troll fan club.

  5. #5
    Shadowlander
    Join Date
    Feb 2011
    Posts
    25

    Default

    The golden rule with laptops is: There's no such thing as a gaming laptop.

  6. #6
    Plane Touched Feiyth's Avatar
    Join Date
    Jan 2011
    Location
    Perth, Western Australia
    Posts
    218

    Default

    Ah well, Back to desktops next upgrade - thanks guys!

  7. #7
    Champion of Telara Forum Troll's Avatar
    Join Date
    Jan 2011
    Location
    Norcal
    Posts
    1,254

    Default

    Quote Originally Posted by thunderkrakish View Post
    The golden rule with laptops is: There's no such thing as a gaming laptop.
    It's like buying a Prius to race with.

    And an alienware laptop?
    http://priuschat.com/forums/attachme...ius-prius1.jpg
    My computer
    Proud member of the Forum Troll fan club.

  8. #8
    Plane Touched Gnimitz's Avatar
    Join Date
    Jan 2011
    Posts
    214

    Default

    I'm gonna go ahead and say, it's mostly the game engine.

    They have done a good job, with a bad engine, that just isn't optimized and can't handle large groups of players, which is odd they chose it considering the game is built around large groups of players.

  9. #9
    Champion of Telara Forum Troll's Avatar
    Join Date
    Jan 2011
    Location
    Norcal
    Posts
    1,254

    Default

    Quote Originally Posted by Gnimitz View Post
    I'm gonna go ahead and say, it's mostly the game engine.

    They have done a good job, with a bad engine, that just isn't optimized and can't handle large groups of players, which is odd they chose it considering the game is built around large groups of players.
    I experience minimal (5fps?) frame rate drop with large groups.
    My computer
    Proud member of the Forum Troll fan club.

  10. #10
    Plane Walker Anakha's Avatar
    Join Date
    Jan 2011
    Posts
    447

    Default

    Quote Originally Posted by Forum Troll View Post
    It's like buying a Prius to race with.

    And an alienware laptop?
    http://priuschat.com/forums/attachme...ius-prius1.jpg
    Hey not all electric/electric hybrid vehicles suck.

    http://www.motoczysz.com/

    http://gizmodo.com/#!027286

    However an Alienware is more like a tricked out escort than a Prius, otherwise it would have a longer battery life.
    CPU: AMD Phenom II x4 965 3.4 GHz RAM: 8 GB GSkill Ripjaw DDR3 1333 MOBO: Gigabyte GA-MA790GPT-UD3H Case: Cooler Master ATCS 840

    GPU: Crossfired Dual XFX ATI HD 5850 PSU: Cooler Master Silent Pro Gold 800 W modular PSU Storage: Western Digital Caviar black 1 TB x2 Raid 0

    Keyboard: Logitech G110 Mouse: Logitech G9x O.S.: Windows 7 Pro 64 bit

  11. #11
    Soulwalker
    Join Date
    Jan 2011
    Posts
    6

    Default

    I got huge amount of lag on my laptop too but that was only in beta 6 and 7 in beta 5 all was working fine. I looked into that a bit and noticed the post on forum about GT causing trouble as ISP. After a bit of looking trough posts i saw that alot of people with other ISP's had similar troubles something about some changed portnumbers between beta 5 and 6. Not sure, just saying that it could bee an RIFT/your ISP problem too and not your machine which i btw would love to own ;)

  12. #12
    Champion of Telara Forum Troll's Avatar
    Join Date
    Jan 2011
    Location
    Norcal
    Posts
    1,254

    Default

    Quote Originally Posted by graakappe View Post
    I got huge amount of lag on my laptop too but that was only in beta 6 and 7 in beta 5 all was working fine. I looked into that a bit and noticed the post on forum about GT causing trouble as ISP. After a bit of looking trough posts i saw that alot of people with other ISP's had similar troubles something about some changed portnumbers between beta 5 and 6. Not sure, just saying that it could bee an RIFT/your ISP problem too and not your machine which i btw would love to own ;)
    Network latency is not related to a drop in FPS such as in the OP. Not even in the same ballpark.
    My computer
    Proud member of the Forum Troll fan club.

  13. #13
    Soulwalker
    Join Date
    Feb 2011
    Posts
    7

    Default

    First of all: update your drivers. 90% it's a bad install or update that bothers you.


    Do not use AA(or if you want to only use up to x4) as it's a huge resource bomb and doesn't even do anything that's visually an update.

    Resolution is the highest stress of a videocard. Turn either that down or your details.

    Lagging in a big number is bad memory management in the videocard. Since you're using xfire. Enable first one. See if that causes a problem. The other solution is again... Re-install your driver. Could be both, who knows. A GPU processor is fast enough to render these types of games(especially that card), so yea... Especially this game, it's not that ZOMG HIGH END VISUALLY CRISIS A MA GAD game.

    1. Drivers check: reinstall them
    2. Resolution down and in game details... If that's the problem go back to 1 .
    3. Enable only 1 videocard. problem solved? do nothing untill game patches or drivers patches to support good enough memory management of cards.
    4. if problem still occurs with 1 videocard. Try the other one .
    5. Do a check on your system memeory. Who knows even this memory can cause visual lagg.
    6. Hard drive? eventhough that's a far shot. A hard drive is the weakest link in your system. Do a hard drive stress test. Still you're using SSD. Which simply owns, but you can never be sure
    7. If none of these have the solution, send the laptop back and ask for refund and buy a desktop PC. Laptops are not made for gaming extensivly.
    Last edited by nickje; 02-22-2011 at 07:46 AM.

  14. #14
    Rift Disciple
    Join Date
    Feb 2011
    Posts
    132

    Default

    I'm not experiencing really any issues. Then again I'm not trying to run on Ultra. Also, I've become used to the fact that in just about any game with a massive number of people on a screen, things tend to slow down.

  15. #15
    Rift Disciple ColdKarl's Avatar
    Join Date
    Feb 2011
    Posts
    111

    Default

    From experience, I know it can be a total pain trying to hunt down drivers for mobile graphics cards. It's like they're half-way unsupported..
    The tank is the driver, healer is the fuel. And the DPS are the kids sitting in the back crying about if they're there yet. And this is coming from a DPS.
    http://forumwatch.riftideas.com/ *Credit to Meritt*
    Ever heard of Mumble? It's like Vent & Skype had a kid!

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts