+ Reply to Thread
Results 1 to 4 of 4

Thread: unable to patch error

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Posts
    1

    Default unable to patch error

    I try to login in and I get an unable to patch and to try again later is anyone else getting this error

  2. #2
    Soulwalker
    Join Date
    Dec 2010
    Posts
    3

    Default

    same here.

  3. #3
    Soulwalker
    Join Date
    Feb 2011
    Posts
    18

    Default

    the servers are down, i am guessing. ob ended 10 am pst today iirc

    FBN

  4. #4
    RIFT Community Ambassador
    Join Date
    Nov 2010
    Posts
    1,995

    Default

    Quote Originally Posted by Fearedbynone View Post
    the servers are down, i am guessing. ob ended 10 am pst today iirc

    FBN
    that would be correct. beta is over. also since it is the last beta the beta client is probably no good anymore. what has been said a lot is we will all be redownloading a whole new client and the whole game over again.

    ...of course, i havent seen the official word yet. thats likely how it is though.
    Last edited by HeavyMetalLucidity; 02-21-2011 at 04:16 PM.
    Operating System: Windows 7 Pro 64bit
    Processor: Intel i7 960 @ 3.8Ghz
    Memory: 6GB DDR3 Triple Channel
    Graphics: Palit Geforce GTX 560Ti 2GB (Driver 301.24 BETA)
    Monitor: ASUS VE248 @ 1920x1080

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts