+ Reply to Thread
Page 1 of 5 1 2 3 4 5 LastLast
Results 1 to 15 of 71

Thread: What video card do you have?

  1. #1
    Soulwalker
    Join Date
    Jan 2011
    Posts
    16

    Default What video card do you have?

    Besides Ati 6970 and GTX 580, what video cards are you using to run at max settings (not ultra) and still getting 30+ fps

  2. #2
    Soulwalker
    Join Date
    Oct 2010
    Posts
    6

    Default

    gtx 580 solo questing 40 fps

  3. #3
    Soulwalker Savior82's Avatar
    Join Date
    Jan 2011
    Location
    Tampere, Finland
    Posts
    2

    Default

    Pair of Radeon 5870's in crossfire. Pretty good FPS but it still drops down to 20'ish in larger Rift events.

  4. #4
    Plane Touched
    Join Date
    Feb 2011
    Posts
    180

    Default

    AMD 6870.
    /10chars

    Edit: Oh not Ultra? But MAXXX?
    NO WAI! :<
    Last edited by NuDimon; 02-21-2011 at 02:25 PM.

  5. #5
    Soulwalker
    Join Date
    Jan 2011
    Posts
    16

    Default

    Quote Originally Posted by NuDimon View Post
    AMD 6870.
    /10chars

    Edit: Oh not Ultra? But MAXXX?
    NO WAI! :<
    yes Wai! lol sorry when i clicked ultra in the settings it didnt have all the sliders at max.. so i feel that ultra isnt so ultra

  6. #6
    Rift Disciple jimerick's Avatar
    Join Date
    Feb 2011
    Location
    netherlands, amsterdam
    Posts
    183

    Default

    ati readon 2400 pro max settings not possible hahaha

  7. #7
    Rift Disciple thune's Avatar
    Join Date
    Dec 2010
    Posts
    192

    Default

    a pair of crossfire ati 5400 HD's
    Last edited by thune; 02-21-2011 at 03:01 PM.

  8. #8
    Soulwalker Zadeus's Avatar
    Join Date
    Feb 2011
    Posts
    11

    Default

    Two 1GB DDR5 ATI Radeon 4870's Crossfire

  9. #9
    Shield of Telara Jhenox's Avatar
    Join Date
    Feb 2011
    Posts
    762

    Default

    ATI 6850 but I never went higher than Ultra.

  10. #10
    Shadowlander Cirae's Avatar
    Join Date
    Jan 2011
    Location
    South Carolina
    Posts
    35

    Default

    Asus Gtx560 Ti (Fermi) Direct CU II

  11. #11
    Shadowlander
    Join Date
    Feb 2011
    Location
    WV USA
    Posts
    23

    Default

    MSI R6970 1gb
    (ultra) well beyond 30fps
    Last edited by razok; 02-21-2011 at 04:58 PM.

  12. #12
    Shadowlander Eyeless's Avatar
    Join Date
    Jan 2011
    Posts
    28

    Default

    1 GTX 480. Run on Ultra settings with AA at 2.

  13. #13
    Soulwalker Zyrax's Avatar
    Join Date
    Feb 2011
    Location
    England
    Posts
    5

    Default

    ATI 3850hd, plays ok

  14. #14
    Soulwalker
    Join Date
    Nov 2010
    Posts
    7

    Default

    Sapphire 5970 (single card, dual GPU). Runs at about 80 fps with everything on max (With the current dual GPU / SLI / X-fire issue, it goes down to 50 after a few min of play time, should be fixed soon though).
    Last edited by dragonstuff; 02-21-2011 at 07:05 PM.

  15. #15
    343
    343 is offline
    Soulwalker 343's Avatar
    Join Date
    Feb 2011
    Posts
    6

    Default

    260 Gtx in sli, and i get around 30-50 fps with no AA

+ Reply to Thread
Page 1 of 5 1 2 3 4 5 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts