+ Reply to Thread
Results 1 to 10 of 10

Thread: Direct3D Initialization Error Fix

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Location
    Clute, TX
    Posts
    2

    Default Direct3D Initialization Error Fix

    Ok first off check what Resolution you have your windows at. For me was 1600x900.
    Next open the folder were u have Rift installed and look for the file "rift.cfg" open it ( make sure to back up before u mess with it)
    Scroll down to the VIDEO section and look for the Resolution X and Y , change those to the resolution your desktop is at, in my case X = 1600 and Y= 900
    Save it and try again. for me it worked hope it works for you too.

    PS All my drivers are up to date so be sure thats what u do first.

  2. #2
    Soulwalker
    Join Date
    Feb 2011
    Posts
    3

    Default

    Thanks, this worked for me. ResolutionY = 1024 was default and I play on an HD TV that only does 768 wide.

    Can't play of course as the servers are locked until tuesday, which is odd for a beta invite that I got on a Friday. But anyway good work.

  3. #3
    RIFT Community Ambassador
    Join Date
    Nov 2010
    Posts
    1,995

    Default

    Quote Originally Posted by Jdrez View Post
    Thanks, this worked for me. ResolutionY = 1024 was default and I play on an HD TV that only does 768 wide.

    Can't play of course as the servers are locked until tuesday, which is odd for a beta invite that I got on a Friday. But anyway good work.
    this extra time is used for ppl to download/patch and make sure they can get there games running. all sorts of problems out there ya know.
    Operating System: Windows 7 Pro 64bit
    Processor: Intel i7 960 @ 3.8Ghz
    Memory: 6GB DDR3 Triple Channel
    Graphics: Palit Geforce GTX 560Ti 2GB (Driver 301.24 BETA)
    Monitor: ASUS VE248 @ 1920x1080

  4. #4
    Soulwalker
    Join Date
    Feb 2011
    Posts
    1

    Default Thank you!

    I actually had the same problem but this method has fixed it. Now I am really stoked to get to play during the upcoming event on Tuesday!

  5. #5
    Soulwalker
    Join Date
    Feb 2011
    Location
    Clute, TX
    Posts
    2

    Default

    I'm glad this has worked for you guys. hope anyone else with the same problem can resolve this quickly.
    Operating System: Windows 7
    CPU Type: AMD Phenom(tm) II X4 965 Processor 3.98 GHz CPU Speed
    System Memory (GB): 12
    Video Card Model: ATI Radeon HD 6950 2GB GDDR5 x2
    Hard Disk Size (GB): 1880.7

  6. #6
    Soulwalker
    Join Date
    Mar 2011
    Posts
    7

    Default

    I just started getting the 3d initialization error since the most recent patch. I want to try this fix but the rift.cfg file is completely un-openable. It's greyed out and on right click there are no open with options. Is there a program I need to open this or a more recent fix? Thanks.

  7. #7
    Shadowlander
    Join Date
    Feb 2011
    Posts
    42

    Default

    I also started getting this error after the patch earlier this week.

    I am running W7 64b. I can edit the file but is correctly reflects 1366x768. I am running this on a laptop, but it was running well before. (25+ fps in low graphics mode)

    I had started using a port replicator with different resolution on a second monitor, but even when running Rift now without the port replicator I am unable to play.

    Any suggestions?

  8. #8
    Shadowlander
    Join Date
    Feb 2011
    Posts
    42

    Default

    Edma R

    The first place you see the cfg file in the rift folder...is simply a short cut to the actual file. Perhaps that might help you. If you right click and open file location that will take you to the actual file. The other posibility is you do not have administrator righs to change the file.

  9. #9
    Shadowlander
    Join Date
    Feb 2011
    Posts
    42

    Default

    YEA!! Found the fix posted by another member:

    Also you can run the patcher click on settings and change to window mode then when you get ingame, change back to fullscreen.

  10. #10
    Soulwalker
    Join Date
    Apr 2011
    Posts
    1

    Default

    Changing the resolution in the .cfg worked for me! Thank you so much!

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts