+ Reply to Thread
Results 1 to 8 of 8

Thread: (beta 7) Game stuck before intro

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Posts
    6

    Default (beta 7) Game stuck before intro *solved*

    new version, same problem: the game doesn't get past a black screen even before the intro movies are shown. It seems to be caught in some infinite loop (fully using 1 core with 27meg of memory, for hours)



    devs can PM me if they want the dxdiag.
    Last edited by Batgolas; 02-12-2011 at 04:34 AM.

  2. #2
    Ascendant
    Join Date
    Jan 2011
    Posts
    1,471

    Default

    Cpu bottleneck.

    Jokes aside, try renaming the rift.cfg file rift will create a new one. Could be a bad setting. All other games running fine?
    2600K@5.3Ghz
    XFX GTX580@960
    28" 1920x1200
    SuperNerd

  3. #3
    Shadowlander SpottyGee's Avatar
    Join Date
    Oct 2010
    Location
    Calgary, AB
    Posts
    24

    Default

    Found this in another thread and it helped them

    Code:
    its solved:
    
    -----------SOLVED--------------
    ----SOLVED---
    
    I saw that for some reason, Windows Update was not working, I did a netsh winsock reset and NO MORE BLACK SCREEN, now Ive seen the video and Im waiting for shard list (I suppose they are the servers).
    
    
    C:\Windows\System32>netsh winsock reset
    
    El catálogo Winsock se restableció correctamente.
    Debe reiniciar el equipo para completar el restablecimiento.
    
    
    Probably the issue is that, before the video is loading, the game is checking some registry entries and dns records, and trying to contact rift servers, if it cant reach them it just hangs without giving a message and loops in an end loop.
    Give it a try and see if that helps
    CPU: Intel i7 2600K 3.4Ghz Quad Core OC'd to 4.0Ghz
    GPU:AMD Radeon HD 6950 2GB Flashed and OC'd to 6970@950Mhz/1450Mhz
    Ram: 8GB - Corsair 2x4G 1600MHz DDR3 Memory

    Guild: Relics of Honor - Faeblight RP-PVE

  4. #4
    Plane Touched Illian.Amerond's Avatar
    Join Date
    Feb 2011
    Location
    Portland Oregon USA
    Posts
    207

    Default

    Quote Originally Posted by Batgolas View Post
    new version, same problem: the game doesn't get past a black screen even before the intro movies are shown. It seems to be caught in some infinite loop (fully using 1 core with 27meg of memory, for hours)
    Let me get some clarity on this real quick...

    Are you logging in to the game and trying to play the game... like today, right now and this error is happening to you now? Or is this a previous issue you have had?

  5. #5
    Telaran Nailgun's Avatar
    Join Date
    Jan 2011
    Location
    Dallas, TX
    Posts
    56

    Default

    Open Beta starts Feb15th. There is no beta going on right now

  6. #6
    Soulwalker
    Join Date
    Jan 2011
    Posts
    1

    Default

    Quote Originally Posted by SpottyGee View Post
    Found this in another thread and it helped them

    Code:
    its solved:
    
    -----------SOLVED--------------
    ----SOLVED---
    
    I saw that for some reason, Windows Update was not working, I did a netsh winsock reset and NO MORE BLACK SCREEN, now Ive seen the video and Im waiting for shard list (I suppose they are the servers).
    
    
    C:\Windows\System32>netsh winsock reset
    
    El catálogo Winsock se restableció correctamente.
    Debe reiniciar el equipo para completar el restablecimiento.
    
    
    Probably the issue is that, before the video is loading, the game is checking some registry entries and dns records, and trying to contact rift servers, if it cant reach them it just hangs without giving a message and loops in an end loop.
    Give it a try and see if that helps
    this worked for me, thanks

  7. #7
    Soulwalker
    Join Date
    Feb 2011
    Posts
    6

    Default

    Quote Originally Posted by Illian.Amerond View Post
    Let me get some clarity on this real quick...

    Are you logging in to the game and trying to play the game... like today, right now and this error is happening to you now? Or is this a previous issue you have had?
    This happens BEFORE the game tries to connect to the shard servers. So whether the servers are up or down doesn't matter. If they are down I should be able to see the intro and get to the loading screen (and get stuck there but that would already be progress).

  8. #8
    Soulwalker
    Join Date
    Feb 2011
    Posts
    6

    Default

    Quote Originally Posted by SpottyGee View Post
    Found this in another thread and it helped them

    Code:
    its solved:
    
    -----------SOLVED--------------
    ----SOLVED---
    
    I saw that for some reason, Windows Update was not working, I did a netsh winsock reset and NO MORE BLACK SCREEN, now Ive seen the video and Im waiting for shard list (I suppose they are the servers).
    
    
    C:\Windows\System32>netsh winsock reset
    
    El catálogo Winsock se restableció correctamente.
    Debe reiniciar el equipo para completar el restablecimiento.
    
    
    Probably the issue is that, before the video is loading, the game is checking some registry entries and dns records, and trying to contact rift servers, if it cant reach them it just hangs without giving a message and loops in an end loop.
    Give it a try and see if that helps
    Just tried it, either the latest small patch solved it or this did. Anyway I'm able to see the shard selection screen now Thanks for the help, given the number of people that faced this problem I'm amazed it's not stickied.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts