+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23

Thread: Asus Xonar with GX enabled crashes the sound driver on client exit?

  1. #1
    Shield of Telara C00lit's Avatar
    Join Date
    Nov 2010
    Location
    UK
    Posts
    731

    Default Asus Xonar with GX enabled crashes the sound driver on client exit?

    So I just realised by reading another thread that even though the beta is not currently on you can log in and update the client to the latest version (which you couldn't do after previous betas), then go to the server screen where you'll see a few changes including more audio options.

    What I've found though is that when I exit the client it now seems to crash my sound driver which causes a repeating sound in the background, the only course of action from here is to reboot your system.

    I've tracked this down to the EAX implementation on the Xonar, if I click and disable EAX with the GX button I can exit normally.

    Does anyone else have this problem with the Xonar sound card and the latest client update?

    I have a Asus Xonar HDAV Deluxe 1.3 on windows 7 64bit.
    Last edited by C00lit; 02-11-2011 at 12:07 PM.

  2. #2
    Soulwalker
    Join Date
    Feb 2011
    Posts
    1

    Default

    I have this error also. I've updated client yesterday and when I exit game there is this repeating sound in the background.

    Win 7 64bit + ASUS Xonar DX/XD 7.1

    I've changed drivers from 7.12.8.1780 to 7.12.8.1792 and error still remains. The only thing that helps is disabling EAX with GX button.
    Last edited by Kojambo; 02-12-2011 at 03:31 AM.

  3. #3
    Soulwalker
    Join Date
    Jan 2011
    Posts
    3

    Default

    I also have this error with a Xonar Essence STX on 64bit Vista. I'm running the most current drivers from ASUS.

    Very annoying! Hopefully this gets fixed before the beta starts on the 15th or I am going to be rebooting a lot.

  4. #4
    Soulwalker
    Join Date
    Jan 2011
    Posts
    3

    Default

    Hmmm. I don't think it is a problem with Rift. I just got the same problem when Civilization 5 just crashed on me. I even rolled back my driver to one from 2009 and I still get it. I wonder if something in the Windows update from last Tuesday broke the driver? It's the only major software update I've done to my system recently.

  5. #5
    Shield of Telara C00lit's Avatar
    Join Date
    Nov 2010
    Location
    UK
    Posts
    731

    Default

    Quote Originally Posted by ChickenLover View Post
    Hmmm. I don't think it is a problem with Rift. I just got the same problem when Civilization 5 just crashed on me. I even rolled back my driver to one from 2009 and I still get it. I wonder if something in the Windows update from last Tuesday broke the driver? It's the only major software update I've done to my system recently.
    After what you said I went and tried it with several other games I have installed and its only doing it with RiFT for me.

    RiFT worked fine with GX enabled until the last update that coincidence or not added audio options to the settings page. I've sent a mail to Trion support so we'll see what they say

    I'm using the latest driver with my card, Version 7.12.8.1792 dated 2010/11/01 on windows 7 64bit.
    Last edited by C00lit; 02-12-2011 at 07:54 AM.

  6. #6
    Shadowlander
    Join Date
    Feb 2011
    Posts
    44

    Default

    Got this problem after last update on beta (HF + GX enabled).
    Audio card: Xonar Essense STX
    OS: Windows 7 64-bit
    Lastest audio drivers: 7.12.7.1792

  7. #7
    Soulwalker
    Join Date
    Jan 2011
    Posts
    3

    Default

    Quote Originally Posted by C00lit View Post
    After what you said I went and tried it with several other games I have installed and its only doing it with RiFT for me.

    RiFT worked fine with GX enabled until the last update that coincidence or not added audio options to the settings page. I've sent a mail to Trion support so we'll see what they say

    I'm using the latest driver with my card, Version 7.12.8.1792 dated 2010/11/01 on windows 7 64bit.
    I wonder if perhaps Rift isn't closing correctly then? I've been able to duplicate the repeating sound with client crashes in two other games now. Company of Heroes is the other one. No issues if they close properly.

  8. #8
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    188

    Default

    While using my Xonar DX Rift CTD'd a lot more. Both in b6 and b5. Also when they crashed, the sound system made a buzzz-like noise which only stopped when rebooted. So it was unplayable with sound. My solution was switching back to mobo SC while playing Rift...

  9. #9
    Soulwalker
    Join Date
    Oct 2010
    Posts
    23

    Default

    I had this exact problem. Turning off GX fixes it. Wasn't an issue previous beta. Gotta love conflicting code.

    Edit: Asus Xonar DX by the way.
    Last edited by Wrathos; 02-12-2011 at 08:56 PM.

  10. #10
    Shield of Telara C00lit's Avatar
    Join Date
    Nov 2010
    Location
    UK
    Posts
    731

    Default

    Still not had a response from tech support but its hardly a surprise considering its the weekend.

  11. #11
    Soulwalker
    Join Date
    Feb 2011
    Posts
    1

    Default

    I have a similar experience here with Asus Xonar DX in Windows 7 32 bit, using the latest available driver.

    I looked in game for the EAX or GX control mentioned but couldn't find anything there. I found a "Xonar DX Audio Center" in the Windows 7 Control Panel. On the resulting window that looks like a mixer control panel, there is a little round button labeled "GX" and highlighted with green. I clicked on it and the green highlight cleared.

    Now when I run the game and quit, no irritating feedback noise. I guess I found the right control.
    I hope this will be fixed soon.

    I have this experience also with Vindictus. All of my other many games: not. Only Vindictus and Rift do it.

    Thank you.
    Last edited by Jaim Sandar; 02-13-2011 at 09:31 AM.

  12. #12
    Soulwalker
    Join Date
    Feb 2011
    Posts
    3

    Default

    I get this issue without a crash. All I have to do is open the game to the shard selection menu and quit the game. Asus Xonar STX. I did confirm that this only happens when the device is in GX mode as selected by the Xonar control panel.

  13. #13
    Rift Master Josaline's Avatar
    Join Date
    Jan 2011
    Location
    Australia WA Perth
    Posts
    678

    Default

    I had the same problem with Rift. I did have a Xonar D2/PM, had another card the Xonar D1 and have yet to try it out in the game.

    I have had this problem with the D2/PM with almost all games I have played since installing W7.

  14. #14
    Shield of Telara C00lit's Avatar
    Join Date
    Nov 2010
    Location
    UK
    Posts
    731

    Default

    I've still not had anything back from support yet, I would suggest you all log the problem with support so hopefully the issue will be given a higher priority.

    Trion Support

  15. #15
    Soulwalker
    Join Date
    Feb 2011
    Posts
    1

    Default

    Many games will crash with GX mode enabled because it is not meant to be used with modern games that don't need EAX/DirectSound support for optimal sound.

    Just turn GX off and then only turn it on while playing games that need it.

    You won't miss out on anything (other than crashes) by having it turned off in games that don't need it, I promise!


    BTW, if you want to recover from the endless looping sound without rebooting, open the Device Manager and disable and re-enable the Xonar driver.

    If it tells you that you need to reboot when you try to disable it, you can get around it by doing the following:
    - click No
    - right-click the speaker icon in the system tray
    - select Playback Devices
    - right-click and disable all Xonar devices (usually Speakers and SPDIF)
    - repeat the Device Manager part (disable and re-enable Xonar driver)
    - right-click and enable all Xonar devices that you previously disabled

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts