+ Reply to Thread
Results 1 to 5 of 5

Thread: So far I need help....

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Posts
    10

    Default So far I need help....

    Well I finally got around to installing the game which required me to leave my comp on overnight. Got on Rift this afternoon and was excited I would finally get to play, then I get to the "loading character screen" part and it freezes at 89%, after about 3 minutes it says connection failed and asked if I wanted to exit Rift or Try Again. Naturally, I select Try Again and it freezes at 49% and every time after that 49%. So I restarted the game and same thing, first one was 89% the rest are 49%. I checked the Technical Difficulties page and it says Anti Virus software might be in the way, nope, not mine. It also said if you waited long enough, I did that, and the failed to connect thingy comes up. Do REALLY have to re-install the whole game or something..? Or should I just try again later and see if it blows over? OOOOR are the servers not up right now or something? I really hope I just missed something here, and that it's not an actual technical error.... Help!

  2. #2
    Telaran
    Join Date
    Feb 2011
    Posts
    67

    Default

    Quote Originally Posted by duravian View Post
    Well I finally got around to installing the game which required me to leave my comp on overnight. Got on Rift this afternoon and was excited I would finally get to play, then I get to the "loading character screen" part and it freezes at 89%, after about 3 minutes it says connection failed and asked if I wanted to exit Rift or Try Again. Naturally, I select Try Again and it freezes at 49% and every time after that 49%. So I restarted the game and same thing, first one was 89% the rest are 49%. I checked the Technical Difficulties page and it says Anti Virus software might be in the way, nope, not mine. It also said if you waited long enough, I did that, and the failed to connect thingy comes up. Do REALLY have to re-install the whole game or something..? Or should I just try again later and see if it blows over? OOOOR are the servers not up right now or something? I really hope I just missed something here, and that it's not an actual technical error.... Help!
    The servers are down. The confusing part is the existence of a similar error. Wait until The open Beta and try again.

  3. #3
    Soulwalker
    Join Date
    Feb 2011
    Posts
    10

    Default

    Quote Originally Posted by Zidaen View Post
    The servers are down. The confusing part is the existence of a similar error. Wait until The open Beta and try again.
    OH!!! Phew, I thought I did something wrong!! Well when are the servers going back up? Every weekend isn't it?

  4. #4
    Telaran
    Join Date
    Feb 2011
    Posts
    67

    Default

    Feb 15th.

    /10chars

  5. #5
    Soulwalker
    Join Date
    Feb 2011
    Posts
    10

    Default

    Quote Originally Posted by Zidaen View Post
    The servers are down. The confusing part is the existence of a similar error. Wait until The open Beta and try again.
    Quote Originally Posted by Zidaen View Post
    Feb 15th.

    /10chars
    Ok thanks so much man!

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts