+ Reply to Thread
Results 1 to 1 of 1
Like Tree1Likes
  • 1 Post By Echidna

Thread: Unable to install Rift

  1. #1
    Soulwalker Echidna's Avatar
    Join Date
    Sep 2011
    Posts
    19

    Question Unable to install Rift

    Hi,
    after a long break I want to play Rift again. I installed Glyph new, and when I want to install Rift, I see onlay a grey window for the terms of service and 3 buttons at the bottom of the window. The first button is "Download" - when I click it, I get directed to the terms of service in my internet-browser. The right butten is "Deny" - when I click it, the window closes. The button in the middle "Accept" - I can't click it. I think there must be a checkbox or something else, to accept the tos, but I have only this grey window.
    So I can't install Rift. Does anybody know this problem and can help me?

    My English is not good, but I hope, you can understand what I mean. I'm playing with the German client.

    ______________________________________
    Edit:
    I solved this problem: I downloaded Rift with Steam, and then it worked and I can play now .
    Last edited by Echidna; 07-31-2021 at 12:38 AM. Reason: solved

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts