+ Reply to Thread
Results 1 to 2 of 2

Thread: Glyph suddenly not working

  1. #1
    Soulwalker
    Join Date
    Aug 2011
    Posts
    16

    Default Glyph suddenly not working

    Glyph wont work since updating. Currently running windows 10. It just crashes every time i try to load. Any suggestions? Ive uninstalled/reinstalled 50 times now, ive followed every step on the web

  2. #2
    Soulwalker
    Join Date
    May 2020
    Posts
    1

    Default Same Issue and this is the data that Trion gave me..

    Quote Originally Posted by Aador View Post
    Glyph wont work since updating. Currently running windows 10. It just crashes every time i try to load. Any suggestions? Ive uninstalled/reinstalled 50 times now, ive followed every step on the web
    ClaireTuesday at 02:44
    Greetings,

    Thank you for contacting us.

    To troubleshoot this issue, please completely close your Game and Glyph.

    Then please follow the steps below:

    Launch Glyph
    Sign in to your account
    Right-click on RIFT in the top-left corner of the launcher and select the "Repair" option
    When prompted to begin file recovery, please click the "Yes" button
    Allow the repair process to go through
    Re-launch your game
    Should the above solution not work, it could be due to some corrupted data left over from the patch. This can be resolved by the following:

    Press the Windows key + R at the same time to bring up your run prompt.
    Type in %appdata% and click 'OK'
    Delete the RIFT folder
    Attempt to load the game again
    Kind Regards,

    Claire

    AND ALSO....
    ClaireTuesday at 08:28
    Greetings,

    Thank you for your response.

    Please check if all your drivers, the .Net framework and windows installer are up to date. Then proceed to uninstall Glyph and remove the left over data (if any) as below:

    Press the Windows key + R at the same time to bring up your run prompt.
    Type in %appdata% and click 'OK'.
    Delete your game's folder.
    Perform a disk cleanup and clear your browsing history before downloading the latest version of Glyph from the link below:
    https://store.trionworlds.com/accoun...ut.action?dd=1

    After the download, please right click on the Glyph icon and select 'run as administrator', enter your log in details, proceed to Settings > General and change from 64 bit to 32 bit.

    Kind Regards,

    Claire


    BUT this remains an issue on LAPTOP... that had an Windows update.. The 2 CPUs have no issue but i refuse to Update those with Windows Auto Update OFF>>
    BadJaws Over and Out..

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts