+ Reply to Thread
Results 1 to 7 of 7

Thread: you are not running the correct version of the game please exit the game

  1. #1
    Soulwalker
    Join Date
    Apr 2019
    Posts
    2

    Default you are not running the correct version of the game please exit the game

    you are not running the correct version of the game, please exit the game as there may be a new patch on the way. As above after 4/4/2019 server maintence went down for new patch i cant find a way to update it via the launcher or any other means of updating the game to the new version
    Last edited by chibz84; 04-04-2019 at 09:05 AM.

  2. #2
    Soulwalker
    Join Date
    Apr 2019
    Posts
    1

    Default same here

    tried to play the game today with a friend of mine. we both got the same problem as described above. we tried to repair and install totally new, but without any effect

  3. #3
    Ascendant Onebutton's Avatar
    Join Date
    Jan 2011
    Posts
    2,069

    Default

    This usually just means the patch is not synced yet with the game, so just wait and eventually the patch will work properly for you. They might actually be updating the patch again as well since it has gone over time a bit today.

    Sometimes you can also try to run the patch from the rift folder directly. It should all be resolved withing the next 30-60 minutes I am guessing.
    OneButton (Half-way now to becoming a two-button player!)
    If there is anything you need, just ask, and I will tell you how to get along Without it!
    "One button raider for life!"

  4. #4
    Soulwalker Deshmiriai's Avatar
    Join Date
    May 2011
    Posts
    19

    Default Patcher will update again

    Yep! As Onebutton said, sometimes they apply the patches in sections. I get the same error when it's mid-update. Wait 5-30 min and completely restart the glyph client. It should update and fix itself.
    Rogue/Mage/Warrior/Cleric/Primalist
    70/70/70/70/70 Both Guardian and Defiant - 'cause we're all friends now! More or less.
    Estrael/Silkweb/Greenscale Shards- now Greybriar/Hailol/Wolfsbane.. old shards rest in peace, you were awesome
    (Proud raider and clearer of content for 7+ years now)

  5. #5
    Soulwalker
    Join Date
    Apr 2019
    Posts
    2

    Default

    Quote Originally Posted by Deshmiriai View Post
    Yep! As Onebutton said, sometimes they apply the patches in sections. I get the same error when it's mid-update. Wait 5-30 min and completely restart the glyph client. It should update and fix itself.
    Thanks for the info guys and will do

  6. #6
    Soulwalker
    Join Date
    Feb 2014
    Posts
    2

    Default "incorrect version of the game" error

    I am currently trying to apply todays patch (11th April 2019), however, even after the update is downloaded, I still get the "incorrect version of the game" error when I log into the game, then when I change to North America in the Glyph launcher there is an update to download for that, once this is done and I change back to EU, the download starts again. Has anyone else had this problem and is there a way around this?

  7. #7
    Soulwalker
    Join Date
    Mar 2011
    Posts
    16

    Default

    Quote Originally Posted by davepro View Post
    I am currently trying to apply todays patch (11th April 2019), however, even after the update is downloaded, I still get the "incorrect version of the game" error when I log into the game, then when I change to North America in the Glyph launcher there is an update to download for that, once this is done and I change back to EU, the download starts again. Has anyone else had this problem and is there a way around this?
    Over and over again, with today's update. Don't know of any workaround

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts