+ Reply to Thread
Results 1 to 1 of 1

Thread: Game Updates won't download/getting stuck

  1. #1
    Champion
    Join Date
    May 2011
    Posts
    585

    Default Game Updates won't download/getting stuck

    After an absence of about 6-8 months, I decided yesterday to return to Rift. No problems logging in, and Glyph started to download updates.

    The first two were small, but the third one is 6.10 GB. It started the download from the Glyph screen, and when it got to 2.9 GB download out of 6.10 GB, the play button lit up. I opted to go for that because after sitting there for about 10 minutes, Glyph refused to download anything beyond the 2.90 GB it had already downloaded.

    Once in game, I got an moving icon on top of the screen that showed it was downloading again. I played for several hours, when I noticed that the download had stopped at 3.04 GB. After that, it didn't matter if I went to the Glyph screen, the character selection screen (which also has that icon on the center top of the screen), or go into the game and play. The game refused to download past 3.04 GB.

    The worst thing about this is that in order to get control over my computer back, I had to exit the game and Glyph, which resulted in a warning that I would lose the download that was already completed. I got this warning also after I paused the update, figuring I would leave the game and Glyph and try to resume today. But, there's no "resumption," once you exit you've lost the download.

    One thing I forgot to mention. Twice the icon on top of the window showed a 2.4KB per second download speed but it refused to go higher, and eventually after about 15 seconds it disappeared and never returned, and the downloaded amount stayed at 3.04 GB.

    I run W10, 64-bit, video drivers updated yesterday, NIVIDIA.

    If you have any suggestions, I would appreciate it.

    NOTE: OK, I restarted Glyph, and it only had the play button, nothing about downloading updates. I started the game, and have the icon on the top of the screen, with the download speed over 300 KB/ps, which is normal for my Verizon DSL, and it's downloading the remaining parts. Makes me wonder why it didn't do this yesterday afternoon/last night, but it's working now, so no complaints.
    Last edited by Raptor7; 01-31-2018 at 06:10 AM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts