+ Reply to Thread
Results 1 to 2 of 2

Thread: Error 0xc000007b

  1. #1
    Telaran
    Join Date
    May 2013
    Posts
    72

    Default Error 0xc000007b

    Prevents client from opening, figured out how to fix it after I noticed I had 2 copies of the 32 bit and no 64, this has apparently been an issue with Rift since like 2014 and it hit me today when I tried to come back to the game.

    I can only imagine cuz it runs on such an old version of dx which are a pain to download now with newer versions of windows as most won't let you run them since you have the latest version already.

    How to fix:

    You need a D3DX9_43.DLL that is 32bit, and one that is 64bit. You can download either one from dll-files (simple google search).

    The 64 goes into your C:\windows\system32
    The 32 goes into your C:\windows\SysWoW64

    Problem solved... now hopefully this thread comes up in the google search instead of all of those needless threads telling you to download 3rd party garbage, scan this, scan that, etc.

    If mod could edit my title to say 'Rift Error 0xc000007b' without quotations would probably help the search out since I wasn't thinking about it at the time.
    Last edited by Magdaer; 10-03-2017 at 06:06 AM.
    Bro do you even Rift?

  2. #2
    Rift Chaser
    Join Date
    Jul 2014
    Posts
    311

    Default

    I've seen this issue before, in this post: http://forums.riftgame.com/technical...ease-help.html

    I would love to know why it occurs, but I would guess it's some kind of Windows upgrade issue, generally DirectX is pretty good with it's DLL installs. RIFT itself doesn't mess with DirectX apart from running it's Runtime during install, so if the wrong DLLs were installed, I wouldn't think it's RIFT's fault, though it exposes the issue due it's use of the older DLLs.
    Last edited by Spikeles; 10-04-2017 at 12:27 AM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts