+ Reply to Thread
Results 1 to 12 of 12
Like Tree2Likes
  • 1 Post By Charysh
  • 1 Post By Charysh

  Click here to go to the first Rift Team post in this thread.   Thread: Can't add a payment method

  1. #1
    Soulwalker
    Join Date
    May 2017
    Posts
    23

    Default Can't add a payment method

    I have tried to add my credit card for a payment method. Put all the information in, hit send, and nothing happens. I do have ublock, adblock and noscript which I either turned off or did the temporarily allow and still nothing... Caught a quick glimpse of waiting.... in the bottom left corner but couldn't see it all.

    Help?

  2.   Click here to go to the next Rift Team post in this thread.   #2
    Customer Support Hesk's Avatar
    Join Date
    Apr 2016
    Posts
    128

    Default

    Hello! Clearing cache & cookies, or trying another browser may resolve the issue for you, but if it does persist, please submit a support ticket at support.trionworlds.com so that our Customer Service team can investigate.

  3. #3
    Soulwalker
    Join Date
    May 2017
    Posts
    23

    Default

    I have done that and I still can't add my credit card. Input all the information, hit send, and nothing happens. My information remains there. It just doesn't do anything. I have submitted a ticket (906927) and still waiting for a reply.

  4. #4
    Soulwalker
    Join Date
    May 2017
    Posts
    23

    Default

    Welp, customer service reset my payment method (which I have never been able to enter in the first place) twice and it still doesn't work. They say my only alternative left is to contact my financial institute, which is ludicrous because I have a zero balance, never in all the times I've used online have I ever had a problem, and my information isn't even going anywhere. There are no errors, no screen change, nothing. Has anyone out there had this problem before??

    I guess I will remain f2p even though I would love to become a patron and get some credits....

  5.   This is the last Rift Team post in this thread.   #5
    Customer Support Hesk's Avatar
    Join Date
    Apr 2016
    Posts
    128

    Default

    Ad blockers and things of that nature may also be a part of the problem - if you use one, please try disabling it while adding your information. What browsers were able to try with?

  6. #6
    Soulwalker
    Join Date
    May 2017
    Posts
    23

    Default

    It's me again... I still can't add a payment method. I have had multiple emails back and forth with customer service and tried all their suggestions with nothing helping. They came to the conclusion that they believed it might be my physical address that the website doesn't like. That is something I really can't do anything about..lol. If anyone has any idea why the website is not taking my input, please let me know. Never have I worked this hard to give a company money!

  7. #7
    Soulwalker Murolosch's Avatar
    Join Date
    May 2017
    Posts
    2

    Default You are not alone

    Titel says everything. There are a lot of players in germany with this problem, too.
    Clearing cache & cookies, or trying another browser, Ad blockers and things of that nature are definitly not part of the problem.

    I also tried to use my linux mint and another computer.

    The problem is definitly the server!

    Please fix it...i know it`s f2p....but maybe that's not how it's meant to be


  8. #8
    Soulwalker Murolosch's Avatar
    Join Date
    May 2017
    Posts
    2

    Default

    Steam did it. I bought via Steam. That worked

  9. #9
    Soulwalker
    Join Date
    May 2017
    Posts
    3

    Thumbs down Still not working for me

    when i try to add CC Information Server tells me that he is unable to verify Billing adress.

    when i try to use PayPal server tells me that my Paypal Acc is registered in another Country then my current Account EMail Adress lol

    No Money from me then
    Last edited by Daytime; 05-20-2017 at 08:44 PM.

  10. #10
    Soulwalker
    Join Date
    May 2017
    Posts
    23

    Default

    Update here: After numerous emails back and forth with customer service it was finally decided that they didn't know what the problem was but that they would work on it. They even gave me some credits for sticking with it..lol. They evidently continued to work on the problem because I tried it today and IT WORKED!!! I am now a happy patron with plenty of credits!

    Customer service was awesome I must say. They were quick to respond and worked many angles without success at that point and was truthful with me about it. So, Kudos to Senior GM Soulwalker and your team!

  11. #11
    Rift Chaser
    Join Date
    Mar 2014
    Posts
    334

    Default

    Quote Originally Posted by Charysh View Post
    Update here: After numerous emails back and forth with customer service it was finally decided that they didn't know what the problem was but that they would work on it. :
    I wrote also some tickets, because I canīt add a payment method. The "Send" Button donīt work.

    I finally decided that they didnīt know what the problem is and closed my ticket.

    Quote Originally Posted by Murolosch View Post
    Clearing cache & cookies, or trying another browser, Ad blockers and things of that nature are definitly not part of the problem.
    Same here. I also tried another Pc and Browser: Opera, Firefox, Mircrosoft Edge and Explorer. I donīt wish to add more browser only to try if they works for Rift-Shop. It isnīt a problem of my financial institute because my credit card works in other cases.

    I canīt buy in your shop.
    Last edited by Maelya; 07-09-2017 at 11:42 PM.

  12. #12
    Soulwalker
    Join Date
    Jan 2011
    Posts
    4

    Default works from one PC but not from another

    My husband has this problem. He tried several times over several days when he clicked submit to add a new credit card nothing would happen.

    I tried from my PC by logging to his account and add the credit card and it worked. I did the exact same steps as him.

    We have the same desktop computer (Dell) with the same version of Windows OS and same browser (Edge).

    I had a problem before with bank information not displaying correctly while he could display the information on his PC and when I logged to his PC my banking information would display just fine. We went through the various browser options and set mine the same as his and this fixed the problem.

    My guess is that this problem is something related to that.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts