+ Reply to Thread
Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By Monmaagi

  Click here to go to the first Rift Team post in this thread.   Thread: BUGGED Battle of Saint Taranas BUGGED

  1. #1
    Soulwalker
    Join Date
    Mar 2011
    Posts
    2

    Default BUGGED Battle of Saint Taranas BUGGED

    I did the go to the front lines,
    defeat Gedlo forces 20/20,
    Use the Dragonslayer Ballista,
    Weaken Garn with Armor Piercing Bolt,
    Fall back to the second armor Piercing bolt,
    Chain Garn to Iron Pillars using Hunter's Harpoons 3/3,
    Attack Garn,
    Fall back to Saint Taranis
    and the last part Fight Garn I CAN'T do cause he never followed me to Sant Taranis. He is still stucking flying in the air where I did the Pillars. I tried abandoning the quest twice and it didnt do a thing to helpe me. I also went back to where Garn is flying and stuck in the air flying and nothing has helped me with that too. He still never followed me or anything.. SO how the heck am I suppose to finish a story quest if he is still stuck flying in the air at the previous place????????????????????

  2.   This is the last Rift Team post in this thread.   #2
    Customer Support ZamboniChaos's Avatar
    Join Date
    Feb 2016
    Posts
    271

    Default

    Hey there! If you're having trouble with this quest, go ahead and submit a ticket so our CS team can help.
    Need help? Contact our Customer Support team here!

    Trion Worlds Support Center
    @TrionHelp
    facebook.com/TrionHelp

  3. #3
    Soulwalker
    Join Date
    Feb 2018
    Posts
    4

    Default Still BUGGED Battle of St Taranis

    Apparently the fix for this bug is no longer working. I'm experiencing the same issue as the above poster. 1st and 2nd part complete fine, but when going back to town, no Garn shows up to fight. Yes, I did submit a request for help with this issue. I've logged out, logged back in. Dropped the quest many times, repicked up the quest, even rebooted my computer, but all for nothing. When I pick up the quest again, I'm still back in town with no Garn to fight. I'm spent over an hour trying different things to get this quest chain back on track. Hopefully someone at Rift will have mercy and fix this quest line once and for all.

  4. #4
    Soulwalker
    Join Date
    Feb 2018
    Posts
    4

    Default Work around for this bugged quest.

    As a last ditch effort, I switched to another shard besides faeblight, and that worked for me. Hopefully, this will save someone else hours of frustration in trying to complete this quest line. FYI and I'm not pointing a finger a CS, as this is a weekend evening, I hope to hear from that department on Monday.

  5. #5
    Telaran Saido's Avatar
    Join Date
    Feb 2011
    Posts
    96

    Unhappy

    ... and I'm stuck on the 'chain' part. First chaining went fine; since then I've spent nearly 45 minutes channeling chains (yes, standing next to the pillar, with the dragon barbecuing my face )... stuck at 1 of 3.

    Is this a "come back at 70 unless you're in raid gear" sort of quest?
    Last edited by Saido; 07-14-2018 at 08:12 PM.
    ~ Hana ~ Thorn ~ Mirceliade ~ Zondria ~ Amatsoni ~
    <Mythical Creatures>

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts