+ Reply to Thread
Results 1 to 7 of 7

Thread: RIFT goes to black screen on start up.

  1. #1
    Soulwalker
    Join Date
    Apr 2015
    Posts
    1

    Default RIFT goes to black screen on start up.

    After launching RIFT from GLYPH my screen just goes black. I can hear the main screen music and i can see my cursor but i cant seen anything. My other games work just fine and Rift loaded correctly once and i played it for about 15 minutes. All my drivers are up to date. If you know anything i can try to fix this it would be a huge help.

    Here are my system specs.
    OS: Windows 8.1
    Resolution: 1366x768
    Processor: intel celeron 1007u 1.5ghz
    Graphics: Integrated Intel® HD Graphics.

    EDIT: As soon as i made this i restarted glyph and launched rift and it works. Idk what happened but everything is working well now.
    Last edited by Kornholleo; 04-11-2015 at 01:33 PM. Reason: Problem solved

  2. #2
    Prophet of Telara Kadeth's Avatar
    Join Date
    Apr 2012
    Posts
    1,145

    Default

    Your computer does not meet the minimum requirements to run the game.

    http://www.systemrequirementslab.com...rift/11092?p=r

    That tells you what you need and, checks your computer for what is lacking.
    Life is what you make it so make it good, even when it isn't.

  3. #3
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Question

    I get the same thing.


    Windows 8.1
    Resolution 1920x1080
    i7 Quad Core 2.4 GHz
    NVidia GeForce GTX 770M with 3 GB dedicated memory
    Almost a TB of free disk space


    I just reinstalled Rift, after a while of being gone. Glyph is new to me. This has persisted through several shutdowns and restarts. It doesn't prevent playing the game. If I hit ESC, it will exit the beginning cinematic (that I can't see anyway) and go to the character selection screen. I can play the cinematic from there, if I choose, so I know that works. I can get into the game just fine, from there, as well. It's just annoying and it's not supposed to do that, so it's driving me nuts.


    Just venting. If anyone knows why this happens, though, I'd love to know. It's probably windows 8. I hate windows 8.
    Yup... spelling and grammar errors will abound in my posts. Get over it.

  4. #4
    Soulwalker
    Join Date
    Apr 2015
    Posts
    7

    Default Same as i

    same with me. im not sure if my computer specs is out of minimum requirements. i dont know how to compare computer specs. and if im going to uninstall it, it would take toooo long for me to download and install..
    can someone help me with it? MY SPECS

    OS win 7 64bit
    core i3 with 8gb RAM
    and built in graphics Intel(R) Graphics (Core i3)
    - approx 1696 MB



    thank you so much. really appreciate your help

  5. #5
    Telaran Ernbrecht's Avatar
    Join Date
    Feb 2012
    Posts
    90

    Default

    I experienced something similar after reinstalling the game on a new OS installation recently. On the first launch, what appears to have been the intro cinematic only gave me a black screen, while the sound played just fine. I'm not sure though if I had to force-quit and restart the game, or if I was able to just skip the cinematic. Either way, I'm getting to the character selection screen just fine now.
    "I am a leaf on the wind, watch how I soar!"
    -- Hoban Washburn

  6. #6
    Soulwalker Aleanda's Avatar
    Join Date
    May 2013
    Posts
    5

    Default Black screen

    Not sure where to put this it sounds like something similar to this thread. I just had the weirdest crash. I was in Silverwood doing the zone event and while fighting the one boss the screen went black but I could still hear the sound. I could not minimize the game and tried control alt delete. Then the Rift error report message came up and started filling up the screen with multiple error reports saying the error had been reported like something out of Windows 95. I also got a message saying Rift was blocked from accessing the graphics card. I'm running Windows 8 and I am not technically inclined, I am on a laptop with nvidia geforce gtx 670mx and an Intel core i7. I kind of had a moment of panic, maybe I played too long but I'm so close to 65. Rift marathon...I hit the power button because everything was locked up and Rift has worked fine so far. This has happened a few times before but only rarely and never before with the multiple error pop ups. Not really looking for help as long as the game works again I just thought it was bizarre.

  7. #7
    Shadowlander A World Maker's Avatar
    Join Date
    Oct 2012
    Posts
    26

    Default

    That is probably due to memory leaks, causing a gradual decline in available registers space and crashing the graphics driver. Only advice is, make sure your pagefile/swapfile is in the region of twice that of your systems ram. This is moreso important if your system ram is being shared.

    With your setup, it would be better the faster and more system ram you have to support the i7 CPU and Win8
    Politeness is priceless when received, cost nothing to own or give, yet some cannot afford.
    Checkout A World Maker aka Trepid

+ Reply to Thread

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts