+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 25
Like Tree3Likes

Thread: Rift 3.0 still crashing on Mac using Emulators

  1. #1
    Soulwalker
    Join Date
    Sep 2014
    Posts
    13

    Default Rift 3.0 still crashing on Mac using Emulators

    I was able to run 3.0 successfully for a few hours on release. Ever since they released hotfix #1, my client has failed to load. I usually get stuck on 14% and 22%, very few times the character screen loaded before crashing. Rift has always ran perfectly prior to these hotfixes and even ran well on 3.0 release. I don't know if Windows users are having the same troubles, but I would appreciate any advice. I'm assuming it's a patch problem, but I could be incorrect. Hopefully trion fixes these "bad" patches that apparently went out. I re-downloaded the game last night (48 hours after the bad patch went out and was "fixed") and have been reaching the same failed results.

    I have tried repairing the game with glyph several times, used the task set command, and a number of alternate boot options and have not been achieving any results. I am running the latest version of crossover and running OS X Yosemite 2.3 GHZ Intel Core i7 with 4 gb of ram.
    I have used wine before but have had the best results with Crossover.

    NVIDIA GeForce GT 650m 512 MB Graphics card

    Rift has always ran flawlessly on my computer and I was able to enjoy 3.0 on day of release before it was shut down. Any feedback that may lead me to being able to play the game again would be appreciated, else I will wait for Trion to come up with the Hotfix.

  2. #2
    Soulwalker
    Join Date
    Oct 2014
    Posts
    24

    Default

    Hi! Yep, the Codeweavers (and I assume WINE) people are aware of it: https://www.codeweavers.com/compatib...m=1;msg=168092

    There's a workaround that works for Linux users (using taskset), but I don't know if you can schedule your CPU's cores the same way on a mac.

  3. #3
    Soulwalker
    Join Date
    Sep 2014
    Posts
    13

    Default

    Appreciate the link, I will look into the proposed solutions. I tried a simple taskset command but the game was running off a single core and was too slow.

    What was interesting is that I was able to play 3.0 the first day, so whatever was in the first two patches must have been out of the crossover coding.

    If anyone else has a solution, please do post!

  4. #4
    Soulwalker
    Join Date
    Sep 2014
    Posts
    13

    Default

    After reading the post, I found a temporary solution.

    Steps:
    1: Open a terminal window
    2: Navigate to your Crossover/Wine directory and find the launcher file for Glyph
    3: run the command #taskset -c 0,7 and just drag the launch file into the terminal window

    Notes: You will be running the game without the full processor capabilities (on lower details it still runs smoothly) but it will not be as good as before. For whatever reason, 3.0 has processor requirements that have not been updated with Crossover/wine.
    Sounds like upcoming versions will be fixing the problem but this will get you playing rift for the meantime.

    If anyone has better solution please post!


    #taskset -c 0,7 /Users/DJ-KR/Library/Application\ Support/CrossOver/Bottles/GlyphInstall.exe/drive_c/Program\ Files/Glyph/GlyphClient.exe

  5. #5
    Champion
    Join Date
    Feb 2013
    Posts
    555

    Default

    Quote Originally Posted by Ciaviel View Post
    Hi! Yep, the Codeweavers (and I assume WINE) people are aware of it: https://www.codeweavers.com/compatib...m=1;msg=168092

    There's a workaround that works for Linux users (using taskset), but I don't know if you can schedule your CPU's cores the same way on a mac.
    I'm having very much the same issue pavihail but it seems that files end up missing . in weird ways. hope it gets fixed soon.

  6. #6
    Soulwalker
    Join Date
    Oct 2014
    Posts
    24

    Default

    I'm kind of surprised that more aren't having this issue. It sounds like if RIFT is running on consecutive cores, it'll crash. Likewise if 0 isn't in use for RIFT. That sounds like a bug on RIFT's end, and something they might want to fix. (Especially if it started happening after the first hotfix.)

  7. #7
    General of Telara
    Join Date
    Mar 2014
    Posts
    967

    Default

    Don't know why it seems to work for you, but for me allowing it to use more than one core consistently makes the client crash at startup, I tried all kind of combinations (Core i5 CPU).

    Anyway, it currently looks like this is not even our real problem with 3.0 (at least on Linux). You can reset the CPU affinity after you logged in to use all cores again, by giving taskset the PID of the rift.exe process.

    But the game still runs like sh**. Trion apparently did add more multithreading with 3.0 (Daglar mentioned it in one of the whining threads recently), and it makes excessive usage of synchronization primitives that need to go throug wineserver, which absolutely kills framerate, to the point where you get a slideshow and eventually other problems like stuck keys and weird sound output at zone events.

    And I was really looking forward to NT and planned to get one of the CE, but currently my optimism that I can stay with Rift is slowly fading...

  8. #8
    Soulwalker
    Join Date
    Sep 2014
    Posts
    13

    Default

    Depending the specs of your computer, also varies the amount of cores needed to run the game. It is a bit odd that this problem presented itself after the second hotfix but if they added furthur multithreading, then it would require more of a CPU load. It has been running fine with 7 running, 0-7 has been the right combination for me. I experience some lag but nothing too serious. Most of the other combinations have also resulted in the initial browser loading to crash. I have been reading that some windows users have been experieincing the same problem.
    0-1 crashes
    0-5 Really laggy
    0-7 Works for me

    The core 0 is required to play, any combinations other than 0 have crashed for me. I love Rift but before I plan on paying any money into this expansion, I would like to see this problem fixed or hope this "temporary fix" continues to work.

  9. #9
    Soulwalker
    Join Date
    Oct 2014
    Posts
    24

    Default

    For me taskset -p 0xf <PID of RIFT> works. Although if I zone too many times over the course of an hour or two, it'll crash.

  10. #10
    Shadowlander Nezac's Avatar
    Join Date
    Jan 2014
    Posts
    29

    Default

    I just wonder why you are discussing Linux answers here, when actually Mac was the topic!

    I'm having this problem too on a 2011 iMac 12GB ram.
    Prior to Crossover 14.0.0 I couldn't even install Glyph.
    Now the client worked fine (which made me really happy at first) but the game crashes after start and before I reach the character screen.

    I'd really look forward to a solution to this (and I actually hoped to be able to play patch 3.0 again...)!

  11. #11
    Soulwalker
    Join Date
    Aug 2014
    Posts
    14

    Default

    Another update and still no luck

    Looks like I won't be playing for a while, or at all.

  12. #12
    Soulwalker
    Join Date
    Sep 2014
    Posts
    13

    Default

    So my client only seems to run for about 2-3 hours until crashing. After that, even with the various taskset commands, my client fails to restart. Only after restarting my computer am I able to get my client running again using
    #taskset -c 0,7

    I tried #taskset -p <Rift PID> and it didn't work either.

    I really hope Trion/Crossover fix this problem soon. 3.0 is AMAZING and I want to be able to reliably play.

  13. #13
    Soulwalker Syda's Avatar
    Join Date
    Nov 2010
    Posts
    18

    Default

    Yup i have same problem. Crossover 14 osX 10.8.5. Filed a ticket to codeweavers, afaik they are looking into it.

  14. #14
    Soulwalker Syda's Avatar
    Join Date
    Nov 2010
    Posts
    18

    Default

    interesting workaround from the official forums.

    https://www.codeweavers.com/compatib...m=1;msg=168092

    If you delete EULA=300 from rift.cfg it forces to accept eula again and it logs to char select screen. Next time you want to play, unfortunately you have to delete that row again.
    Last edited by Syda; 10-30-2014 at 05:50 AM.

  15. #15
    Soulwalker
    Join Date
    Oct 2014
    Posts
    2

    Default

    I can confirm that deleting the EULA=300 line stops the crashing. Then, so that I won't have to do it all the time, I simply changed the rift.cfg file permissions to "read only" so that the game won't add the line next time I log in.

    While it also means that any graphics changes I make don't get saved either, I can always re-enable writing of the file to change settings, then lock it up again after removing the EULA line. Personally, I find this fix on the far more acceptable side than locking RIFT to a core or two and suffering a performance loss.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts