I was playing without incident just two nights ago so I have no idea what changed or caused it to suddenly fail. There were no changes done by me.

I am not using BootCamp (yet) which installs Windows on a separate partition on the hard drive so at startup you can choose to boot in Windows or boot into Mac.


However, several other options are available to run windows programs on a mac: virtual machines (Parallels, VirtualBox, VMWare) and emulators (CrossOver).


I decided to go with CrossOver for ease of use and performance and followed their instructions here:

https://www.codeweavers.com/via/RIFT/

I installed CrossOver with no problems. RIFT is one of their "Supported Applications" so I clicked the "Install RIFT now" button on their webpage (which is the same as starting CrossOver and choosing to Install a New Program from the wizard or choosing Configure > Install Software > and choosing RIFT from their list of Supported Applications > Download installer > New winxp Bottle). The install also installs helper programs (Core Fonts, Direct X 9, Microsoft Visual C++ 2008 (9.0) Redistributable) so it will function properly as if in Windows.

The installation requires some user interaction to click through the dialogue boxes but goes fairly quickly.

When it was done, Glyph was installed and started downloading the RIFT game. That download can take a while depending on your internet download speed. When that finished, I clicked the Play button and the Glyph client launched where I entered my email address and password and it signed me in just fine.

That was over 2 weeks ago and it has been running just fine ever since, until 2 nights ago.

Now here's where I think the problem comes in. I decided to try the Rift Authenticator on my mobile phone. That was working fine too, but I didn't realize that if you uninstall it and/or re-install it it causes problems with your Trion Worlds (RIFT) account as well.

Here is a copy of the email I sent to support@trionworlds.com (which generated an auto-reply from "trionworld1@mailwc.custhelp.com"):

Question Reference # 141015-000370

Date Created: 10/14/2014 08:11 PM
Date Last Updated: 10/14/2014 08:11 PM
Status: Unresolved

-----------------------------------------------------------------------

"The login request was not valid. Please try again later. (Error #2016)"


My user login (email) and password (that I just changed today after learning about your DOS and network problems because I wanted to protect my account) are both current and valid. They seem to work if I log in to your website on my cell phone browser (also using the Rift Authenticator app for the code), but NOT when I try from my home computer's browser OR via the Glyph app.


From my mobile phone (Samsung Galaxy Note 3 on T-Mobile running JellyBean v4.3) using the Chrome browser I was able to navigate to your main page (http://www.trionworlds.com/en/games/rift/) and click the Sign In link at the top and get to the point where it asks for my Authorization Code (https://rift.trionworlds.com/account...n!input.action). I checked my email and waited but the code never came, so I used the Rift Authenticator app I also have installed on my phone. That worked, and I am now signed in to my account ONLY on my phone.

However, when I launch the Glyph client on my home computer and use the same login (email) and password that I used to successfully sign in on my phone, I get the above error and it never signs in.

I was signed in and played Rift yesterday evening after work but have no idea why now I cannot. What has changed? My roommate has the exact same phone and carrier and did the exact same procedure as me as detailed above and he can log into his account via phone browser but NOT via Rift client (with same error message) the same as me.

Please advise. We are wanting to start paying for your service (Patron status as I understand it), but not if inconsistencies or complications in the sign in process will prove frustrating. I thank you in advance for your assistance and prompt reply.

The two user accounts attempting to sign in via the Glyph client are...

-----------------------------------------------------------------------

I submitted two separate Help Request tickets (https://support.trionworlds.com/app/ask2?) yesterday at 8:11 PM and now it has almost been 24 hours and I have not heard back from them yet. Twelve hours ago I sent this follow-up email:

-----------------------------------------------------------------------

Unable to log in on your website (Sign In) OR via the Glyph app. Installing/removing the Rift Authenticator app on my Android phone seems to have screwed things up.

If I can't play the game, I can't decide to pay for monthly service. Please advise, and do NOT WAIT many days to a week as people in the forums have posted that it takes you to respond. Frankly, that is unprofessional and starts rumors and negativity towards you and your efforts which isn't fair to you and us.


Thanks in advance for your assistance and prompt reply.

-----------------------------------------------------------------------


So now I am not sure what caused this or how to fix it. Tonight I am uninstalling CrossOver and Glyph/RIFT and starting over. I HAVE tried the following suggestions as well, to no avail:

-- Flushed Mac OS X DNS

-- Allowed firewall access: configured Mac firewall and Little Snitch to allow Glyph (~/Applications/CrossOver/Glyph/Glyph.app) and RIFT (~/Applications/CrossOver/RIFT/Play RIFT.app) and their general processes and Windows files full access to both Incoming and Outgoing connections (all protocols/all ports) - added as exceptions; also tried disabling the firewall

-- Ran as Administrator

-- Ended background tasks and services

-- Disabled anti-virus but also whitelisted Glyph and RIFT (added as exceptions)

-- Restarted router and modem

Steps I have NOT tried because of system limitations:

-- Going into C:\Users\(my username)\AppData\Local\Glyph and deleting the Cache folder inside

-- Clean boot state for Windows XP

-- Connecting via ethernet cable instead of via WiFi

My parameters:

17" early 2008 MacBook Pro 2.6GHz w/4GB SDRAM running Mac OS-X (v. 10.9.5 - Mavericks) and CrossOver (v. 13.0.1.27646).

Samsung Galaxy Note 3 on T-Mobile running Android 4.3 (JellyBean)

Browsers tried: Safari, Google Chrome, Firefox

ANY HELP IS MOST APPRECIATED as I realize now that I am not the only one facing these issues without resolution. Thanks all !