Hi there... I have tried searching for the minimum/maximum system requirements for the 3.0 expansion but cannot seem to find it anywhere! Could someone please enlighten me on what these could be?