+ Reply to Thread
Results 1 to 2 of 2

  Click here to go to the first Rift Team post in this thread.   Thread: RIFt won't let me update.

  1. #1
    Soulwalker blissfulghost's Avatar
    Join Date
    Aug 2014
    Posts
    13

    Default RIFt won't let me update.

    New patch has come out and after it its hasn't let me press the update button. Nothing happens when it gets pressed. Any ideas ?

    Also I've tried all the recommended troubleshoots, modem checked and updated and still no difference.

  2.   This is the last Rift Team post in this thread.   #2
    Community Manager Fasti's Avatar
    Join Date
    Mar 2013
    Posts
    2,134

    Default

    Hey!

    I definitely don't want to ask you to duplicate steps, so take a look at this article for me.

    Try any steps you haven't done yet. as they will usually get you fixed up.

    If the Play/Update button still won't react when clicked, try the steps here for downloading the DX 9 files RIFT needs.

    Thanks!

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts