As the title says.
I made a purchase on the Rift store.
It first came up with an error message saying to retry the purchase, however it then took the credits for the item (I had just bought that very same day as a birthday present to myself...) but no item appeared.
I have tried the Glyph support and written them 2 'questions'.
I wrote my first enquiry on the day of the incident. My second 2 days later, expressing my further concern.

I have not received a reply to either.

Of course by now I am getting quite annoyed.
I realise and understand that it takes time to get back to somebody but I feel that getting no reply at all to be highly frustrating and unprofessional.

I have -
1) Paid for something that I haven't got.
2) Tried to contact Trion
and 3) Waited

I have so far done everything correctly, but I feel rather let down by lack of response.

Apologies for posting here but I am unsure what else I can do.
I either want my item or my credits back.
I hope somebody sees this who can help.

Thanks.