+ Reply to Thread
Results 1 to 11 of 11

Thread: RIFT not using dedicated GPU.

  1. #1
    Soulwalker
    Join Date
    Sep 2014
    Posts
    7

    Default RIFT not using dedicated GPU.

    Hello.

    I have the exact same issue posted in this closed thread: http://forums.riftgame.com/technical...ntegrated.html

    I have tried the workaround: right clicking the rift.exe and choosing 'Run with grapihcs processor' -> 'High-performance NVIDIA processor'.

    It literally does nothing. The game and even launcher doesn't even start.
    I suppose it's due to there now being a launcher (Glyph) that this workaround doesn't help anymore?

    I have the exact same computer by the way as the one in the thread I posted.

    Any help is appreciated.

  2. #2
    Soulwalker
    Join Date
    Sep 2014
    Posts
    7

    Default Steam and GeForce Experience.

    I saw the game was available on Steam, and uninstalled to reinstall by Steam in any hope it would work. Sadly it hasn't so it is still relevant. Hoping for a reply.

    I have also noticed RIFT is no longer found by GeForce Experience. It used to show up when I first tried RIFT many months ago (before Glyph by the way).

  3. #3
    Soulwalker
    Join Date
    Sep 2014
    Posts
    7

    Default NVIDIA GeForce thread.

    For reference: I have also posted about this problem now on the NVIDIA GeForce Support forums:
    https://forums.geforce.com/default/t...g-nvidia-gpu-/

  4. #4
    Soulwalker
    Join Date
    Sep 2014
    Posts
    7

    Default Bump.

    This deserves to be looked at.

  5. #5
    Telaran
    Join Date
    Nov 2012
    Posts
    94

    Default

    Have you tried right clicking the Glyph launcher and set it to run on the dedicated card?
    The post that says they right clicked the RIFT icon, I believe they were right clicking the rift LAUNCHER which has been replaced by the GLYPH launcher.

    RIFT.exe will not run without the launcher, I don't think it ever has. That's why it does nothing when you try to run it. This is because the game needs the launcher for updates, and running an older version of the game could have some weird results.

    Do you have the same problem in other games? Since my laptop apparently only uses a dedicated card, and doesn't seem to have the integrated Intel graphics, I don't have any of the options that you might have with multiple GPUs.

    I'm assuming that the system uses the integrated card under normal conditions in order to save power. It probably only uses the dedicated card under high-performance power settings, when a game is active. I would check my power settings for PCI settings.
    Last edited by Dulge; 09-12-2014 at 05:11 PM.

  6. #6
    Plane Walker
    Join Date
    Feb 2011
    Posts
    469

    Default

    Quote Originally Posted by Dulge View Post
    Have you tried right clicking the Glyph launcher and set it to run on the dedicated card?
    What.? Never heard of this before for any game.
    Spartans! Ready your breakfast and eat hearty... For tonight, we dine in hell!

  7. #7
    Soulwalker
    Join Date
    Sep 2014
    Posts
    7

    Default

    Quote Originally Posted by Dulge View Post
    Have you tried right clicking the Glyph launcher and set it to run on the dedicated card?
    The post that says they right clicked the RIFT icon, I believe they were right clicking the rift LAUNCHER which has been replaced by the GLYPH launcher.

    RIFT.exe will not run without the launcher, I don't think it ever has. That's why it does nothing when you try to run it. This is because the game needs the launcher for updates, and running an older version of the game could have some weird results.

    Do you have the same problem in other games? Since my laptop apparently only uses a dedicated card, and doesn't seem to have the integrated Intel graphics, I don't have any of the options that you might have with multiple GPUs.

    I'm assuming that the system uses the integrated card under normal conditions in order to save power. It probably only uses the dedicated card under high-performance power settings, when a game is active. I would check my power settings for PCI settings.
    Thanks for trying, but that doesn't work. Glyph is just a launcher and not the actual game. Glyph just starts the 'rift.exe' application.
    I don't have this issue with any other game.

  8. #8
    Ascendant Slipmat's Avatar
    Join Date
    Jan 2011
    Location
    Ireland
    Posts
    6,370

    Default

    You've probably tried this already, but just in case.....


    From NVIDIA Control Panel

    3D Settings->Manage 3D Settings

    Tab "Global setttings"

    Preferred Graphics Processor

    Select : High performance NVIDIA processor

  9. #9
    Soulwalker
    Join Date
    Sep 2014
    Posts
    1

    Default Check Graphics settings in Rift

    I had the same problem. Rift is down right now so I can't logon to check, but somehere in the graphic settings of the game (not NVidia or Windows) there is an option to select the graphics you want to use.

  10. #10
    Plane Walker
    Join Date
    Feb 2011
    Posts
    469

    Default

    Quote Originally Posted by Slipmat View Post
    You've probably tried this already, but just in case.....


    From NVIDIA Control Panel

    3D Settings->Manage 3D Settings

    Tab "Global setttings"

    Preferred Graphics Processor

    Select : High performance NVIDIA processor
    Don't have this option on my control panel even deleted and reinstalled .
    Spartans! Ready your breakfast and eat hearty... For tonight, we dine in hell!

  11. #11
    Soulwalker
    Join Date
    Sep 2014
    Posts
    7

    Default

    Quote Originally Posted by Slipmat View Post
    You've probably tried this already, but just in case.....


    From NVIDIA Control Panel

    3D Settings->Manage 3D Settings

    Tab "Global setttings"

    Preferred Graphics Processor

    Select : High performance NVIDIA processor
    Thank you for the reply.
    Afraid I have and can confirm this is not working.
    Also tried this while having 'High Performance' power settings from the Windows Control Panel.

    @Feebweasel: There is no in-game setting for which graphics processor to use...

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts