+ Reply to Thread
Results 1 to 2 of 2

  Click here to go to the first Rift Team post in this thread.   Thread: Game saying" im not running the correct version of the game"

  1. #1
    Soulwalker
    Join Date
    Jun 2014
    Posts
    1

    Default Game saying" im not running the correct version of the game"

    " i'm not running the correct version of the game" is what comes up when i log in but when i go to EU side i'm fine and the patch is working but when i switch to NA it just gives me the error, is their any way i can download the patch manually? or even fix this problem?

    ive uninstalled already and redownloaded the game and still the same thing

  2.   This is the last Rift Team post in this thread.   #2
    Customer Support Specialist
    Join Date
    Apr 2014
    Posts
    417

    Default

    Have you also gotten a chance to check these suggestions?

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts