+ Reply to Thread
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By Darkmaester

Thread: Performance

  1. #1
    Plane Touched
    Join Date
    Apr 2011
    Posts
    212

    Default Performance

    I think a simple game of balloons will show whomever it concerns where the problem of bad framerates comes from.


    [Using Athlon II X4 620 @ 3.6ghz, GTX 570]
    Resource Monitor states Rift is using 39 threads. Averages 30% usage. Core 0 hovers between 10-30% sometimes spiking to 50%. Core 1 hovers between 60-80%, sometimes spiking to 95%. Core 2 hovers between 10-30%, usually 25%. Core 3 hovers between 20-40% sometimes spiking to 50%. Graphics card sits between 7-10% usage. Framerates are 7fps to 10fps.

    I believe it's caused by massive object creation, which is loaded on the CPU, and apparently it's on Core 1. Objects probably should be getting created and destroyed so frequently, but hidden instead. Object creation should also likely be offloaded to the graphics card, if at all possible.

    hugs

  2. #2
    Plane Touched
    Join Date
    Apr 2011
    Posts
    212

    Default

    Another performance issue noticed. Standing in Meridian facing northeast, towards the porticulum, I tested out a few settings to see where dramatic framerates are lost. One stood out - Shadows.

    1920x1080 resolution
    Cloaks - None.
    Ground Clutter Density: 0
    " Radius: 0
    Particle Quantity: 10 (config edit)
    Full Screen FX - off.
    Antialiasing - Edge Smoothing.
    Everything else enabled or maxed.
    Shadows: Off - 41 FPS.
    Shadows: Environmental only - 26 FPS
    Shadows: Full - 21 FPS.

    Tried adjusting other settings to see if it would change the framerates as dramatically - nope.

    Since the time of the first post I changed out my cpu to an FX 8320 at 4.1GHZ.
    Last edited by Darkmaester; 03-31-2014 at 02:04 PM. Reason: CPU

  3. #3
    Soulwalker Koraya's Avatar
    Join Date
    Apr 2011
    Posts
    11

    Default

    Since the latest patch my FPS have dropped considerably. The game went from playing well at high settings to being barely playable at minimum settings. If you guys could please look into the what caused this issue, it would be much appreciated
    Last edited by Koraya; 04-03-2014 at 03:14 PM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts