+ Reply to Thread
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By Messiah1332

Thread: Supersampling -fullscreen FX removes all overhead names and titles

  1. #1
    Soulwalker Messiah1332's Avatar
    Join Date
    Jun 2013
    Posts
    17

    Default Supersampling -fullscreen FX removes all overhead names and titles

    When I have Supersampling on but Fullscreen FX turned off I lose all the names, above NPCs, enimies, friends, etc.

    Are there any way to fix this? I can't stand playing with Fullscreen FX turned on and I would love to use supersampling but right now it's really annoying to do so (having to click on every NPC so locate the merchant, seeing the mobs I need to kill for a quest, etc.

    I believe this happened after I updated to the latest driver, and rolling back is not really an option as I get way better FPS on this one.

    I have a AMD 7950 and a AMD Phenom II X6 OCd to 4GHz if anyone was wondering. I also get way low FPS for what my rig should be able to, but that's a topic for another day.

  2. #2
    Soulwalker Messiah1332's Avatar
    Join Date
    Jun 2013
    Posts
    17

    Default

    Small update: I teleported to Sanctum and I couldn't get the names to show at all, even with bloom turned on. I relaunched the game and now it is as it was before.

    Also, if anyone could tell me how to edit my posts, that would be great

  3. #3
    Sword of Telara
    Join Date
    Jun 2010
    Posts
    797

    Default

    Quote Originally Posted by Messiah1332 View Post
    Small update: I teleported to Sanctum and I couldn't get the names to show at all, even with bloom turned on. I relaunched the game and now it is as it was before.

    Also, if anyone could tell me how to edit my posts, that would be great
    You can edit your posts if you do so within 5 minutes of originally posting them. After that you're out of luck.
    Fahrenheit and Celsius temperature scales have probably not been rationalized due to puritanical reasons. If the freezing point in both scales was 0, then body temperature would be 66.6F. If it was 32 degrees, body temperature would be 69C.

    Silly reason, no matter how you think of it.

  4. #4
    Ascendant Rounded's Avatar
    Join Date
    Sep 2011
    Posts
    2,421

    Default

    AA implementation inside Rift is slow and known to cause issues on certain cards.

    Please disable the built-in AA inside Rift and force the desired level from your graphics drivers. You will get better performance and you will avoid most, if not all, issues.

  5. #5
    Soulwalker Messiah1332's Avatar
    Join Date
    Jun 2013
    Posts
    17

    Default

    Quote Originally Posted by Rounded View Post
    AA implementation inside Rift is slow and known to cause issues on certain cards.

    Please disable the built-in AA inside Rift and force the desired level from your graphics drivers. You will get better performance and you will avoid most, if not all, issues.
    Thanks for the suggestion! Sadly the quality of AA I get with forcing it seems so much worse than the ingame one that I don't know if it's worth it.
    Quick sample for comparison:
    http://i.imgur.com/1z1ZYxs.jpg
    That's with the ingame one turned up to supersampling.
    http://i.imgur.com/jBqVqDP.png
    And this is with it forced. Notice the arms.

    Are there so kind of trick to getting this to work properly? It seems like there is no AA at all when I force it from the CCC. I have tried to restart rift ater applying it, create a profile based on the rift.exe and both overriding and enhancing the AA.

    Thanks again.

  6. #6
    Ascendant Rounded's Avatar
    Join Date
    Sep 2011
    Posts
    2,421

    Default

    Did you point the profile to rift.exe or riftpatchlive.exe?

    I don't run an AMD card, nor have I ever used the CCC, I'm only familiar with nvidia's control panel. Someone else with knowledge of the tips and tricks of CCC has to help you further.
    Last edited by Rounded; 06-02-2013 at 03:44 AM.

  7. #7
    Rift Disciple
    Join Date
    Jun 2011
    Posts
    156

    Default

    Normal AA won't work on rift as it is a dx9 game using deferred rendering. You either have edge smoothing or super sampling so setting any "normal" AA modes through control panel won't do anything. For nvidia control panel the super sampling is under Anti alaising - transparency. You can also set edge smoothing through the grafics card control panel, for nvidia this is the FXAA option, i think with ATi it might be under MLAA. I personally use sweetfx, for whatever reason the edge smoothing option in game makes it look like they have smeared the screen with vaseline which sweetfx doesnt seem to do.

    http://forums.guru3d.com/showthread.php?t=376265

    The main reason for using edge detection, even though it isn't as good as removing jaggies, super sampling renders at double the screen resolution then reduces this down. This is a large performance hit on the grafics card. Edge smoothing uses significantly less resources.

  8. #8
    Soulwalker Messiah1332's Avatar
    Join Date
    Jun 2013
    Posts
    17

    Default

    Thanks for the SweetFX link, the game looks a lot better now, and with the AA from it I don't have to choose between names and smooth edges!

    If I could mark this as solved somehow, I would
    Last edited by Messiah1332; 06-02-2013 at 06:03 AM.

  9. #9
    Ascendant
    Join Date
    Dec 2010
    Posts
    7,120

    Default

    It would be nice for Trion to resolve this issue, though. I built a new rig yesterday and everything looked great except that names weren't displaying at all. This meant I had to use nameplates (ugly) or disable supersampling to distinguish enemies in PvP.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts