Closed Thread
Results 1 to 4 of 4

Thread: High Latency

  1. #1
    Soulwalker
    Join Date
    Mar 2012
    Posts
    2

    Default High Latency

    My game has been experiencing latency ranging from 1000mms-3000mms ever since I started playing again.

    I just bought the expension and looked forward to playing it, but now I can't due to this high ping. My internet works fine, it's just Rift thats causing the problem.

    Please help.

  2. #2
    Ascendant Intim's Avatar
    Join Date
    Dec 2011
    Posts
    1,554

    Default

    More info needed. What region you in? What shard you in? Broadband connection etc

    If its icewatch then its the servers fault although sounds very high latency for it to be just server
    Intim @ Zaviel EU
    Twitch Channel ,YouTube,Twitter

  3. #3
    Soulwalker
    Join Date
    Mar 2012
    Posts
    2

    Default

    Quote Originally Posted by Intim View Post
    More info needed. What region you in? What shard you in? Broadband connection etc

    If its icewatch then its the servers fault although sounds very high latency for it to be just server
    I live in the USA and my shard is Seastone. I also tried making accounts on other shards to check if the latency would decrease, but no luck.

  4. #4
    Soulwalker Brukhalian's Avatar
    Join Date
    Apr 2012
    Posts
    9

    Default

    I've been suffering far worse latency, making Rift well-nigh impossible to play.

    Yesterday, during an expert run it spiked up to 48000ms and today, whilst I was questing, it held at 72000ms for a period of time. I've been experiencing intermittent spikes of a few thousand ms and been randomly disconnected over and over, too.

    I play in the Oceanic region with a normal latency of between 200ms and 250ms.

    At first, I thought it was the fault of my modem, but I bought a new one a few days ago and there's been zero improvement.

    My ISP reports that there are no problems on their end. My connection is strong during these latency periods. I can alt-tab away from Rift and access webpages in my browser during these spikes.

    I've never had any problems like this playing WoW, GW2, The Secret World and a variety of other MMOs.

    My connection has been steady and without problems since I started playing Rift when it launched. This issue of massive latency and disconnects only started shortly after patch 2.2 and has become worse ever since.

Closed Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts