So I posted several months ago, and posted a video too, of how shadows looked messed up. I couldn't understand why especially with a top end vid card (GTX 680) and i7 quad-core processor. Well, I finally figured it out.

I would use the Nvidia Control Panel and enhance the application setting as far as anti-aliasing was concerned. I also used anti-aliasing in game. The fix was simple. Turn off the anti-aliasing in game...wallah. Problem solved. Go figure!!

Hope this helps a few folks.