+ Reply to Thread
Page 1 of 8 1 2 3 4 5 ... LastLast
Results 1 to 15 of 106
Like Tree2Likes

Thread: Rift crashing my video card driver

  1. #1
    Rift Master McWaffles's Avatar
    Join Date
    Jan 2011
    Posts
    601

    Default Rift crashing my video card driver

    Whenever i'm in meridian, turning my camera angle at all crashes my video card driver and the game. This has only happened since the most recent hotfix to Conquest and only happens in meridian.

    PLEASE port people from conquest somewhere other than meridian to prevent this ABSURD lag and crashes in the city.

  2. #2
    Shadowlander
    Join Date
    Mar 2011
    Posts
    37

    Default

    I'm getting this also, every time I'm in Meridian. Others in my guild reporting it also.

  3. #3
    Soulwalker
    Join Date
    Aug 2011
    Posts
    18

    Default Display driver amdkmdap stopped responding and has successfully recovered.

    Intel Core i7 930 @ 2.8 ghz
    8 GB RAM
    2 Radeon HD 5750 xfire ATI driver 12.6

    Seems to only happen in Meridian for me too.

  4. #4
    Soulwalker
    Join Date
    Aug 2011
    Posts
    18

    Default

    Turned settings to low and I'm having some luck

  5. #5
    Rift Disciple Vixiar's Avatar
    Join Date
    Jan 2011
    Location
    Austin, Texas
    Posts
    175

    Default

    same issue for my HD 6950 as well as grass that randomly disappears then reappears

  6. #6
    Plane Touched Humble's Avatar
    Join Date
    Jan 2011
    Location
    California
    Posts
    221

    Default

    This literally just started happening to me as well. I'm in Sanctum, never had any graphic card issues and now I've blue screened from my video card three times just trying to get out of the port building.
    It is only the dead who have seen the end of war. - Plato

  7. #7
    Plane Walker
    Join Date
    Feb 2011
    Posts
    466

    Default

    Happened to me in the latest hotfix. Put it on low render, was able to escape meridian with only freeze ups (though I did have to restart rift once). Without low render I got artifacts and **** that required a restart to fix. No other application does this, loads of my guilds can't spend any time in meridian either, it's not a hardware problem, it's the patch.

    So trion.. eta on this fix? It's horrible and I can't sustain it forever as I can't reach the bank and guild bank.

    This is in addition to ability lag in conquest making raiding impossible. This has been the worst patch in the history of rift.

  8. #8
    Ascendant
    Join Date
    Jan 2012
    Posts
    2,570

    Default

    This also happened to me recently in Sanctum just going up to the portal I turned around and crashed. It repeated on login about 4 times, and about the 5th time worked fine.

  9. #9
    Plane Touched Humble's Avatar
    Join Date
    Jan 2011
    Location
    California
    Posts
    221

    Default

    Is there an update to this at all? I'm running 2 crossfired ATI 5800 2 GB video cards in my Alienware. I've run Rift at all max settings with no issue since the release. Since 1.9, I blue screen every time I'm near the portal in Sanctum. Even on low settings, the whole thing crashes. I've updated from 12.3 catalyst to 12.6 and I still crash. The blue screens are from an ATI .sys file usually.

    The cards are fine considering I play every other game I have on max settings with no issue. I loaded up BF3 maxed out right after crashing and it ran fine. There is something wrong in the 1.9 client.
    Last edited by Humble; 07-05-2012 at 03:52 PM.
    It is only the dead who have seen the end of war. - Plato

  10. #10
    Soulwalker
    Join Date
    Mar 2011
    Posts
    14

    Default Ditto

    I've been experiencing this problem as well. Since the Conquest fix. Go into Meridian and the video card crashes. Tired of sending in bug reports lol. I hope you guys can fix this soon.

  11. #11
    Ascendant Liziana's Avatar
    Join Date
    Apr 2010
    Location
    England
    Posts
    2,415

    Default

    Quote Originally Posted by Humble View Post
    Is there an update to this at all? I'm running 2 crossfired ATI 5800 2 GB video cards in my Alienware. I've run Rift at all max settings with no issue since the release. Since 1.9, I blue screen every time I'm near the portal in Sanctum. Even on low settings, the whole thing crashes. I've updated from 12.3 catalyst to 12.6 and I still crash. The blue screens are from an ATI .sys file usually.

    The cards are fine considering I play every other game I have on max settings with no issue. I loaded up BF3 maxed out right after crashing and it ran fine. There is something wrong in the 1.9 client.
    You have exactly the same set up as me. Somebody said to disable Crossfire, so I'm going to try that tonight. I have never had problems like this with any game. I get the message "Display driver stopped responding and has successfully recovered"...only it doesn't recover at all...it blue screens.
    If you say plz instead of please, I say no because it's shorter than yes.

  12. #12
    Prophet of Telara Kadeth's Avatar
    Join Date
    Apr 2012
    Posts
    1,145

    Default

    Most here that have posted their GPU have lower end cards. As the devs add more to Rift, the minimum requirements are going to go up. I think that is what is beginning to happen now.

    All you can do is make sure your drivers are up to date and that you are keeping your machine, specifically the GPU, as dust free and cool as you can. (use canned electronics duster or a low PSI compressor to dust inside the computer.) Hope for minimal GPU crashes and, start saving for a better GPU.
    Life is what you make it so make it good, even when it isn't.

  13. #13
    Plane Touched Belorian's Avatar
    Join Date
    Jun 2011
    Posts
    243

    Default

    Quote Originally Posted by Kadeth View Post
    Most here that have posted their GPU have lower end cards. As the devs add more to Rift, the minimum requirements are going to go up. I think that is what is beginning to happen now.

    All you can do is make sure your drivers are up to date and that you are keeping your machine, specifically the GPU, as dust free and cool as you can. (use canned electronics duster or a low PSI compressor to dust inside the computer.) Hope for minimal GPU crashes and, start saving for a better GPU.
    Please take a look at the cards mentioned in this thread. They are far from lower end and are more than fine for Rift.. we're talking about Sanctum / Meridian crashes here. Stop being a clueless tool and admit the latest hotfix is unstable as it started to cause crashes on good PCs. Someone who is running Rift on ultra at all times and suddenly starts to crash in Sanctum should upgrade GPU?? Why won't people read what they type before clicking the post button :\
    Last edited by Belorian; 07-06-2012 at 06:02 AM.

  14. #14
    Rift Disciple
    Join Date
    Apr 2011
    Posts
    119

    Default

    i have an I7 2600k at 5.0 ghz, 16gb corsair vengeance 1600mhz ram, OCZ vertex 3 120gb SSD, Nvidia GeForce GTX 560 1gb ram and im having this same issue alot lately since 1.9. i thought at first, maybe it was the newest drivers from nvidia, so i went back to old driver, problem got worse. tried the new beta drivers, same thing. went back to the current drivers.

    its beyond annoying now at this point. having to constantly relog because the ground has vanished, or parts of the screen are flashing black. if you ignore it, the game crashes or worse, it causes a blue screen.

  15. #15
    Ascendant Liziana's Avatar
    Join Date
    Apr 2010
    Location
    England
    Posts
    2,415

    Default

    Quote Originally Posted by Kadeth View Post
    Most here that have posted their GPU have lower end cards. As the devs add more to Rift, the minimum requirements are going to go up. I think that is what is beginning to happen now.

    All you can do is make sure your drivers are up to date and that you are keeping your machine, specifically the GPU, as dust free and cool as you can. (use canned electronics duster or a low PSI compressor to dust inside the computer.) Hope for minimal GPU crashes and, start saving for a better GPU.

    Riiight.....Comp spec below:

    INTEL CORE I7 880 @ 3.06 ghz + Turbo Boost
    ASUS P7P55D-E Pro
    1GB ATI RADEON HD 5850 x 2
    KINGSTON HYPER-X GENESIS DUAL DDR-3 1600 Mhz
    CORSAIR 850 PSU (TX850)
    60 GB OCZ Vertex 2 Sata II SSD
    1 TB Serial ATA 3-G/sec 7,200
    Super quiet 22dBA Triple Copper Heatpipe CPU cooler
    Antec 900 case
    WINDOWS 7 64 Home Premium
    IIYAMA 24 inch 1920 x 1080

    Hardly think I need to save for anything better...this is NOT a low end machine or cards, and cool? it's super freaking cool!!! drivers all up to date etc.etc.
    If you say plz instead of please, I say no because it's shorter than yes.

+ Reply to Thread
Page 1 of 8 1 2 3 4 5 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts