+ Reply to Thread
Results 1 to 2 of 2

Thread: Strange game lock-ups and disconnects.

  1. #1
    Soulwalker
    Join Date
    May 2012
    Posts
    2

    Default Strange game lock-ups and disconnects.

    Hello there!

    I was tanking an instance called the Foul Cascade for the first time today when I got a really peculiar crash.

    Amongst the quests inside the instance, I had to destroy Earth Mounds and offer things to altars. I had just completed the second altar and destroyed all 4 out of 4 Earth Mounds.

    Moving forward, I pulled a group as usual only to find my screen completely locked up as if my computer imploded. It wasn't budging so I alt+F4'd out and re-opened Rift, and logged straight back on, - Only to find I had been teleported back to before the second altar, with it NOT completed in my quest log, as well as only 2/4 Earth Mounds destroyed.

    Putting it down to a one off crash, I continued forward, realising I wouldn't be able to complete the altar quest as the boss was supposed to drop some essence (which I had already picked up, but was 1/3 instead of 2/3), only to find that it happened again on the next pull.

    Instead of closing the game I sat it out, hoping my patient group members wouldn't leave me high and dry. It came to a loading screen and said I had disconnected and that it was going to reconnect me. As I reconnected, I yet again had spawned back to before the second altar, with any Earth Mounds I had done after the first crash, gone. Stuck on 2/4.

    On the third crash I gave in and just closed the game and made this topic. Has anyone else had a similar problem happen to them? I started playing about a week and a half ago and this has never happened to me in any situation ever. Last night I think there was a maintenance and it all started to fall apart. Do you reckon it could be linked?

    Many thanks.
    Last edited by Renkai; 05-01-2012 at 03:52 PM.

  2. #2
    Soulwalker
    Join Date
    May 2012
    Posts
    2

    Default

    I guess I should add my computer specs - Playing on ultra@1080p

    AMD Phenom II x4 970BE @3.5Ghz
    4GB DDR3 RAM
    ATi HD Radeon 5970
    Win7 64bit

    Cheers.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts