+ Reply to Thread
Results 1 to 9 of 9

Thread: Invisible Monsters And Invisible Characters

  1. #1
    Soulwalker Sunstone's Avatar
    Join Date
    Oct 2011
    Posts
    12

    Default Invisible Monsters And Invisible Characters

    Invisible monsters and invisible (avatar) character
    zooming right in then back out fixes the character problem.
    restarting the game fixes the invisible monster problem.
    Often Occurs After several hours of play.
    happens randomly / everywhere (inside dungeons or in the world map,)
    also occurs after monsters death making loot drops usable.

    Running a Radeon 5670 card on min settings with projected textures on,

    happens to everybody in game, so its not really a graphics card issue.

  2. #2
    Soulwalker
    Join Date
    Nov 2011
    Posts
    21

    Default

    same issue since the latest patch, and i'm running a 2gig amd ati radeon hd 6950

  3. #3
    Soulwalker
    Join Date
    Dec 2011
    Posts
    1

    Default me too!

    I have the same issues, it's really annoying. Relogging helps, but sometimes I have to do that every ten minutes. Getting attacked by invisible monster, no looting and no butchering screws things up.
    I'm running Rift on WinXP with minimal background threads, P3D 3GHz, Nvidia 8400GS, 3GByte RAM with low settings.
    Please fix this soon!
    Last edited by Berlioz; 12-14-2011 at 04:52 PM.

  4. #4
    Ascendant Anuhart's Avatar
    Join Date
    Mar 2011
    Posts
    6,003

    Default

    Been an issue forever.

    Just another one of those many many game breaking problems that Rift has.

    Which are completely and utterly ignored by Trion even though they are mentioned frequently by players. To the point that it's impossible for it not to be something Trion employees are specifically told to not respond to.
    Last edited by Anuhart; 12-14-2011 at 05:24 PM.

    Quote Originally Posted by View Post
    You obviously know nothing about Laethys, have you tried him?
    I don't log in anymore.

  5. #5
    Ascendant Hotter's Avatar
    Join Date
    Jun 2011
    Posts
    2,089

    Default

    Competition is tough. I have this issue as well but don't expect much as it's been ongoing for the duration of my Rift experience. If the game survives another year I think they'll get it fixed.

  6. #6
    Telaran
    Join Date
    Aug 2011
    Posts
    90

    Default

    My wife and I have not been playing much after the last big 1.6 patch. However we started again this week and low and behold we are both getting this problem as well.

    I am running AMD 6870 and she is using the Nvidia 250GTS, both with AMD Phenom 2 cpu's. Fix this please!!!

  7. #7
    Soulwalker
    Join Date
    Jun 2011
    Posts
    22

    Default

    Same here. I've sent in bug reports but it seems no one cares especially since no one from Trion ever seems to respond in the forums about this. It's been happening to me since I first started playing last May and appears to be related to being online for several hours. Running Windows 7, Intel Core i7 2.67 GHz cpu, 6 gigs ram with Nvidia GeForce GTS 240 video adapter. All my graphics are set low. I'm not sure when exactly, but it seemed like the problem kind of cleared up for awhile but just lately, since 1.6, it's happening again. yay.....

  8. #8
    Telaran
    Join Date
    Dec 2011
    Posts
    65

    Default

    Sounds to me like yet another thread bashing Rift when its probably just a heat issue from the enduser(but hey lets blame tron). Add some good case flow on your mobo and see if it helps, open your case but a box fan on the side if you have to just to test. But i play all the time and have zero issues like this.

  9. #9
    Ascendant Anuhart's Avatar
    Join Date
    Mar 2011
    Posts
    6,003

    Default

    Sounds to me like yet another thread bashing Rift when its probably just a heat issue from the enduser(but hey lets blame tron). Add some good case flow on your mobo and see if it helps, open your case but a box fan on the side if you have to just to test. But i play all the time and have zero issues like this.
    This really is a silly post.

    I heard people were blaming drunk drivers for knocking people down, sounds like a case of careless pedestrian to me. I walk the streets all the time, I have never been knocked down.


    But seriously, let's test your idea.

    This happens mostly when the client has been running a while, restarting the client fixes it, now this heat issue just vanished by restarting the client? And won't appear again until the client has been running a while again?

    Nobody is blaming but you. This problem has been about from day one and affects people with a wide variation of machines.

    It rarely affects humanoid mobs but can affect some if the model is far from a normal humanoid. It is most prominent in elementals, ghosts and birds.

    Remember the Fire/Earth event invasion boss Pahoeh? The huge fiery elemental using the water elemental model? Well, when that event first started and for a while after, NOBODY could see the model, related? I'd think so.

    What is very annoying about this, is that there have been dozens of threads asking about this and not one response from Trion.

    Quote Originally Posted by View Post
    You obviously know nothing about Laethys, have you tried him?
    I don't log in anymore.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts