+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Thread: Rift patcher not updating....not doing anything...

  1. #1
    Soulwalker
    Join Date
    Jul 2011
    Posts
    9

    Default Rift patcher not updating....not doing anything...

    So I went to log on today after the patch. The Rift patch said it needed to be update so I clicked ok and the update progress bar pops up...and just sat there idly for 30 minutes...not downloading anything....not installing anything...not updating in any way. Suddenly it closes and the Rift login is shown...so I attempt to login and now it says I cannot connect. Of course upon attempting to search for a solution on Trions tech support page nothing comes up...because apparently everyone just assumed their patcher would never have any problems...even Rift Patcher comes up with zero results for me

    So great...now I can't connect....so I try to restart Steam, and relaunch Rift....only now instead of launching the program it opens the steam folder that rift is in what the hell is going on? Does anyone have a solution other than attempting to reinstall everything?

  2. #2
    Telaran venndann's Avatar
    Join Date
    Jan 2011
    Location
    Canada
    Posts
    83

    Default

    I got a C Runtime Error and then nothing. I am in the process of recovering files now, but I am not confident that will work. Can you start the game or the patcher outside of Steam?
    After recovery it is downloading another 388MB of files, we'll see if that helps.
    Last edited by venndann; 07-20-2011 at 02:35 PM.

  3. #3
    Soulwalker
    Join Date
    Jul 2011
    Posts
    9

    Default

    Well I can start the patcher, but now it says I cannot connect to the update server...I have 120 hours logged through steam so it isn't like the game didn't work before. It must be something to do on Trion's end. Perhaps they're working on a fix on their servers? It seems only North American server players are affected, but thats the trend I've noticed and I could be wrong. Really rather irritating...

    I did try uninstalling and reinstalling and that just made the problem worse...now the patcher doesn't even recognize that it needs to be updated...it just won't connect anymore.

  4. #4
    Rift Disciple Tehjianna's Avatar
    Join Date
    Feb 2011
    Location
    USA
    Posts
    154

    Default

    Had the same problem went to sleep now trying again...and it's patching AGAIN....I got the bar all the way to the end but couldnt' log into the servers.........hopefully it gets fixes ssooon!!!
    Tehjianna Starweaver
    Hailol, Threesprings, Deepwood PVe Servers and Faeblight
    ~~Practically all servers have a character I made, but my Main is DeepWood!

    Mayelianna, Arylenna, Airey, Zartanya, Kynne, Aibanna Maeyara & Mayeli as wel ;P

  5. #5
    Telaran Red Star's Avatar
    Join Date
    Mar 2011
    Posts
    50

    Default

    I'm having this problem too, is anyone looking into this issue?
    http://sigs.enjin.com/sig-rift/21393_5b2ee92cf136c933.png

  6. #6
    jdc
    jdc is offline
    Shadowlander jdc's Avatar
    Join Date
    Jul 2011
    Posts
    46

    Default

    Have any of you (other than venndann, who did but didn't follow up as to whether or not this fixed the problem for him) tried running the Rift client, logging in, then clicking the Recover button in the bottom right of the window? This should, hopefully, resolve the issue for you.
    Last edited by jdc; 07-20-2011 at 07:43 PM.

  7. #7
    Telaran Red Star's Avatar
    Join Date
    Mar 2011
    Posts
    50

    Default

    Quote Originally Posted by jdc View Post
    Have any of you (other than venndann, who did but didn't follow up as to whether or not this fixed the problem for him) tried running the Rift client, logging in, then clicking the Recover button in the bottom right of the window? This should, hopefully, resolve the issue for you.
    It won't even let us run the client, the patch update window (launched separately over and above the current one) will prevent any further progress.
    http://sigs.enjin.com/sig-rift/21393_5b2ee92cf136c933.png

  8. #8
    Telaran Red Star's Avatar
    Join Date
    Mar 2011
    Posts
    50
    http://sigs.enjin.com/sig-rift/21393_5b2ee92cf136c933.png

  9. #9
    Telaran Huzzah's Avatar
    Join Date
    Feb 2011
    Posts
    56

    Default

    "The Fix" did not work for me. Once I update the game files and get past the Rift icon screen, I cannot connect to the character selection servers.
    Huzzah - Rogue -=- Rhowyn - Cleric
    Head Wench of <Shiny> Defiant, Wolfsbane
    (Formerly <Serenity> of Sunrest, may the shard rest in peace)

  10. #10
    jdc
    jdc is offline
    Shadowlander jdc's Avatar
    Join Date
    Jul 2011
    Posts
    46

    Default

    Quote Originally Posted by Red Star View Post
    It won't even let us run the client, the patch update window (launched separately over and above the current one) will prevent any further progress.
    Okay, I see what's going on here. The misunderstanding is that you're using the word "patch update" when you're actually referring to the **patcher** update. Let me explain:

    The latest patch (1.3 Hotfix #2) required two updates be pushed out:

    1) The patcher application itself needed to be updated,
    2) The Rift game itself needed to be updated (1.3 Hotfix #12).

    It sounds like what you're describing is that the patcher update isn't completing or isn't working -- you're repetitively prompted to re-update the patcher itself (e.g. stuck in an infinite loop of #1), and never able to reach #2. Is that correct?

  11. #11
    Soulwalker
    Join Date
    Jul 2011
    Posts
    9

    Default

    Quote Originally Posted by jdc View Post
    Have any of you (other than venndann, who did but didn't follow up as to whether or not this fixed the problem for him) tried running the Rift client, logging in, then clicking the Recover button in the bottom right of the window? This should, hopefully, resolve the issue for you.
    I would...but I can't log in to the server....

  12. #12
    Soulwalker
    Join Date
    Jul 2011
    Posts
    9

    Default

    Quote Originally Posted by jdc View Post
    Okay, I see what's going on here. The misunderstanding is that you're using the word "patch update" when you're actually referring to the **patcher** update. Let me explain:

    The latest patch (1.3 Hotfix #2) required two updates be pushed out:

    1) The patcher application itself needed to be updated,
    2) The Rift game itself needed to be updated (1.3 Hotfix #12).

    It sounds like what you're describing is that the patcher update isn't completing or isn't working -- you're repetitively prompted to re-update the patcher itself (e.g. stuck in an infinite loop of #1), and never able to reach #2. Is that correct?
    It's the patcher and/or not being able to connect to anything. I was getting the patcher issue (prompting for update...progress bar pops up but not updating) after a complete reinstall, I cannot even connect.

  13. #13
    Soulwalker
    Join Date
    Jul 2011
    Posts
    9

    Default

    Ok well..I was able to get past the login screen (by logging in...obviously) so I was able to connect for a brief moment. But now the patcher says I "cannot recover at this time. Please try again in a few minutes. (Error #1012)"

  14. #14
    Soulwalker
    Join Date
    Jul 2011
    Posts
    9

    Default

    Hm well...I cannot find the edit forum function so I'm posting again...anyway...after a series of restarts it finally worked and I'm downloading the patch now...hopefully thats the end to my problems.

    For those still having issues; I restarted everything, and it didn't work. But I was able to get it to run after around 4 or 5 system reboots yesterday. But after a reboot today it does work, so I'm not sure what the problem is...but there you go....

  15. #15
    Soulwalker
    Join Date
    Jul 2011
    Posts
    9

    Default

    Alright well...it still doesn't work. The update never finish. I've uninstalled everything and will be reinstalling it ONE MORE TIME. If it doesn't work, I'm canceling my subscription. Trion tech support has been zero help through this entire process...not a single reply, not even an email. Nothing I've seen acknowledging this issue...

    I hope it works...I love the game...but if Trion does not want to support it's paying customers than I see no reason to support them. In fact I am seriously considering just canceling now...but I want to give it one more try. So...here's to hoping it works...I would hate to have to not only, not recommend this to anyone, but to recommend other games over this one simply because the company refuses to support the player-base. That's the impression I'm getting anyway...really disappointing...

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts