+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 24

Thread: So it doesn't even work?

  1. #1
    Soulwalker denniedarko's Avatar
    Join Date
    Jul 2011
    Posts
    12

    Default So it doesn't even work?

    I just got the game, installed and patched up and cannot get it to work. When I log in and click play it seems like maybe there is a movie going on, but all I see is constant white flashing. So I hit esc and get to what I think is a character selection screen with nothing to click on. There are some statues on each side with some torches.

    Anyone have any idea what it is?

  2. #2
    Soulwalker denniedarko's Avatar
    Join Date
    Jul 2011
    Posts
    12

    Default

    Well these forums sure are active...

  3. #3
    Champion of Telara
    Join Date
    Jan 2011
    Posts
    1,238

    Default

    The forums are active and you dont even mention your computer specs.


    Also try to run the "Recovery" option on the launcher before you click play.

    Anyways it sounds like a case of either bad files or ancient PC.

  4. #4
    Soulwalker denniedarko's Avatar
    Join Date
    Jul 2011
    Posts
    12

    Default

    I have run the recovery option.

    My PC isn't ancient either:

    -Windows 7 Home Premium
    -Intel Core 2 Quad CPU @ 2.33 GHz
    -4096MB Ram
    -DirectX 11
    -ATI Radeon HD 5570

    I also have a 1000 watt power supply if that makes a difference.

  5. #5
    Soulwalker Audie's Avatar
    Join Date
    May 2011
    Posts
    16

    Default

    Have you set ATI drivers to "application controlled" for both AA and AF? I'm betting that you have not. Try this and you should be good to go.

  6. #6
    Champion of Telara
    Join Date
    Jan 2011
    Posts
    1,238

    Default

    Your CPU is 3 years old,but should be fine.

    Your graphics card is made to play Blu ray movies and not games, you will be lucky to run on low as many others in these forums have cards similar to yours and expect to play on ultra with a 70$ card.

    things to try:

    1)Update your drivers.

    2)Check this forums for some changes to some files that might help you.

    3)Pray that you can play on Low.

    Makes me wonder why you have such a strong PSU when your setup requires barely 300, ready PC's are bad, dont buy them they are just stealing money from you.

  7. #7
    Soulwalker denniedarko's Avatar
    Join Date
    Jul 2011
    Posts
    12

    Default

    Ready PCs...what are you talking about? This card plays both WoW and LotRo just fine.

  8. #8
    Soulwalker denniedarko's Avatar
    Join Date
    Jul 2011
    Posts
    12

    Default

    Quote Originally Posted by Audie View Post
    Have you set ATI drivers to "application controlled" for both AA and AF? I'm betting that you have not. Try this and you should be good to go.
    I am not sure how to do this.

  9. #9
    Soulwalker Audie's Avatar
    Join Date
    May 2011
    Posts
    16

    Default

    Quote Originally Posted by denniedarko View Post
    Ready PCs...what are you talking about? This card plays both WoW and LotRo just fine.
    Try my suggestion, Dennie. I originally ran this on an ATI rig and I had to do what I have suggested. In fact, this procedure is stickied above.

    Honestly? I would phone Trion and avoid these forums. You will be endlessly flamed if you stick around. This community is anything but helpful.

  10. #10
    Champion of Telara
    Join Date
    Jan 2011
    Posts
    1,238

    Default

    WoW and Lotro are not Rift, they both have 5-6 year old graphic engines combined with the fact that they arent buggy engines.

    As i said you are gonna be lucky to run Rift on low, which has a 2 year old Graphic Engines with stupid bugs.

  11. #11
    Soulwalker Audie's Avatar
    Join Date
    May 2011
    Posts
    16

    Default

    Quote Originally Posted by denniedarko View Post
    I am not sure how to do this.
    From the stickied post:

    Rift Settings

    In game video settings have a large impact on framerate, as would be expected. Try decreasing your settings using the top slider in the advanced video settings. If your framerate does not change significantly when changing from high settings to low settings this generally indicates a problem external to rift, most likely a driver issue. In this case, ensure you are running the latest drivers (see below).
    Certain video settings have a much larger framerate than others. Some examples of these settings are: antialiasing, shadows, and ground clutter. Disabling vertical sync will also result in a framerate increase. Each setting has a tooltip which indicates if that option is especially expensive, as well as whether that setting requires CPU or GPU processing. If you know one aspect of your system is weaker than another, you can disable specific settings to tune your performance for your hardware configuration.
    Resolution also has a large impact on framerate. Attempt to lower your resolution and see if your framerate improves. If it does not, that indicates you are CPU bound, and therefore should reduce settings which are listed as CPU intensive. If framerate does increase, you may either keep the new resolution, or go back to your original resolution, and try lowering settings which are listed as GPU intensive.


    Hardware Specific Performance

    ATI
    AMD is actively releasing new drivers which often contain Rift specific fixes. Updating to the latest driver may result in significantly improved framerate.
    AMD has also recently released a new application profile. Downloading and installing the latest Rift application profile may result in significantly improved framerate. Note that this profile is not just for CrossFire, it may result in improvements even if you do not have a CrossFire setup.
    Ensure "Anti-Aliasing" and "Anisotropic Filtering" are set to"Application Controlled" in the Catalyst Control Center.
    Disabling "Morpological Filtering" in the Catalyst Control Center will result in improved framerates.
    Disabling "ATI Overdrive" may result in increased framerates in some configurations.

    -Hope this helps.

  12. #12
    Soulwalker denniedarko's Avatar
    Join Date
    Jul 2011
    Posts
    12

    Default

    Quote Originally Posted by Audie View Post
    From the stickied post:

    Rift Settings

    In game video settings have a large impact on framerate, as would be expected. Try decreasing your settings using the top slider in the advanced video settings. If your framerate does not change significantly when changing from high settings to low settings this generally indicates a problem external to rift, most likely a driver issue. In this case, ensure you are running the latest drivers (see below).
    Certain video settings have a much larger framerate than others. Some examples of these settings are: antialiasing, shadows, and ground clutter. Disabling vertical sync will also result in a framerate increase. Each setting has a tooltip which indicates if that option is especially expensive, as well as whether that setting requires CPU or GPU processing. If you know one aspect of your system is weaker than another, you can disable specific settings to tune your performance for your hardware configuration.
    Resolution also has a large impact on framerate. Attempt to lower your resolution and see if your framerate improves. If it does not, that indicates you are CPU bound, and therefore should reduce settings which are listed as CPU intensive. If framerate does increase, you may either keep the new resolution, or go back to your original resolution, and try lowering settings which are listed as GPU intensive.


    Hardware Specific Performance

    ATI
    AMD is actively releasing new drivers which often contain Rift specific fixes. Updating to the latest driver may result in significantly improved framerate.
    AMD has also recently released a new application profile. Downloading and installing the latest Rift application profile may result in significantly improved framerate. Note that this profile is not just for CrossFire, it may result in improvements even if you do not have a CrossFire setup.
    Ensure "Anti-Aliasing" and "Anisotropic Filtering" are set to"Application Controlled" in the Catalyst Control Center.
    Disabling "Morpological Filtering" in the Catalyst Control Center will result in improved framerates.
    Disabling "ATI Overdrive" may result in increased framerates in some configurations.

    -Hope this helps.
    Yea, I read that, but I cannot find anyway to change the settings. I don't see a Catalyst Control Center, and doing a search on the PC turns up nothing.

    I do appreciate your help though.

  13. #13
    Soulwalker denniedarko's Avatar
    Join Date
    Jul 2011
    Posts
    12

    Default

    So I have searched all around and have discovered I have no catalyst control center and cannot change any settings. So far my experience with the game has been grand.

  14. #14
    Rift Disciple rbra's Avatar
    Join Date
    Jul 2011
    Posts
    156

    Default

    Quote Originally Posted by denniedarko View Post
    So I have searched all around and have discovered I have no catalyst control center and cannot change any settings. So far my experience with the game has been grand.
    Dennie, I think hes referring to ur ingame settings, not on ur video card. Those can be acessed via game menu, video options, advanced.
    i7 2600 OC 3.9Ghz (8 cache) Quad Core Liquid Cooled - 8GB 1866mhz Kingston - Nvidia Geforce 580 1.5GB Superclocked - 875 PSU
    Heaven 2.5 Benchmark: 54.1fps

  15. #15
    Soulwalker denniedarko's Avatar
    Join Date
    Jul 2011
    Posts
    12

    Default

    Quote Originally Posted by rbra View Post
    Dennie, I think hes referring to ur ingame settings, not on ur video card. Those can be acessed via game menu, video options, advanced.
    I can't get in game, that is the problem.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts