+ Reply to Thread
Results 1 to 10 of 10

Thread: Really Bad Draw Distance Pixelation on NPCs, Looking for Fix

  1. #1
    Soulwalker
    Join Date
    May 2011
    Posts
    6

    Default Really Bad Draw Distance Pixelation on NPCs, Looking for Fix

    So I bought Rift today; I've spent the entire day trying to make this game look presentable on my computer. I'm frustrated and regretting my purchase to say the least, regardless, I'm looking for some helpful advice.

    The problem I'm having is no matter what I try, even if I turn the graphics as high as they will go, when rendered from a distance all NPCs look highly pixelated. I would never be able to play the game like this I find it aesthetically hideous that even if this were 1995 I would still find this game breaking.

    Here is a screen shot at a distance of some NPCs:
    http://i50.photobucket.com/albums/f345/iviijin/22s.jpg

    Here is a close up as to display that they are rendered perfectly when not at a distance:
    http://i50.photobucket.com/albums/f345/iviijin/21s.jpg

    I've been known to be pretty resourceful in the past, I'm not simply being lazy. I have read every graphic tweaking thread on the web and I still have had no luck.

    Here is what I've tried so far:

    Switched between VGA and HDMI cables to see if there was a difference.

    Tweaked graphics settings in the game UI every possible way.

    Under task manager I set the games priority to high.

    I tried running the game under many different resolutions, full screen, windowed and full screen windowed mode.

    I added "-dx9" to the target line of the games short cut, which I later found out the game was designed to run on DirectX 9 anyway so this most likely changed nothing...

    I made 100% sure that my graphics card drivers were up to date.

    I prayed to God to make this go away and I'm not even religious. When that didn't work I Edited rift.cfg some and here is what it looks like currently:

    [Audio]
    AmbientVolume = 90
    EnvironmentVolume = 90
    FootstepVolume = 90
    ListenerLerpToCamera = 0.010000
    MasterVolume = 90
    MusicEnabled = True
    MusicVolume = 90
    PlayInBackground = False
    ReverbEnabled = True
    SpellAbilitiesVolume = 90
    UserInterfaceVolume = 90
    VoiceOverVolume = 90

    [Camera]
    distanceScale = 4.010001
    distanceScaleAlt = 3.000000
    pitch = -0.016052
    useAltDistScale = False
    yaw = -0.421817

    [Client]
    CPUBenchmarkTime = 2.023671
    DefaultVideoPreset = 0
    DriverVersionHigh = 524302
    DriverVersionLow = 656158
    EULA = 29
    GPUBenchmarkTime = 19.849566
    LogCombatConsole = False
    LostFocusMinFrameTime = 100
    MainThreadCPU = 0
    ShowLowQualityRendererWarning = False
    UseQueryPerformanceCounter = True

    [Movies]
    PlayedIntroMovie = True

    [Video]
    AmbientOcclusion = False
    AnisotropicFiltering = 8
    AntialiasMode = 0
    AutoAdjustSettings = False
    DetailObjectsEnabled = True
    FullscreenFXEnabled = False
    Gamma = 0.910000
    GroundClutterDensity = 6
    GroundClutterRadius = 80
    LegacyRenderer = False
    LightingComplexity = 0.600000
    MaxLOD = 1
    MaxShaderLOD = 10
    MinShaderLOD = 2
    MipFilter = 2
    MultipassTerrainEnabled = True
    ObjectDetail = 80
    ObjectDrawDistance = 120
    OverrideGamma = False
    ProjectedTexturesEnabled = True
    QualityPreset = 5
    ResolutionX = 1024
    ResolutionY = 768
    settingsInitialized = True
    ShadowMapResolution = 1
    ShadowMode = 0
    TerrainDetail = 2
    TerrainDrawDistance = 4
    TextureQuality = 2
    VfxCullDistance = 256
    VFXLimit = 287
    VSyncEnabled = True
    WindowMode = 1

    [Window]
    Maximized = False
    Here are my system specs:

    > Mainboard : PEGATRON CORPORATION VIOLET
    > Chipset : nVidia nForce 720a
    > Processor : AMD Athlon II X2 215 @ 2700MHz
    > Physical Memory : 6144MB (3 x 2048 DDR2-SDRAM )
    > Video Card : ATI Radeon HD 4300/4500 Series
    > Hard Disk : Seagate ST350041 8AS SCSI Disk Device (500GB)
    > DVD-Rom Drive : Hewlett-Packard DVD-RAM GH40L
    > Network Card : Nvidia MCP77 Ethernet
    > Operating System : Windows 7 Home Premium Home Edition Media Center 6.01.7600 (64-bit)
    > DirectX : Version 11.00
    > Windows Performance Index : 4.2 on 7.9
    Now I know my computer isn't top of the line but it also isn't trash. Comparatively speaking the way other resource demanding games run on my PC I shouldn't be having this issue.

    I really want to play this game, I have an inkling that it's actually going to be a very good MMO so I'm begging for help. If anyone can tell me how to fix this I will repay you somehow, and if it's not fixable then I guess it's off to another MMO and im out $59.00
    Last edited by Mijin; 05-05-2011 at 10:04 PM.

  2. #2
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    is that a prebuilt? (hp/emachine/dell)

  3. #3
    Soulwalker
    Join Date
    May 2011
    Posts
    6

    Default

    Quote Originally Posted by ThatTomGuy View Post
    is that a prebuilt? (hp/emachine/dell)
    Yes it is. HP
    Last edited by Mijin; 05-05-2011 at 10:30 PM.

  4. #4
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by Mijin View Post
    Yes it is. HP
    Well there is your answer lol

  5. #5
    Soulwalker
    Join Date
    May 2011
    Posts
    6

    Default

    Quote Originally Posted by ThatTomGuy View Post
    Well there is your answer lol
    Doubtful, if this PC can run games like FFXIV on moderate settings with great performance this game shouldn't be giving me problems like this.

    All I can figure is it's some sort of compatibility issue with this games engine and the ATI Radeon HD 4300/4500 Series.

    I'll acknowledge the fact that HP and everything they produce is worthless but even if this was a custom computer I'm pretty confident I would still be having this issue if I had the same graphics card in it.

    Even though its totally regardless I guess its worth mentioning that anything even remotely HP has been removed from this computer software-wise.

  6. #6
    Telaran
    Join Date
    Jan 2011
    Posts
    77

    Default

    I can't even see what you are trying to show in your screenshot.

  7. #7
    Plane Touched
    Join Date
    Jan 2011
    Posts
    292

    Default

    You could try turning on Anti-Aliasing, though that will murder your performance, moreso in Rift than other games.

    Otherwise maybe mess around with the nVidia control panel, guide Here may help.

  8. #8
    aux
    aux is offline
    Ascendant aux's Avatar
    Join Date
    Jan 2011
    Posts
    2,306

    Default

    There's nothing wrong, that's how Rift looks.

    The game simply doesn't support proper anti-aliasing.
    I'm so BORED

  9. #9
    Rift Chaser elegos87's Avatar
    Join Date
    Apr 2011
    Posts
    346

    Default

    I've got the AnisotropicFiltering set to 8 and AntiAliasing set to 0, but I don't get that pixellation both on distance and on near views... Couldn't it be due to your specific GFX card, your drivers or global settings (i.e. GFX card settings somewhere in your computer)?
    CPU: i7-2600k @ 4.5 Ghz | GPU: GeForce 560 GTX Ti | RAM: 8GB DDR3 @ 1600Mhz 7-9-7-24 | OS: Windows 7 Pro 64bit

  10. #10
    Soulwalker
    Join Date
    May 2011
    Posts
    6

    Default

    Never mind, I had my money refunded. This game is caca. I'd rather play Hello Kitty™ Online than this steaming pile of disaster. I could almost overlook the graphic flaws but then I realized everything else wrong with the game.

    Have fun...

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts