+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17

Thread: increadibly low and unstable fps

  1. #1
    Soulwalker
    Join Date
    Apr 2011
    Posts
    6

    Default increadibly low and unstable fps

    Heya,

    even tho i got a low budget computer id still think that i should get higher performance than i do here are my specs:

    M4A79XTD EVO/USB3
    AMD Phenom II X4 965be + NH-U9B SE2
    4x2GB G-Skill DDR3 1333mhz
    ASUS HD 6870 DirectCU
    Chieftec 650W PSU

    im thinking this problem has to do with my gpu being an ATI card since my fiance is using a GTX460 768mb and her fps is very stable.

    any config setups or something that would help will be appreciated.

  2. #2
    Shadowlander
    Join Date
    Feb 2011
    Posts
    30

    Default

    What settings are you trying to play the game at?
    That system should run it fine as long as you arnt trying to overdo the settings you are using.
    The two systems in my signature run the game on ultra settings (shadows off mind you) and neither of them drop below 29fps. And the 29 fps is only sometimes whilst in a city at a busy time of day.
    Last edited by Dekurgan; 04-10-2011 at 10:32 PM.
    My Boys pride and joy
    COOLERMASTER CM690 MKII ADVANCED CASE : AMD PHENOM II X4 970 BE - OC to 3.9 Ghz : ASUS CROSSHAIR IV FORMULA: DDR3, USB 3.0, SATA 6.0Gb/s : 8GB KINGSTON HYPER-X GENESIS DUAL-DDR3 1600MHz (2 x 4GB KIT) : 2 x 2GB AMD RADEON HD6950 (crossfire) (oc to just below 6970...couldnt quite get it stable any higher ) : 120GB OCZ VERTEX 2 SERIES SSD, SATA 3 Gb/s
    1TB WD CAVIAR BLACK WD1002FAEX, SATA 6 Gb/s, 64MB CACHE (7200rpm) : CORSAIR 1000W PRO SERIES (HX1000) 80+ MODULAR PSU : TITAN FENRIR EVO EXTREME HEATPIPE CPU COOLER : WIN 7 64bit

    My Rift machine
    MAELSTROM T900 BLACK CASE : AMD PHENOM II X6 1100T - OC to 4.0 Ghz on air : ASUS CROSSHAIR IV FORMULA: DDR3, USB 3.0, SATA 6.0Gb/s : 8GB KINGSTON HYPER-X GENESIS DUAL-DDR3 1600MHz (2 x 4GB KIT) : 2GB AMD RADEON HD6970 : 60GB OCZ VERTEX 2 SERIES SSD, SATA 3 Gb/s : 1TB WD CAVIAR BLACK WD1002FAEX, SATA 6 Gb/s, 64MB CACHE (7200rpm) :
    CORSAIR 750W TX SERIES (TX750) 80+ ULTRA QUIET PSU : TITAN FENRIR EVO EXTREME HEATPIPE CPU COOLER : WIN 7 64bit

  3. #3
    Soulwalker
    Join Date
    Apr 2011
    Posts
    6

    Default

    hey cheers for reply, ive tried ultra & high and honestly i didn't see much of a fps difference ( both with shadows off) i can run crysis 2 extreme with playable fps and wow everything max but i guess this problem might be that the game is still new and needs to be patched up or it's a driver issue on my end, gonna try to do clean driver install & put my overclocks on and see if that makes a difference.

  4. #4
    Soulwalker
    Join Date
    Apr 2011
    Posts
    6

    Default

    forgot to add that the resolution is 1920x1080

  5. #5
    Shadowlander
    Join Date
    Oct 2010
    Posts
    36

    Default

    Performance in other games aren't always a good indicator for how it should perform here.

    First Rift runs on a relatively old gameengine, which isn't that optimized to begin with, so some if comes from here.

    Have you checked your temps, your card might be overheating, which will cause unstable FPS and crashes, your PSU might no be able to keep up when the card gets pushed max (Even though you can run Crysis 2, Rift might be pushing the card differently which causes the symptoms to only appear in RIFT)

    Are you drivers up to date, other games may run better on older drivers than others, if you are on newest drivers, have you tried rolling back, the new drivers may have introduced bugs with this game (it happens alot)

    I'm running the game on an I7 920, 950W PSU, 6 GB DDR3, Radeon 5850 and have no problem running on Ultra (Shadows off) constantly at 50-80 FPS only small dips when lots of people are on screen at the same time.

  6. #6
    Soulwalker
    Join Date
    Apr 2011
    Posts
    1

    Default

    I think i have a similar problem:

    System:
    Athlon II x4 2,9 Ghz
    4 gb ram
    Radeon 5500 1 gb ram

    my system is not great, but i can play most actual games smoothly

    but rift is different... i have constant 10-15 fps @ 1600x1200

    ANd Yes its not only on medium details its on low details too ! (not to question that i SHOULD be able to play the game at ultra)

    If i use the ugly low performance renderer my framerate explodes, but who wants to play the game this way if it should be better ?

  7. #7
    Rift Disciple
    Join Date
    Mar 2011
    Posts
    106

    Default

    Quote Originally Posted by MadEd View Post
    I think i have a similar problem:

    System:
    Athlon II x4 2,9 Ghz
    4 gb ram
    Radeon 5500 1 gb ram

    my system is not great, but i can play most actual games smoothly

    but rift is different... i have constant 10-15 fps @ 1600x1200

    ANd Yes its not only on medium details its on low details too ! (not to question that i SHOULD be able to play the game at ultra)

    If i use the ugly low performance renderer my framerate explodes, but who wants to play the game this way if it should be better ?
    i'm not suprised you get that frame rate on that rig.

    that resolution is HUGE for that spec, try bumping it down as the 5500 isn't that great & the CPU will also bottleneck slightly as well.

  8. #8
    Rich Aemry
    Guest

    Default

    Quote Originally Posted by Voryon View Post
    Heya,

    even tho i got a low budget computer id still think that i should get higher performance than i do here are my specs:

    M4A79XTD EVO/USB3
    AMD Phenom II X4 965be + NH-U9B SE2
    4x2GB G-Skill DDR3 1333mhz
    ASUS HD 6870 DirectCU
    Chieftec 650W PSU

    im thinking this problem has to do with my gpu being an ATI card since my fiance is using a GTX460 768mb and her fps is very stable.

    any config setups or something that would help will be appreciated.
    OC your FSB. It's the CPU bottleneck. Gambryo only uses like 50%-70% or so of each core so you have to OC the FSB to give it more to use with that 50%.

  9. #9
    Shadowlander
    Join Date
    Oct 2010
    Posts
    36

    Default

    Quote Originally Posted by Rich Aemry View Post
    OC your FSB. It's the CPU bottleneck. Gambryo only uses like 50%-70% or so of each core so you have to OC the FSB to give it more to use with that 50%.
    When looking a CPU allocation on Multicore CPU's you will rarely see all cores used 100% since that is not always effecient, as allocating and moving tasks between threads and cores has a relatively high cost.

    But of course, OC will help seeing as you are essentially improving the CPU, though his CPU shouldn't really be that bad.

    Mine is an I7 920, at 3.2GHZ and i have absolutely no problems with FPS, so there might be something else going on, so before just overclocking i would go through the other things to see if there is a problem there.

  10. #10
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by Rich Aemry View Post
    OC your FSB. It's the CPU bottleneck. Gambryo only uses like 50%-70% or so of each core so you have to OC the FSB to give it more to use with that 50%.
    Hope his hardware isnt aging and relatively new.

    Age + OC = bad things happen

  11. #11
    Soulwalker
    Join Date
    Apr 2011
    Posts
    6

    Default

    okay well i should have my OC profile for cpu up to 3,8ghz ill enable that today and see if it improves, normally ive disabled the OC since every other game has run perfectly on max settings so far, and temps are not a problem.

    latest ati drivers atm ill test older ones once i get home from work

  12. #12
    Rich Aemry
    Guest

    Default

    Quote Originally Posted by ThatTomGuy View Post
    Hope his hardware isnt aging and relatively new.

    Age + OC = bad things happen
    There aren't any aging 965s out there. That CPU is only 18-20mo RTM.

  13. #13
    Rich Aemry
    Guest

    Default

    Quote Originally Posted by Veryll View Post
    When looking a CPU allocation on Multicore CPU's you will rarely see all cores used 100% since that is not always effecient, as allocating and moving tasks between threads and cores has a relatively high cost.

    But of course, OC will help seeing as you are essentially improving the CPU, though his CPU shouldn't really be that bad.

    Mine is an I7 920, at 3.2GHZ and i have absolutely no problems with FPS, so there might be something else going on, so before just overclocking i would go through the other things to see if there is a problem there.

    It's mainly a K10 and Wolfdale issue. The Gulftown, Nehlam, Lynnfeild, and Sandy Bridge buys aren't really having the weid issues theya re.

  14. #14
    Soulwalker
    Join Date
    Apr 2011
    Posts
    6

    Default

    id also like to point out again that my fiance is running a exactly same setup only difference is she is using GTX 460 768mb version and her RIFT is working properly.

  15. #15
    Shadowlander
    Join Date
    Oct 2010
    Posts
    36

    Default

    Quote Originally Posted by Rich Aemry View Post
    It's mainly a K10 and Wolfdale issue. The Gulftown, Nehlam, Lynnfeild, and Sandy Bridge buys aren't really having the weid issues theya re.
    Oh i see, wasn't really aware that there where specific issues with those families, well guess i learned something today, mind throwing a few links with more information, is always usefull to know more about it.

    Quote Originally Posted by Voryon View Post
    id also like to point out again that my fiance is running a exactly same setup only difference is she is using GTX 460 768mb version and her RIFT is working properly.
    Even though she is running the same setup, you may have faulty chips somewhere, or a heat problem, or driver problem she isn't having, you can't really compare two computers like that as there can be a multitude of things that are not exactly the same.
    But try overclocking a bit and see if that helps as Rich Aemry suggested.
    Last edited by Veryll; 04-11-2011 at 02:58 AM.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts