+ Reply to Thread
Results 1 to 8 of 8

Thread: someone resolve problem with ATI or not?

  1. #1
    Soulwalker
    Join Date
    Jan 2011
    Posts
    2

    Default someone resolve problem with ATI or not?

    Hello,

    i read many forums and many problems with ATI grafic cards with Rift.

    I have same problem, when i play the game i have 25fps, when i change settings to minimum or low render textures, fps is still 25, ultra settings - still about 25fps, i try many things, download drivers, profiles, clean pc, reinstal, change setting in CCC many diferent settings,

    NOTHING help me still about 25fps and when iam in raid or many peoples cast or move around me i have 10fps, with max or minimum grafic settings. I can play Crysis 2 to full details without problem but Rift not

    So if someone can help orTrion can do something with this i will be really happy. Sorry for my english i hope you understand

    My pc is :

    AMD Athlon 64 X2 5200+ (2,7GHz)

    ATI Radeon HD 4870 512MB

    4GB RAM

    Win 7 64bit

  2. #2
    Champion of Telara Ulfhedjinn's Avatar
    Join Date
    Jan 2011
    Location
    United Kingdom
    Posts
    1,142

    Default

    Being someone who just upgraded from a HD 5850 to a GTX 580, I am completely unconvinced that there is any actual issue universal to running this game on ATI hardware. My performance has scaled exactly as expected.


    As for your issues, I'm afraid to say the problem more than likely lies with your CPU. This game makes extensive use of threading its functions to different CPU cores and I saw double the performance with my HD 5850 when I upgraded from a dual core E8400 to a quad core i5 2500K. Overclocking may provide you with a small gain, if you are comfortable with doing that, but an X4 is probably the best thing you can do to boost your performance.
    If at first you don't succeed, threaten to quit unless it's nerfed.

  3. #3
    Soulwalker
    Join Date
    Mar 2011
    Posts
    10

    Default

    check this thread as well, I have been having similar issues.. Mine are resolved, hopefully it will help you.

    http://forums.riftgame.com/showthrea...-11.3-released
    AMD Phenom II X2 555 @ 3.63ghz / 1.275V (220mhz x 16.5x)
    Scythe "KATANA3" w/ Arctic Silver 5
    Gigabyte GA-770TA-UD3 Bios F2
    4GB G.Skill PC3-10700 @ 733Mhz 8-8-8-22-30-2T
    XFX HD-577A-ZNFC Radeon HD 5770 1GB

  4. #4
    Soulwalker
    Join Date
    Jan 2011
    Posts
    2

    Default

    thx for help but it doesnt work

  5. #5
    Telaran
    Join Date
    Feb 2011
    Posts
    79

    Default

    Quote Originally Posted by Mazoku View Post
    thx for help but it doesnt work
    It's most likely your CPU limiting you in very crowded areas. Honestly, that CPU is quite dated and isn't going to fair very well in this game.

    The problem with ATI setups right now stems mostly around crossfire. While there have been some single card issues on both the ATI and Nvidia side (and I'm convinced they are all actually on the Trion side and not the card vendors fualt), most ATI issues are with crossfire support and crossfire scaling. Basically... if you want crossfire to work now you have to use radeonpro to force AFR.

    I haven't had any problems playing the game with a single 4850 or a single 6950. Both of them worked fine. I saw the biggest improvement going from a q6600@3.4ghz to a i5 2500k @ 4.6ghz. Honestly, while I'm glad I went from crossfired 4850's to 6950's for other games... I think I could have stayed with the pair of 4850's and the CPU upgrade for rift and delt with radeon pro until Trion gets their heads out of their butts!

    The game is just poorly optimized. For instance... last night I was doing some mining / herbing in IPP. I was randomly killing some stuff and generally was well into the tripple digit frame rates with most settings maxed (not using any AA and only env shadows... also have clutter density / radius and part effects bumped down a wee bit). A rift spawned behind me (a good ways but it was visible on my screen when I turned around). The spawning caused a momentary drop in my frame rate from 120ish to 30ish (it then returned to 100+ after about 10 seconds). The game looks good... but the random frame rate drops suck. Hell, if I got the frame rate that I get in Meridian everywhere with 100% consistancy I would be just fine (I don't need more than 60FPS). It's when you get 100+ FPS and then it drops to 20-30... then bounces around... thats when I have a problem! When my frame rates drop... it's never because my 2 overclocked 6950's are choking... it's because the CPU is :/

  6. #6
    Plane Walker Kalec's Avatar
    Join Date
    Dec 2010
    Location
    New Westminster
    Posts
    472

    Default

    Quote Originally Posted by Mazoku View Post
    Hello,

    i read many forums and many problems with ATI grafic cards with Rift.

    I have same problem, when i play the game i have 25fps, when i change settings to minimum or low render textures, fps is still 25, ultra settings - still about 25fps, i try many things, download drivers, profiles, clean pc, reinstal, change setting in CCC many diferent settings,

    NOTHING help me still about 25fps and when iam in raid or many peoples cast or move around me i have 10fps, with max or minimum grafic settings. I can play Crysis 2 to full details without problem but Rift not

    So if someone can help orTrion can do something with this i will be really happy. Sorry for my english i hope you understand

    My pc is :

    AMD Athlon 64 X2 5200+ (2,7GHz)

    ATI Radeon HD 4870 512MB

    4GB RAM

    Win 7 64bit
    FOr what you have on your system, is exactly what you would be getting. With a limited of only 512mb ram on your video card, setting higher details will be an issue.
    Now add your CPU, which is old, your system has now became outdated for newer games.

    Playing Crysis 2 on full deatils, you just meet minimum spec, plus its a single player game. You dont have others stuff loading on your system, including network.

    You can still play, but you need to set your settings correctly.
    No clutter, shadows, AA. Your distance will need to be lowered, including objects.
    __̴ı̴̴̡̡̡ ̡͌l̡̡̡ ̡͌l̡*̡̡ ̴̡ı̴̴̡ ̡̡͡|̲̲̲͡͡͡ ̲▫̲͡ ̲̲̲͡͡π̲̲͡͡ ̲̲͡▫̲̲͡͡ ̲|̡̡̡ ̡ ̴̡ı̴̡̡ ̡͌l̡̡̡̡.__

  7. #7
    Rift Disciple
    Join Date
    Mar 2011
    Posts
    110

    Default

    I have an ATI 5750 HD and have no problems with frame rates. I consistently get 50-60 fps. The only thing I adjusted was to turn shadows off. Shadows are a complete waste of gpu and massively affect your frame rate.

  8. #8
    Rift Chaser Blakjak02's Avatar
    Join Date
    Jan 2011
    Posts
    370

    Default

    Quote Originally Posted by Langkard View Post
    I have an ATI 5750 HD and have no problems with frame rates. I consistently get 50-60 fps. The only thing I adjusted was to turn shadows off. Shadows are a complete waste of gpu and massively affect your frame rate.
    Thats what i have as well
    Blakjak
    Liquidus - Defiant - Keenblade

    Message me in the game if you want to chat...

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts