+ Reply to Thread
Results 1 to 9 of 9

Thread: Graphics errors!!

  1. #1
    Soulwalker
    Join Date
    Mar 2011
    Posts
    6

    Default Graphics errors!!

    Hey, I've been getting alot of trouble lately with my graphics. Sometimes objects fail to appear, there will be squares of the ground that doesn't show up, and almost everywhere I go, there's what looks like pillars coming from the ground that go in any direction, but I can go right through them obviously. This has made me disconnect several times as well. I've gotten an error message telling me that my game client might be damaged, but I reinstalled the program and patches and nothing changed. When I turn on the low quality renderer, these problems don't happen anymore, but I was able to run RIFT at maximum graphics settings perfectly fine before the last patch aside from the one released today, being as I bought a new graphics card just for this game. Is anyone else having these problems? If you know how to fix it, please help Also, where the hell is the RIFT recovery thing for the client?

  2. #2
    Ascendant
    Join Date
    Jan 2011
    Posts
    1,471

    Default

    Sounds like your graphics card is overheating & artifacting. Recover button is on the lauhcher itself, you know, the one with the big "PLAY" button.

    List your full system specs.
    2600K@5.3Ghz
    XFX GTX580@960
    28" 1920x1200
    SuperNerd

  3. #3
    Soulwalker
    Join Date
    Mar 2011
    Posts
    6

    Default

    Weird, I don't see it :S And 6gb ram, 2.6 ghz dualcore, 64 bit OS with a 1gb ddr3 video card

  4. #4
    Ascendant
    Join Date
    Jan 2011
    Posts
    1,471

    Default

    Quote Originally Posted by Slaynkri View Post
    Weird, I don't see it :S And 6gb ram, 2.6 ghz dualcore, 64 bit OS with a 1gb ddr3 video card
    If your getting random strange triangles poking out of the game world that's your graphics card artifacting/overheating.

    Like this:
    http://www.google.com.au/images?hl=e...&aqi=&aql=&oq=

    Rift launcher recover button (BUTTON ON THE RIGHT)
    http://media.giantbomb.com/uploads/7...cher_super.jpg
    Last edited by C-BuZz; 03-29-2011 at 04:46 PM.
    2600K@5.3Ghz
    XFX GTX580@960
    28" 1920x1200
    SuperNerd

  5. #5
    Soulwalker
    Join Date
    Mar 2011
    Posts
    6

    Default

    **** yeah. that's exactly what it looks like. What do I do for that? Just turn off the comp for a while or what?

  6. #6
    Soulwalker
    Join Date
    Mar 2011
    Posts
    6

    Default

    and LOL! woooow, how did I not notice that. I guess I just didn't notice the settings button change to recover lmao

  7. #7
    Ascendant
    Join Date
    Jan 2011
    Posts
    1,471

    Default

    Quote Originally Posted by Slaynkri View Post
    **** yeah. that's exactly what it looks like. What do I do for that? Just turn off the comp for a while or what?
    Your graphics card is artifacting, which could mean a few things:

    1) It's faulty get another one, nothing can be done
    2) It's overheating because it's full of dust, take the side of your case off & clean it as much as possible
    3) The heatsink paste has dried out & will need replacing

    I'm leaning towards #1 at this point.
    2600K@5.3Ghz
    XFX GTX580@960
    28" 1920x1200
    SuperNerd

  8. #8
    Soulwalker
    Join Date
    Mar 2011
    Posts
    6

    Default

    Kk thanks for the help.

  9. #9
    Telaran
    Join Date
    Jan 2011
    Posts
    67

    Default Advice

    Slayinkri just a bit of advice before you fly off the handles with what people have told you right now...

    First get a program that can read your temps and compare them to normal temps of the product in question by googling " my product normal temps".

    The reason I say this is that every once in a while Trion "fixes" something in the rendering engine that is not compatible with certain graphics cards. I can play for weeks at 60+fps then some new patch and I get horrendous artifacting. My temps are extremely cool on my GTX460 OC. Hope this helps instead of the panic mode you have crappy hardware posters...

    Submit a ticket:

    https://trionworlds.custhelp.com/

    Put all the information that they tell you to and someone will email you to help you through your problem. I know this method requires patience but its that or 200+ bucks...
    Last edited by Alveon; 03-29-2011 at 05:53 PM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts