+ Reply to Thread
Results 1 to 4 of 4

Thread: New Laptop, Very Troublesome..

  1. #1
    Shadowlander
    Join Date
    Feb 2011
    Posts
    27

    Default New Laptop, Very Troublesome..

    Hey guys, just bought a brand new ASUS G73JW and I've been having some problems. Currently I'm on my last step on how to fix this damn computer/game? It's a weird story, so have patience!

    So I went and bought this laptop, got home and imported Rift from an external harddrive to the new laptop. It didn't have me install Rift but allowed me to play it. I was only getting 7 frames per second, and thats with Ultra graphics which it should definitely play. Anyways, I changed the graphic settings to make sure it just was the graphics setting, and no difference. So I figured it must have been a hardware problem. After calling ASUS they had a few ideas to try, and nothing worked. After bringing the laptop back to the retailer, and getting a brand new one thinking the last had a hardware issue.. I installed Rift the right way, from the website where I had a digital copy (Trion's homepage)

    All was good until it asked me to install directx 9. Having done so, it was close to being finished and popped up with an error. I believe it was a Chrnographic error or something. Anyways, after extensive research and trying multiple ways to fix the problem, I FINALLY came across a solution that actually worked. So having done that step it was fixed, I allowed the 9hour patch download (Argh) and played Rift on Ultra graphics and it was fine!

    But this is where it gets exciting... The next day, my laptop will not open windows. But previously, those steps to try and fix the directx problem, there was a solution posted about deleting a few files, which I believe was the root of the problem, so I System restored to the very beginning to this whole ordeal (you guessed it, the farthest point I could go...) and had to repeat the step that actually worked (which was find the direct x folder, which is actually pretty difficult and delete the certificates in it). After which, since system restoring still had Rift on the laptop, I BELIEVE that I left it on, or at least just deleted the folders and tried again. Anyways, after another 9 hour wait I got the same 7 fps. So at the very end of my sanity I tried wiping Rift completely off the computer, and downloaded from Trion again. Now I'm waiting patiently (Yep, you guessed it... another 9 hours) and hopefully this problem will be finally be done and overwith and I can get back to Shimmersand killing defiants.

    The whole purpose of tis post was to vent a little bit, and hoping someone can shed some light on this. Thanks!

  2. #2
    Ascendant rabb1t's Avatar
    Join Date
    May 2010
    Location
    Bay Area, CA
    Posts
    2,459

    Default

    Are you playing unplugged? It has pretty limited performance with default power settings. I have one, and I'm set to ultra with environmental shadows. I average 20-30 FPS. I don't think it said anything about needing to install DX9.

    Some things you want to do.
    - Delete the hard drive partitions. (Mine was 2x 640 split into 80/240/320/320) note that things want to install to "my programs" which will be where your OS is.
    - Delete the .... I think it's called HybridPower. That's a special Asus power saving thing, but it will interfear with any Windows themes you make. Unless you don't mind it overriding your theme EVERY time you restart.

    And this is a new Core i7 version with AMD mobility 5870 or Nvidia GTX 460M yes? No clue why you'd see 7 FPS plugged in or at higher than 30% power. (Be aware you'll get maybe 45 min play time unplugged. The 17" has horrendously poor battery life.)

    Also DO NOT change your graphic card drivers. It likely will mess it up. If you did, revert.
    Last edited by rabb1t; 03-20-2011 at 09:33 PM.
    **Canceled Oct '11, cannot reply on forums. Contact me through my site.**
    rabb1t.com - pc gaming hardware tech talk for everyone / rabb1t's ramblings podcast
    rabb1t's Gamer Day 2010 After Party videos
    joo can has Rift iPhone 4 and Droid wallpapers


  3. #3
    Shadowlander
    Join Date
    Feb 2011
    Posts
    27

    Default

    Thanks alot rabbit for your input. I'll let you know how it works after it's long download finishes.

  4. #4
    Shield of Telara
    Join Date
    Jan 2011
    Posts
    789

    Default

    well rabb1t he said it was a JW and that means it has a 460M in it. So him installing the latest GPU drivers should have no effect on his machine like it might yours if you didn't do the vbios update like you should have.

    That said it sounds like this has nothing to do with his G73JW in particular and is just another one of those oddball problems with rift.

    I would suggest that you google a usb/dvd tool install of windows 7 and start with a fresh windows 7 with no asus anything on it and then load drivers from the vendors of your hardware rather than Asus. Asus is usually about 3 driver sets behind on average.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts