+ Reply to Thread
Results 1 to 13 of 13

Thread: another video card fail

  1. #1
    Soulwalker
    Join Date
    Mar 2011
    Posts
    5

    Default another video card fail

    same video card as everyone else who can't run it, wondering if GeForce GT 430 would allow me to run it at medium-high settings ?

    SYSTEM SPECS:

    Dell Inspiron 518 desktop
    Intel(R) G33/G31 Express Chipset Family
    3 gigs of ram
    2.4 GHz dual core processor
    300psu...

    75$ budget.... ya im broke get at me

  2. #2
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by Brandoxc View Post
    same video card as everyone else who can't run it, wondering if GeForce GT 430 would allow me to run it at medium-high settings ?

    SYSTEM SPECS:

    Dell Inspiron 518 desktop
    Intel(R) G33/G31 Express Chipset Family
    3 gigs of ram
    2.4 GHz dual core processor
    300psu...

    75$ budget.... ya im broke get at me
    Would need a new power supply.
    A case also if the new one wont fit (can set the power supply on top temporarily if the cords reach till you can afford a new case)

  3. #3
    Soulwalker
    Join Date
    Mar 2011
    Posts
    5

    Default

    i take it im going to need to up the budget , huh ? ):

  4. #4
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by Brandoxc View Post
    i take it im going to need to up the budget , huh ? ):
    Most likely, but not too much, power supplies are 50ish, a decent case is 30-60ish

  5. #5
    Rift Disciple Anyanka's Avatar
    Join Date
    Jan 2011
    Location
    Ft.Bragg, NC
    Posts
    103

    Default

    Quote Originally Posted by Brandoxc View Post
    same video card as everyone else who can't run it, wondering if GeForce GT 430 would allow me to run it at medium-high settings ?

    SYSTEM SPECS:

    Dell Inspiron 518 desktop
    Intel(R) G33/G31 Express Chipset Family
    3 gigs of ram
    2.4 GHz dual core processor
    300psu...

    75$ budget.... ya im broke get at me
    You will probably end up like me an many other people on these forums. You will upgrade your card and be able to put the game on medium settings and get playable fps until you go into a major city, rift/invasion, raid, or dungeon then the game will chew up your CPU and spit it out. The graphics card alone doesnt make this game run well. It seems to need a beefy CPU as well as a decent GPU to be anything resembling playable for anything other then exploring/questing.

    I'm using a Phenom 9500 x4 2.2 GHz and a GeForce 450 GTS and can get 40+ fps questing and drop down into single digits in a raid setting. Doesnt matter if I'm set to medium, low, minimal with all sliders to the left or even low quality renderer. There are people posting here with processors that make mine look like a scientific calculator that have the same issues.
    Last edited by Anyanka; 03-20-2011 at 08:31 AM.
    Doom doom doom doom doomy doomy doom doomy doom doom doom doom doom doom doom doom doom doomy doom

    The Chloro Mantra : "My nukes are my heals... My nukes are my heals.... My nukes are my heals...."~ XtremElement

  6. #6
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by Anyanka View Post
    You will probably end up like me an many other people on these forums. You will upgrade your card and be able to put the game on medium settings and get playable fps until you go into a major city, rift/invasion, raid, or dungeon then the game will chew up your CPU and spit it out. The graphics card alone doesnt make this game run well. It seem to need a beefy CPU as well as a decent GPU to be anything resembling playable for anything other then exploring/questing.

    I'm using a Phenom 9500 x42.2 GHz and a GeForce 450 GTS and can get 40+ fps questing and drop down into single digits in a raid setting. Doesnt matter if I'm set to medium, low, minimal with all sliders to the left or even low quality renderer. There are people posting here with processors that make mine look like a scientific calculator that have the same issues.
    Mine doest get chewed up. I keep my settings down tho and dont try to get more out of it than what i know it will do (not saying you do, just a general observation)

    My specs:

    Amd 64 x2 2.4ghz (dual core)
    2GB ddr 800mhz ram
    Geforece 9800 GTX

    Plays on 1680 x 1050 at 45 fps open world, 30 in dungeons and sometimes dips under 20 in full on boss rift invasions.

  7. #7
    Rift Disciple Anyanka's Avatar
    Join Date
    Jan 2011
    Location
    Ft.Bragg, NC
    Posts
    103

    Default

    Quote Originally Posted by ThatTomGuy View Post
    Mine doest get chewed up. I keep my settings down tho and dont try to get more out of it than what i know it will do (not saying you do, just a general observation)

    My specs:

    Amd 64 x2 2.4ghz (dual core)
    2GB ddr 800mhz ram
    Geforece 9800 GTX

    Plays on 1680 x 1050 at 45 fps open world, 30 in dungeons and sometimes dips under 20 in full on boss rift invasions.
    you are one of the lucky few, and no offense intended, but I dont see how your getting the performance you are when I know people with far better PC's doing less. Have you been in a WarFront with 20 on 20 like Port Scion yet, or tried a 20 man raid?
    Doom doom doom doom doomy doomy doom doomy doom doom doom doom doom doom doom doom doom doomy doom

    The Chloro Mantra : "My nukes are my heals... My nukes are my heals.... My nukes are my heals...."~ XtremElement

  8. #8
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by Anyanka View Post
    you are one of the lucky few, and no offense intended, but I dont see how your getting the performance you are when I know people with far better PC's doing less. Have you been in a WarFront with 20 on 20 like Port Scion yet, or tried a 20 man raid?
    Yep, but its because of a few things.

    I run a clean machine. Very little runs at startup. If i want it running, i click it (my sys tray has 4 icons. Av, network, speaker icon and video icon)
    I dont let my windows install get stale (cluttered registry, old dll's etc) and reinstall windows once per year.

    I keep texture settings to low, keep AA, lighting complexity, shaders low, and shadows off, and all that.
    I do keep terrain distance view up (only one i keep up there really)

  9. #9
    Soulwalker
    Join Date
    Mar 2011
    Posts
    5

    Default

    and a new power supply is a nescessity to run the new video card ?

  10. #10
    Rift Disciple Anyanka's Avatar
    Join Date
    Jan 2011
    Location
    Ft.Bragg, NC
    Posts
    103

    Default

    Quote Originally Posted by ThatTomGuy View Post
    Yep, but its because of a few things.

    I run a clean machine. Very little runs at startup. If i want it running, i click it (my sys tray has 4 icons. Av, network, speaker icon and video icon)
    I dont let my windows install get stale (cluttered registry, old dll's etc) and reinstall windows once per year.

    I keep texture settings to low, keep AA, lighting complexity, shaders low, and shadows off, and all that.
    I do keep terrain distance view up (only one i keep up there really)
    I have everything on minimal with all sliders to the left and i get 40 fps max averaging 34 out exploring, drops to 20 in 5 mans and in mid teens and below in raids. I do everything else you that you say you do, and none of that has any appreciable effect on how this game runs. It gets CPU bound in certain area.

    http://forums.riftgame.com/showthrea...n-high-spec-PC
    http://forums.riftgame.com/showthrea...an-you-help-me
    http://forums.riftgame.com/showthrea...enecking-my-PC
    http://forums.riftgame.com/showthrea...on-high-end-PC

    Again, no offense, but im dubious to you getting the performance you say you are, at least in a raid rift/invasion setting because the links above have people with far better computers who try every setting and tweek and get performance similar to what i experience, yet you aren't. There has to be moor to what you are doing or you are grossly misrepresenting your performance in huge multiperson encounters. Out in the world I perform outstandingly. In a mass group of people I tank hard, and i'm not alone. A powerful CPU is as much a key to this game as a powerful GPU, and thats a fact. Switching out to a better gPU isn't the end all be all fix.
    Last edited by Anyanka; 03-20-2011 at 08:54 AM.
    Doom doom doom doom doomy doomy doom doomy doom doom doom doom doom doom doom doom doom doomy doom

    The Chloro Mantra : "My nukes are my heals... My nukes are my heals.... My nukes are my heals...."~ XtremElement

  11. #11
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by Anyanka View Post
    I have everything on minimal with all sliders to the left and i get 40 fps max averaging 34 out exploring, drops to 20 in 5 mans and in mid teens and below in raids. I do everything else you that you say you do, and none of that has any appreciable effect on how this game runs. It gets CPU bound in certain area.

    http://forums.riftgame.com/showthrea...n-high-spec-PC
    http://forums.riftgame.com/showthrea...an-you-help-me
    http://forums.riftgame.com/showthrea...enecking-my-PC
    http://forums.riftgame.com/showthrea...on-high-end-PC

    Again, no offense, but im dubious to you getting the performance you say you are, at least in a raid rift/invasion setting because the links above have people with far better computers who try every setting and tweek and get performance similar to what i experience, yet you aren't. There has to be moore to what you are doing or you are grossly misrepresenting your performance in huge multiperson encounters. Out in the world I perform outstandingly. In a mass group of people I tank hard, and i'm not alone.
    Could also be the Gamebryo engine not playing nicely with newer hardware. My hardware definately does not fall into that category

    If i had the answer also, i would share so all those people could happily play. Thats why i made my huge tips on how to get help here post. Despite the occasional flame i do, i really do like helping others

  12. #12
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    another video card fail-2011-03-20_095335.jpg

    Tried attatching a pic, hope it didnt thumbnail. Me in sanctum hovering over the icon for fps. 33 fps if it cant be read easily

  13. #13
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Screenshot of my in game settings also

    another video card fail-2011-03-20_095542.jpg

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts