+ Reply to Thread
Results 1 to 9 of 9

Thread: Here is my rig and my FPS

  1. #1
    Rift Disciple
    Join Date
    Dec 2010
    Posts
    105

    Default Here is my rig and my FPS

    Okay, i see a lot of people having serious FPS issue with this game on WAY better rigs then mine so i figured i would share my setup and my in game gfx.

    I'm running Intel(R) Core(TM) Duo CPU 3.0ghz (OC to 3.4ghz)
    Sits 47-57c

    4g DDR2

    GTX 460 SE (OC, Core voltage 1062, Core Clock 850, Shader clock 1700, Memory clock 2000)
    Sits 48-53c

    650W Kingwin PSU

    Vista 64bit (Tweaked)

    My Nvidia control panel is set to App controlled.

    I Dled the Beta drivers of Nvidia so i have version 267.24 (idk if this really made a diff but i felt it did)

    I am running anywhere from 20-40 FPS in sanctum and 40-80 anywhere out in the world and around 35-45 in Rifts.

    My rigs pretty old esp my CPU.

    Screenshots below!

    http://i25.photobucket.com/albums/c81/dawg17o/3.jpg Sanctum

    http://i25.photobucket.com/albums/c81/dawg17o/2.jpg Sanctum Front View

    http://i25.photobucket.com/albums/c81/dawg17o/1.jpg Sanctum Outside

    i just find it odd people are having such huge FPS problems with this game.
    Anyway thought i'd see what people had to say.

  2. #2
    Rift Disciple
    Join Date
    Dec 2010
    Posts
    105

    Default

    I'll bump this once just in case anyone wants to see this.

  3. #3
    Zab
    Zab is offline
    Champion
    Join Date
    Feb 2011
    Posts
    516

    Default

    Yup doesn't really make sense to me either i'm running at max settings with SSAA and i'm achieving ~50 fps pretty much the entire time and i'm not on 1680x1050 reso. Granted my rig is much better overall then yours some people are stating really poor FPS with the newest hardware.

  4. #4
    Champion of Telara Forum Troll's Avatar
    Join Date
    Jan 2011
    Location
    Norcal
    Posts
    1,254

    Default

    Quote Originally Posted by Stinkbag View Post
    Okay, i see a lot of people having serious FPS issue with this game on WAY better rigs then mine so i figured i would share my setup and my in game gfx.

    I'm running Intel(R) Core(TM) Duo CPU 3.0ghz (OC to 3.4ghz)
    Sits 47-57c

    4g DDR2 - Too low / slow for vista.

    GTX 460 SE (OC, Core voltage 1062, Core Clock 850, Shader clock 1700, Memory clock 2000)
    Sits 48-53c - You bought the SE? lol

    650W Kingwin PSU - have fun when it catches fire / breaks the rest of your components.

    Vista 64bit (Tweaked) - Vista. Nuff said.
    You've set your settings to "mediocre" to match your specs. The complaining is coming from people trying to run max settings with specs like yours.

    You also need to say what resolution you run at, as that is a pretty big factor.
    Last edited by Forum Troll; 03-19-2011 at 04:03 PM.
    My computer
    Proud member of the Forum Troll fan club.

  5. #5
    Soulwalker
    Join Date
    Mar 2011
    Posts
    8

    Default Poor FPS on high spec PC

    Its not just you, its the game.

    I've spent the last 4 days trying every conbination of settings and options in order to get the best FPS. My PC is only 4 months old and the spec is:

    Intel i7 950. Overclocked to 4.1Ghz (tested non-overclocked too)
    12GB RAM
    nVidia GTX 580 video card (res 1920x1080)

    With graphic settings on Ultra I can't get more than 45 FPS.

    I have performed numerous Windows 7 installations, with service pack, without service, with all updates, without all updates. With the latest nVidia video driver, with the "stable" video driver. With other applications installed on the PC, with nothing else installed on the PC. And the best FPS I can get is 45!

    This game is disapointing to say the least!
    Last edited by Torrs; 03-19-2011 at 04:04 PM. Reason: res for those who give a damn

  6. #6
    Plane Walker SWTORlooksbad's Avatar
    Join Date
    Jan 2011
    Posts
    464

    Default

    Something else going on with your rig Torrs, same card same rez and I get better fps at max except AF set in drivers and zero in game. AA off because it's not worth it.

  7. #7
    Champion of Telara Forum Troll's Avatar
    Join Date
    Jan 2011
    Location
    Norcal
    Posts
    1,254

    Default

    Yup - something is wrong in your computer Torrs.

    Same card here, I get 50fps with max settings / SSAA enabled. My 580 is overclocked, but still.
    Last edited by Forum Troll; 03-19-2011 at 04:12 PM.
    My computer
    Proud member of the Forum Troll fan club.

  8. #8
    Rift Disciple
    Join Date
    Dec 2010
    Posts
    105

    Default

    Quote Originally Posted by Forum Troll View Post
    You've set your settings to "mediocre" to match your specs. The complaining is coming from people trying to run max settings with specs like yours.

    You also need to say what resolution you run at, as that is a pretty big factor.
    I'm playing at 1440x900 which is what i like. And if i did "max" out the rest of which i don't already have i would still be in playable FPS outside major citys.

  9. #9
    Soulwalker
    Join Date
    Mar 2011
    Posts
    8

    Default

    Quote Originally Posted by Forum Troll View Post
    Yup - something is wrong in your computer Torrs.

    Same card here, I get 50fps with max settings / SSAA enabled. My 580 is overclocked, but still.
    My wife's computer is exactly the same; MB, RAM, Video etc and we get the same FPS (on Ultra) - 45 if we're lucky.

    In other games - pick anything - I get the FPS I would expect from my hardware.
    Last edited by Torrs; 03-19-2011 at 09:28 PM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts