+ Reply to Thread
Results 1 to 3 of 3

Thread: System freezes after patch #18

  1. #1
    Soulwalker
    Join Date
    Mar 2011
    Posts
    3

    Default System freezes after patch #18

    Following the patch, the launcher will let me log in and select Play and the RIFT splash screen will appear followed by my system completely freezing. Sometimes it freezes immediately before my cursor even changes from the windows arrow, sometimes it will switch to the brownish RIFT arrow and sound will start, it's really hit or miss, but I can not get beyond the splash screen now. Anyone else having this issue or have any suggestions on how to resolve it?

  2. #2
    Soulwalker
    Join Date
    Jan 2011
    Posts
    7

    Default

    I have the same issue, after the log in i can play 4-5 min and after the system freeze. Can't even end to model the character. The only thing i can do is a force reboot. I thought was my graphic card a gtx560 but i have this problem only with rift :/ I bought the game yesterday and can't play it. Kinda sucks

  3. #3
    Soulwalker HaCkSwOrD's Avatar
    Join Date
    Feb 2011
    Posts
    11

    Default

    Kind of the same issue here. I have 2 MSI cyclone 460GTX in sli, and had no issues until this patch, now I am freezing on initial game load, or very shortly after load in. Plays fine, no FPS issues. Just goes to black screen and then I have to hit the reset button. Can run a benchmark on ridiculous settings for hours (Heaven ran for 2.5 hours last night) GPU gets to about 75 decgrees, so it is not overheating. Before patch, no issues. Rift is the only game i have problems with at the moment.


    Oh yeah, I forgot. Disable SLI, and problem goes away....
    Last edited by HaCkSwOrD; 03-19-2011 at 03:28 AM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts