+ Reply to Thread
Results 1 to 2 of 2

Thread: 16-18sec disconnect disappointments

  1. #1
    Soulwalker
    Join Date
    Mar 2011
    Posts
    3

    Default 16-18sec disconnect disappointments

    Greetings All,

    I bought this game a week ago today. Installed it and played for about 30minutes, quite nicely and got my first toon to lvl 3. I had to log out for some reason or another. When I came back to play I would get disconnected after 18 secs. I tried to log in several times and each time 16-18secs is the longest I stayed in.

    So I thought ok maybe its my net, but no, world of warcraft still works, did some internet surfing just fine. I restarted the comp, and the same thing happened. So for a WHOLE week now, except for that 30mins i did play for, I have been logging into the character screen just fine, but when i load the character I want to play, I stayed online for 16-18secs. One time I stayed on for around 30secs.

    Needless to say I am very

    I do have a very capable graphics card to run Rift (GTX570), yet I did turn down the graphic settings to minimum to see if this would have an effect. No it didn't.

    I just don't understand.

    Someone else posted they had a similar problem and that they play on-campus, so there-fore using the university internet. Now yes I too live on campus and use the uni net. But if I played alright for a good solid 30minutes, why is now that it is disconnecting in this way?

    I have tried logging in at various times, no change. I even tried to create other toons and on different shards, same thing is happening. So now I have what I thought was a wonderful game, with the 30 days of free game play being wasted and now the game will just remain on the shelf gathering dust.

    very disappointed
    Last edited by Groovy; 03-18-2011 at 08:05 PM.

  2. #2
    Soulwalker
    Join Date
    Mar 2011
    Posts
    3

    Default

    Update*

    Still getting the same disconnects.
    Surely someone in the tech department is aware of this, I just read 3 different posts all relating to 20sec disconnects. This is NOT playable!
    Yes I am 'ing

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts