+ Reply to Thread
Results 1 to 14 of 14

Thread: Patcher not identifying new patch

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Default Patcher not identifying new patch

    Patcher gives me PLAY button but no option to UPDATE. After i click play it trys to load up and says my game is out of date, there might be an update to download... no really?

    I tried the "Recover" option and it says all my files are up to date. This is the first update that it has done this.

  2. #2
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Default

    So I went home and updated, came back to my 1st location and now says:

    "The region you are connecting to has not yet been updated, but will be soon. If you want to play now in this region a full re-downlaod is necessary. Proceed?"

    I haven't changed my region or anything, I'm 2 minutes down the street...

  3. #3
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Default

    So I clicked "Proceed" and re-downloaded and back to problem 1, gets in and says wrong version of the game...

  4. #4
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Default

    So I can apply new update and log in from home, but I cannot from this other location. I can re-download from this other location... So I can access patching servers from here, just not the newest patch. If I patch somewhere else then come here it says it's not updated in this region yet I'm 2 minutes down the street.

    This is ridiculous.

  5. #5
    Sword of Telara corrin's Avatar
    Join Date
    Mar 2011
    Posts
    849

    Default

    Quote Originally Posted by Epik View Post
    So I can apply new update and log in from home, but I cannot from this other location. I can re-download from this other location... So I can access patching servers from here, just not the newest patch. If I patch somewhere else then come here it says it's not updated in this region yet I'm 2 minutes down the street.

    This is ridiculous.
    So let me get this straight: You're patching from one place, trying to patch from another, then trying to patch from the original location again? Herp Derp, ever stop to think that that might be your problem?

  6. #6
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Default

    I don't get how what you said can even happen nor is a problem. If I patch from one location I shouldn't be prompted to patch from another location.

    Facts:
    - I can access the main download server from both locations. The game downloads/re-downloads from either location.
    - I can access the new patch from home (location 2).
    - I cannot access the new patch from location 1. The only problem is access to this most recent patch from this location. I don't see how, if I can access the main game download and all previous downloads/patches, I can't somehow access this latest patch. Normally I'd think it a internet/router problem, but I can download the game and patch the game up to the latest patch BEFORE this most recent one.


    I ran the game fine at "location 1" just before the recent patch. Waited the 30m the servers were down. Attempted to log in, no "UPDATE" button found, just "PLAY." So I click PLAY and it opens the game and tells me the game is out of date, a patch may be required, leave the game and run the patcher...

    So I leave the game and run the patcher again and yet still no "UPDATE" button, just the "PLAY." So I quickly go home (location 2), and open the patcher and then I get an "UPDATE" button. I update and log into the game no problem.

    I go back to "location 1" and run the patcher and now an "UPDATE" button shows, again. When I click it here it tells me: "The region you are connecting to has not yet been updated, but will be soon. If you want to play now in this region a full re-download is necessary. Proceed?"

    No other way into the game. So I clicked the Proceed button from "location 1" and 8+gb re-downloads and the game opens and says I'm "out of date" again.

    I had zero problems before this playing from both locations. Patches applied at one location were applied and whatever location I went after did not matter.
    Last edited by Epik; 03-18-2011 at 08:41 PM.

  7. #7
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Default

    I notice their port forwarding has changed recently... They do not list Port 80 available anymore, wonder if that is the problem for the update server.
    Last edited by Epik; 03-18-2011 at 08:58 PM.

  8. #8
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Default

    So let me get this straight: You're patching from one place, trying to patch from another, then trying to patch from the original location again? Herp Derp, ever stop to think that that might be your problem?
    Also, as another response to this. If Trion allows patching to happen from multiple locations this is a problem on their part. I shouldn't even have the option to patch more than once. If I patch from the first place, I shouldn't have any sort of option to patch again no matter what other location I'm at. I do see this as a problem, but not my problem.

    The question is: Why, if I patch at home am I being prompted to patch again from a different location? Of course it doesn't go through with the patch, as I said, it thinks I'm in a different region suddenly. Why did the game work minutes before hotfix #8 from this location, but after hotfix #8 it doesn't work? There is no problem on my end if the only thing that changed is Hotfix #8 going into effect, unless they changed something with the access to the update server (and/or other servers) that this location has a problem with. Either way, a change was made in Hotfix #8 and I need to find out what it was.

  9. #9
    Sword of Telara corrin's Avatar
    Join Date
    Mar 2011
    Posts
    849

    Default

    Quote Originally Posted by Epik View Post
    Also, as another response to this. If Trion allows patching to happen from multiple locations this is a problem on their part. I shouldn't even have the option to patch more than once. If I patch from the first place, I shouldn't have any sort of option to patch again no matter what other location I'm at. I do see this as a problem, but not my problem.

    The question is: Why, if I patch at home am I being prompted to patch again from a different location? Of course it doesn't go through with the patch, as I said, it thinks I'm in a different region suddenly. Why did the game work minutes before hotfix #8 from this location, but after hotfix #8 it doesn't work? There is no problem on my end if the only thing that changed is Hotfix #8 going into effect, unless they changed something with the access to the update server (and/or other servers) that this location has a problem with. Either way, a change was made in Hotfix #8 and I need to find out what it was.
    I assume you're A) patching the SAME install of Rift because B) you're on a laptop?

  10. #10
    Soulwalker
    Join Date
    Feb 2011
    Posts
    20

    Default

    I assume you're A) patching the SAME install of Rift because B) you're on a laptop?
    You would be correct.

    Problem was fine when i tested it on Monday... Now it happened again with Hotfix #9! Great...

  11. #11
    Plane Walker zwimox's Avatar
    Join Date
    Feb 2011
    Posts
    461

    Default

    When you go down the street are you accessing a public wi-fi network, such as at Barnes&Noble or Starbucks, or is this a private network?
    Ruranak - Cleric - Greybriar - Guardian :: Sacred Haven

    ASrock p67 Extreme6 - i7-2600K @ 4.80Ghz O.C. - 8GB XMS3 - 2x HD6970 - Thermaltake Frio CPU Cooler
    Antec Lanboy Blue - 80GB SSD

  12. #12
    Rift Disciple
    Join Date
    Feb 2011
    Posts
    102

    Angry

    I'm having the same problem with the latest patch. This is my 2nd time experiencing this.

    I do not get an "Update" option and yet when i go into the game, it tells me "You are not running the correct version of this game.... please run the patcher again an update may be on its way!".

    I tried to "recover" a few times and it didnt work. So last night I tried what worked the last time i had this problem: I deleted and reinstalled Rift (and yes I downloaded the 9+ gig patch all over again). However, this has not solved the problem for me.

    I wish Trion would provide some workaround for this - to let us download the patches manually? This is really frustrating. I want to play!!

  13. #13
    Rift Disciple
    Join Date
    Feb 2011
    Posts
    102

    Default

    I give up.

    I'm reinstalling Rift for the 3rd time now. Let's see if this works.

  14. #14
    Champion actionvapor's Avatar
    Join Date
    Mar 2011
    Posts
    574

    Default

    I'm having this issue now too, in addition to my crashing issues
    which are posted here:
    http://forums.riftgame.com/showthrea...ince-new-patch
    and here:
    http://forums.riftgame.com/showthrea...g-forces-reset

    so found some more things I wanted to try to fix the above issue, but now I have a new issue which is this whole patching / region thing
    no matter which region I select I now get:
    region you are connecting to has not yet been updated

    I have found that if you close out and then re-open, it'll let you proceed, but at least for me, it re-runs the whole opening movie and then crashes my system

    Rift is killing me, seriously

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts