+ Reply to Thread
Results 1 to 10 of 10

Thread: Ridiculously slow patch downloads

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Posts
    11

    Default Ridiculously slow patch downloads

    I consistently am downloading the patches at really slow speeds. We are talking 15-20k. I ping fine in game I download from like everywhere at 600k. I am on ATT DSL but live 300ft from my CO so it's not that kind of a thing. I have all the ports forwarded but still getting REALLY REALLY slow speeds. Sometimes dropping to 5k. Just looking for some help.

  2. #2
    Rift Chaser DrakeFS's Avatar
    Join Date
    Feb 2011
    Location
    EST Baby
    Posts
    345

    Default

    same issue my self, Anyone know what ports the patcher uses and If its a torrent or a ddl?
    A Justicar's path is not one of ease. But, hey, we do get to hit stuff.

  3. #3
    Soulwalker
    Join Date
    Jan 2011
    Posts
    6

    Default

    Actually I'm now wondering if it's an AT&T problem. I too have AT&T DSL. I'm actually getting about 1.2KB/sec. Lovely. I was just playing fine. 6 hours remaining on a 50mb patch. Wait. As I'm waiting it just sped up. Woot!

  4. #4
    Shadowlander Cepolation's Avatar
    Join Date
    Jan 2011
    Posts
    40

    Default

    Quote Originally Posted by Clinic View Post
    Actually I'm now wondering if it's an AT&T problem. I too have AT&T DSL. I'm actually getting about 1.2KB/sec. Lovely. I was just playing fine. 6 hours remaining on a 50mb patch. Wait. As I'm waiting it just sped up. Woot!
    I am having the same issue but I use Verizon DSL

  5. #5
    Shadowlander Cepolation's Avatar
    Join Date
    Jan 2011
    Posts
    40

    Default

    Quote Originally Posted by Cepolation View Post
    I am having the same issue but I use Verizon DSL
    So my patcher just jumped up to my normal speeds..fixed itself I guess

  6. #6
    Shadowlander Hambone_Hamlet's Avatar
    Join Date
    Oct 2010
    Posts
    29

    Default

    using Verizon DSL too and getting the slowness

  7. #7
    Plane Touched Plaything's Avatar
    Join Date
    Dec 2010
    Location
    Seattle, WA
    Posts
    245

    Default

    http://forums.riftgame.com/showthrea...Patching-Speed

    Try that. It worked wonders for myself and others.

    <3
    Merintho- Lotham (PvP)

  8. #8
    Shadowlander Adiela's Avatar
    Join Date
    Oct 2010
    Posts
    24

    Default

    I also have the same issue. I have a 50MB fiber pipe and normally takes me about 20 sec to patch. I am sitting at 27 hours right now to patch. Speed and ping test are showing that I my connection to the internet is fine right now. I am looking into the issue further.

  9. #9
    Soulwalker
    Join Date
    Sep 2010
    Posts
    2

    Default

    BUMP! For the last few days all the patches were downloading at 5kb/s, now I am back to 2Mb/s +

  10. #10
    Shadowlander Hambone_Hamlet's Avatar
    Join Date
    Oct 2010
    Posts
    29

    Default

    Quote Originally Posted by Plaything View Post
    http://forums.riftgame.com/showthrea...Patching-Speed

    Try that. It worked wonders for myself and others.
    thanks for the link - updated my host file, had to uncheck Read Only under the Properties first but updated it and now my speed is blazing once again. thanks

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts