This worked for me hopefully it can work for you. I had regular latency 60 ms, and spikes every 20 seconds or so ranging from 2k-250k. Good luck!

I just blocked ports 6520-6540 and now everything has been running just fine.

Control panel->system security->Windows Firewall->left side advanced settings->outbound rules->
New rule->select port->type 6520-6540->block the connection->name and save

I hope it works for everyone else.

Credit to rebeldemon for this find.