+ Reply to Thread
Results 1 to 7 of 7

Thread: Low FPS with 5870 crossfire setup

  1. #1
    Soulwalker cwhite826's Avatar
    Join Date
    Jan 2011
    Posts
    19

    Default Low FPS with 5870 crossfire setup

    Thought I would post here to see if anyone could give me a few ideas to try and fix this. I have 2 sapphire vaporx 5870s in cross fire on a 890fxa-ud5 mobo with 8gig of corsair dominator memory and an AMD Phenom 2 x6 1100t. When I start the game up it goes to about 35 fps which is very low and then goes down to 25 fps about 30 seconds later. The good side is that it never drops below that, unfortunately it never goes above it either. I would think that these 2 cards in crossfire could handle the game at max settings with no problem but for some reason their performance is a bit lackluster here. I have no problems with other games just this one. Like I said the fps goes to about 25 then doesn't change, and that's the wierd part, doesn't matter if I'm in sanctum the middle of nowhere a major rift with tons of people around or a warfront. I am going to try to update the config file for rift to optimize it for multi core processors but I'm not sure what else to try. I would appreciate any help or suggestions you all may have. Thanks.

  2. #2
    Rift Disciple Pitty's Avatar
    Join Date
    Apr 2010
    Posts
    91

    Default

    you have to download radeon pro, and set it to use AFR as the method of crossfire rendering.

    Make sure to take the time to read about how to use Radeon Pro, you have to activate the profile once you create it, and make sure catalyst AI is ON in the CCC.
    Last edited by Pitty; 03-10-2011 at 08:11 PM.
    Server: Laethys, Guild: Nefarious, Char: Ebonella

    my web design: http://www.advancedws.com.au
    I7920, x58 ud3r, 2x5870 crossfire, 3x27"@6080x1080 eyefinity, 6gig, 64&128G SSD, g15, g5, win7x64, hvr2200.

  3. #3
    Plane Touched Krace's Avatar
    Join Date
    Feb 2011
    Posts
    213

    Default Crossfire

    This is for Crossfire only!

    Download RadeonPro and install at your own risk...
    http://www.radeonpro.info/en-US/

    Instructions to recreate:

    Install and open RadeonPro program.
    Add a new Profile and point to rift.exe in your RIFT folder.
    Make sure your profile is highlighted in the left while you make the following changes.
    Go to "Tweaks" and slide the "MVPUMode" slider to the right so it says "Alternate Frame Rendering"

    Make sure RadeonPro is running when you launch Rift.

    One thing i noticed since beta is that the videos don't flicker anymore nor do the pvp maps, now if the world map didn't flicker that would be nice.
    Last edited by Krace; 03-10-2011 at 08:17 PM.

  4. #4
    Ascendant
    Join Date
    Jan 2011
    Posts
    1,471

    Default

    Basically xfire is broken in Rift with no fix as yet.
    2600K@5.3Ghz
    XFX GTX580@960
    28" 1920x1200
    SuperNerd

  5. #5
    Soulwalker
    Join Date
    Mar 2011
    Posts
    6

    Default

    I can confirm that CF does not work, actually I get better performance with a single card then with CF enabled.

    CF does work as I can see the CF enabled sign when I enable it but it doesn't improve frame rates at all.

    Will remove 1 card until its fixed.

    I am running 2x 4890 by the way and my set-ups works fine as I normally get an almost double the fps boost.

  6. #6
    Telaran
    Join Date
    Jan 2011
    Posts
    64

    Default

    radeon pro solves this ... as for now

  7. #7
    Soulwalker
    Join Date
    Mar 2011
    Posts
    6

    Default

    Tested Radeon Pro does not work. not sure if people actually test the performance when they use cross fire/Radeon pro.

    As I stated before Cross Fire works but you do not gain any fps of performance increase with it.
    Last edited by Xuro Deluxe; 03-13-2011 at 09:39 AM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts