+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18

Thread: My mount is riding me.

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Posts
    2

    Default My mount is riding me.

    http://i54.tinypic.com/15ho5qv.jpg


    So after forgetting to dismount after the server went down, and having the collectors mount removed this seems to be what happened.


    I've tried killing myself, using the porticulum. Any ideas how I can fix this?

    Any help appreciated, I dont want a turtle riding me for much longer.

  2. #2
    Soulwalker
    Join Date
    Mar 2011
    Posts
    7

    Default

    I have the same problem too, i can still play like normal but my mount is ontop of me

  3. #3
    Soulwalker greenzy's Avatar
    Join Date
    Dec 2010
    Location
    Sweden
    Posts
    3

    Default

    i also got the issue. cheers ciao and all that
    CPU: i5 650 @ 3.2GHz - GPU: AMD 6850 - HDD: 500GB WD Black x2 - RAM: 4GB CORSAIR DDR3 @ 1600MHz - OS: Windows 7 64bit - Mouse: Mionix Naos 5000 - Mousepad: Mionix Propus 380 - Audio: Creative Tactic 3D Alpha - Display: 24" BenQ V2420H (1920x1080)

  4. #4
    Soulwalker
    Join Date
    Jan 2011
    Posts
    2

    Default Same here

    I have the same problem, as does the creator of this thread:

    http://forums.riftgame.com/showthrea...6836-Model-Bug

  5. #5
    Prophet of Telara MadHouse's Avatar
    Join Date
    Jan 2011
    Posts
    1,189

    Default

    What happens if you enter an area where you're not allowed to mount? Like the main buildings in Sanctum or Meridian?

  6. #6
    Soulwalker
    Join Date
    Mar 2011
    Posts
    14

    Default

    Same problem here.

    If you enter a non-mountable area, it makes no difference. This is because you aren't actually mounted, you are walking around at the base movement speed.

    I tried to fix this problem by purchasing the digital upgrade to the Collector's Edition. However, this has made no difference yet. There is nothing new in my mailbox, I do not have a the special starting bag, etc... don't know who to contact about this.

  7. #7
    Soulwalker
    Join Date
    Feb 2011
    Posts
    2

    Default Fix

    BUY A MOUNT AND RIDE IT!



    Fixed it for me at least.

  8. #8
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by Angelo View Post
    BUY A MOUNT AND RIDE IT!



    Fixed it for me at least.
    this is the fix. If you dont have the plat for a mount you have to open a ticket in game and wait

  9. #9
    Soulwalker
    Join Date
    Mar 2011
    Posts
    14

    Default

    How do you open a ticket in-game?

  10. #10
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Quote Originally Posted by transcend11 View Post
    How do you open a ticket in-game?
    the ? button then submit a ticket tab

  11. #11
    RIFT Fan Site Operator
    Join Date
    Feb 2011
    Posts
    5

    Default Can't command pets while mounted

    As i stated in the other thread you can't command your pet while in this bug.

    "You cannot command your pet while riding a mount."

    A bit annoying for pet classes who often need to have their pet attack an add while they finish of a mob.

  12. #12
    Soulwalker
    Join Date
    Feb 2011
    Posts
    17

    Default

    it would seem to me you guys got a severe case of "save a horse ride a cowboy" going on eh lol

  13. #13
    Telaran
    Join Date
    Jan 2011
    Posts
    77

    Default

    It had to be done:

    In Soviet Russia, mount rides you!

  14. #14
    Shadowlander
    Join Date
    Jan 2011
    Posts
    43

    Default

    Sorry, but this is one of the funnier bugs that I've seen. Of course I likely won't think it's funny if I log in this evening and find I can't control my pet.. >_<

  15. #15
    Soulwalker
    Join Date
    Mar 2011
    Posts
    2

    Default

    Quote Originally Posted by ThatTomGuy View Post
    this is the fix. If you dont have the plat for a mount you have to open a ticket in game and wait
    I have the same problem but some people have a life and dont have that kind of money to throw around. This bug is ******ed and from what I have seen tech support is non existant in this game, might be weeks before it gets fixed.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts