+ Reply to Thread
Results 1 to 14 of 14

Thread: hardwaredetector.exe has stopped working

  1. #1
    Soulwalker
    Join Date
    Mar 2011
    Posts
    1

    Default hardwaredetector.exe has stopped working

    Getting this error. I have just uninstalled and reinstalled. The game is patching now, but
    this happened in my prior installation, and playing caused a "RIFT has stopped working" -type error.

    Any ideas? I am brand new to the game, but not to gaming, so any suggestions or help would be most welcome.
    Last edited by Sithean; 03-01-2011 at 05:28 PM.

  2. #2
    Soulwalker
    Join Date
    Mar 2011
    Posts
    8

    Default

    I am having the same issue. I think its related to my d3dx9_43.dll but I am not sure. When I try to run either the rift.exe or the hardwaredetector.exe I recieve an error stating that my d3dxd9_43.dll file is not for windows or is corrupt. I have downloaded the June 2010 DirectX package from Microsoft, made sure everything was updated, and even deleted the d3dx9_43.dll file and did the online patch and it still would not work. I have spent 8 hours straight trouble shooting and trying to figure this out, but to no avail. No Rift for me until I can figure out what the problem is. I also re-downloaded the entire game (as I purchased it in digital form).

    I really hope someone who is alot better with computers or maybe a new patch can help the ones who are having this issue out.

    Edit: I forgot to mention that when I start the Play Right shortcut and log in and click play, a "Rift has stopped working" error pops up with windows saying it is trying to figure out why. I tried all the shortcuts and .exe files in the Rift folder and nothing has worked.
    Last edited by NotTaken; 03-02-2011 at 12:47 AM. Reason: Added in additional information for clarity

  3. #3
    Soulwalker
    Join Date
    Mar 2011
    Posts
    1

    Default

    the Hardwaredetector dose the same thing for me, but for me when i log in, the screen flashes a few times, and i just get the background visual of the .. i dono what it is, a stone overlook with a pretty blue thing. Anyway, none of the UI shows up. have installed and reinstaled, and the HArdwaredetector crashses instantly. =/

  4. #4
    Soulwalker
    Join Date
    Mar 2011
    Posts
    7

    Default

    im having the same issue

  5. #5
    Soulwalker
    Join Date
    Mar 2011
    Posts
    1

    Default

    Quote Originally Posted by esieane View Post
    the Hardwaredetector dose the same thing for me, but for me when i log in, the screen flashes a few times, and i just get the background visual of the .. i dono what it is, a stone overlook with a pretty blue thing. Anyway, none of the UI shows up. have installed and reinstaled, and the HArdwaredetector crashses instantly. =/
    Exactly the same thing here.

  6. #6
    Ascendant ThatTomGuy's Avatar
    Join Date
    Feb 2011
    Location
    Seattle
    Posts
    2,306

    Default

    Great job at posting such WONDERFUL amounts of information.

    I suggest you all read http://forums.riftgame.com/showthrea...-everyone-here and try again at asking for help.

  7. #7
    Soulwalker
    Join Date
    Mar 2011
    Posts
    3

    Default

    I had the same issue.
    Here is some help without the know-it-all attitude.

    It seems there are components to DirectX 9.0c Rift needs. But if you have DirectX 11 because it came with your version of Windows then Windows Update will think you have it all.

    Do this:
    Download the "DirectX End-User Runtime Web Installer"
    http://www.microsoft.com/downloads/i...dxwebsetup.exe

    Run it. It should find some kind of 'optional SDK developers module' or some other kind of 'what ever' message. It downloads something you don't have that is part of DirectX 9.0c that RIFT needs to run.

    It got mine working. Hope this helps others.

  8. #8
    EJD
    EJD is offline
    Soulwalker
    Join Date
    Jan 2011
    Posts
    21

    Default

    Quote Originally Posted by SeanIx View Post
    I had the same issue.
    Here is some help without the know-it-all attitude.

    It seems there are components to DirectX 9.0c Rift needs. But if you have DirectX 11 because it came with your version of Windows then Windows Update will think you have it all.

    Do this:
    Download the "DirectX End-User Runtime Web Installer"
    http://www.microsoft.com/downloads/i...dxwebsetup.exe

    Run it. It should find some kind of 'optional SDK developers module' or some other kind of 'what ever' message. It downloads something you don't have that is part of DirectX 9.0c that RIFT needs to run.

    It got mine working. Hope this helps others.
    You are a genius, fixed me right up.
    It is a tale told by an idiot, full of sound and fury, signifying nothing.

  9. #9
    Soulwalker
    Join Date
    Apr 2011
    Posts
    20

    Default

    wow, iv been looking for a post like this. dunno why i couldnt find it till now. but im trying the direct x fix as i type. the hardwaredetector just stopped working on me yesterday, has been fine for the past month or so.

  10. #10
    Soulwalker
    Join Date
    Apr 2011
    Posts
    20

    Default

    sadly this didnt work. during the install it says directx setup- an internal system error occured. PLease refert to the DXError.log and Directx.log in your windows folder.

  11. #11
    Soulwalker
    Join Date
    Dec 2010
    Posts
    12

    Default

    Quote Originally Posted by SeanIx View Post
    I had the same issue.
    Here is some help without the know-it-all attitude.

    It seems there are components to DirectX 9.0c Rift needs. But if you have DirectX 11 because it came with your version of Windows then Windows Update will think you have it all.

    Do this:
    Download the "DirectX End-User Runtime Web Installer"
    http://www.microsoft.com/downloads/i...dxwebsetup.exe

    Run it. It should find some kind of 'optional SDK developers module' or some other kind of 'what ever' message. It downloads something you don't have that is part of DirectX 9.0c that RIFT needs to run.

    It got mine working. Hope this helps others.
    Thanks Seanix, going to give this a whirl tonight.

  12. #12
    Soulwalker
    Join Date
    Jun 2011
    Posts
    8

    Default

    I have an identical problem. hardwaredetector fails. When the game launches the screen flashes a few times with different colors then goes to the char select screen but there is no UI just the background.

    I went to dxwebsetup and it says I have the latest version.

    Any tips welcome.

  13. #13
    Telaran
    Join Date
    Jun 2011
    Posts
    63

    Default

    im in the exact same boat as drinkblot and the OP, the dxweb didn't work, told me i already have the equiv or newer version...

  14. #14
    Soulwalker
    Join Date
    Jun 2011
    Posts
    8

    Default Resolved

    I was able to get this resolved by reformatting and reinstalling my OS, then my Nvidia drivers, then DX and then Rift.

    I don't know what screwed the pooch on this but it was a very irritating problem and having to do a hard-drive wipe to fix it really sucked but the deed is done.

    Thanks for the help.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts