+ Reply to Thread
Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By Riane

Thread: [macro] @mouseover not working as intended

  1. #1
    Soulwalker
    Join Date
    Aug 2015
    Posts
    9

    Default [macro] @mouseover not working as intended (Solved)

    Hi there, i've been doing a quick search concerning this but couldn't find anything related to my problem, therefore, please excuse me if it has been already adressed.

    recently while playing healer, as most if not all my heals are macro'ed with the @mouseover modifier, i've noticed that the macro sometime does not work

    to be blunt, most of the time it work fine, and sometime it don't, suddenly the spell decide to not be casted at all. (if self casting is activated it will cast on me though) but my mouse become a hand and if I spam my macro it will target the closest friendly and cast on him, as if I was trying to cast the spell without target and the @mouseover, or out of range target (while in range of course).

    Even with my mouse hovering over the correct raid frame / having the right target highlighted.

    It's not a big deal in small encounters like random nte dungeons, but when you try to quickly respond to a high damage spike and the macro decide to go dafuq, it's kind of a pain.

    can anyone confirm ?
    Last edited by Mielgato; 09-28-2015 at 10:25 PM. Reason: Problem Solved

  2. #2
    RIFT Fan Site Operator Riane's Avatar
    Join Date
    Apr 2011
    Posts
    5,612

    Default

    Personally, I always use @mouseoverui.

    Also, are you using an add-on for your raid frames? If you're using Gadgets then you need to uncheck "Solo" in the raid frame options.

  3. #3
    Soulwalker
    Join Date
    Aug 2015
    Posts
    9

    Default

    I tried to use @mouseoverui but it does not work with raid frames apparently, and I am not using Gadget addon

    how do you do to have @mouseoverui to work with raid frames ?

    (I only have RGM parser and Target casting bar)

  4. #4
    Plane Touched Nehira's Avatar
    Join Date
    Nov 2013
    Posts
    223

    Default

    Quote Originally Posted by Mielgato View Post
    I tried to use @mouseoverui but it does not work with raid frames apparently, and I am not using Gadget addon

    how do you do to have @mouseoverui to work with raid frames ?

    (I only have RGM parser and Target casting bar)
    The @mouseoverui is especially made to only work with raid frames. I suspect you either use the command wrong or you have an error in your macro.
    An example line in a macro would look like this:
    cast @mouseoverui spellname

    Very common are macro errors, if you copy and paste macros or single lines for a macro from websites. These macros often include not visible control characters such as line feed (\n) or carriage return (\r) which cause the macro to not work yet give no error feedback.
    Always try to type the macro manually to make sure that there are no invisible character that don't belong there. If it still does not work please post your whole macro here.
    Nehira@Zaviel
    <The Fires of Heaven>

    Nehira@Hailol
    <Coriolis>

  5. #5
    Soulwalker
    Join Date
    Aug 2015
    Posts
    9

    Default

    I make my macros myself, as anyway most macros on the internet are in english which i'm not neither my game, so I would have to translate and retype everything anyway.

    I did tried cast @mouseoverui putspellnamehere but nothing happens, the hand shows up so spell is correctly loaded, but mouseover does not work. It was the first @mouseover macro I tried anyway and the reason why I moved to @mouseover instead of @mouseoverui

    when I use @mouseover, it basically work on any UI element that highlight ppl / mobs, but when used on raid frame it sometime don't work

    I tried to use gadget, and @mouseover macros does not bug with its raid frames, BUT gadget bug in itself (somethign to do with wtcurrencies-idontknowhat that does not work as intented and make the whole thing go awry, it will work once the problematic file deleted but will still have errors laters on something else anyway, so it's basically unusable for me)

    my macros looks like this

    #show bloom
    suppressmacrofailures
    cast @mouseover bloom

    which work fine, but sometimes not. I basically wanted to know and understand why ?

    i'll try again @mouseoverui with raid frames, maybe I did something wrong at this moment, but as I understand it, if the group isn't raid, i'm stuck with a macro I can't use at all, right ?

  6. #6
    Plane Touched Nehira's Avatar
    Join Date
    Nov 2013
    Posts
    223

    Default

    Quote Originally Posted by Mielgato View Post
    I make my macros myself, as anyway most macros on the internet are in english which i'm not neither my game, so I would have to translate and retype everything anyway.
    I'm from Germany and played a long time on the german client. From my own experience and from what other players with a french client told me can I tell you, that the localization of Rift is horrible. Eventually I switched to the english client and it is much much better. One major problem with the none-english client is/was, that commands, especially for macros, were so inconsistent. Some commands and spell names worked in english and others only in german and some of the translations made no sense at all, so you can not translate it intuitive.
    I suggest you open the macro editor and click on the button "Commands" and make ensure that the commands you wanna use are in the list or if they are there under a different name.

    Another source for not working macros are things like line-of-sight, if there is an object between you and your target. Then you can press your buttons as long as you want, nothing will happen. Same goes for out of range and when you have to face a target to cast a spell on it. There are many reasons why macros refuse to work, but it's not that a certain command like @mouseoverui would be bugged, because the majority of healer and support chars use it every day without a problem.
    Nehira@Zaviel
    <The Fires of Heaven>

    Nehira@Hailol
    <Coriolis>

  7. #7
    Soulwalker
    Join Date
    Aug 2015
    Posts
    9

    Default

    Quote Originally Posted by Nehira View Post
    I'm from Germany and played a long time on the german client. From my own experience and from what other players with a french client told me can I tell you, that the localization of Rift is horrible. Eventually I switched to the english client and it is much much better. One major problem with the none-english client is/was, that commands, especially for macros, were so inconsistent. Some commands and spell names worked in english and others only in german and some of the translations made no sense at all, so you can not translate it intuitive.
    I suggest you open the macro editor and click on the button "Commands" and make ensure that the commands you wanna use are in the list or if they are there under a different name.
    @Nehira, I heard you, I will give a shot with the english client and update. Since the [notactive] modifier does not work either (have to write it in french, even through it is given in english in the command pannel) I think that might be the case

    edit : Problem solved, @mouseoverui wasn't working with french game client, but is with english game client. I now have perfectly working macro !
    Last edited by Mielgato; 09-28-2015 at 10:28 PM. Reason: problem solved

  8. #8
    Soulwalker
    Join Date
    Aug 2015
    Posts
    9

    Default

    I think you are all in for a good laughter.

    So, I did changed the localization of Rift from French to English

    I dont need the inconsistent @mouseover macros anymore @mouseoverui is working perfectly now.

    Will continue playing with the game client in english. Thanks a lot for the advice Nehira !
    Last edited by Mielgato; 09-28-2015 at 10:27 PM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts